WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] [Plugin: Yet Another Related Posts Plugin] Error in Post Editor (6 posts)

  1. Jabawack
    Member
    Posted 2 years ago #

    Plugin works, but i get error in post editor, where there is post related panel:
    Fatal error: Call to a member function get_post_types() on a non-object in \wp-content\plugins\yet-another-related-posts-plugin\class-admin.php on line 237

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. kaszeta
    Member
    Posted 2 years ago #

    I'm seeing this as well. WP 3.3.3 and YARPP Version 3.5.1.

    Plugin is functional, but throws that error on the editing screen.

  3. leviticus
    Member
    Posted 2 years ago #

    I'm seeing this as well, but the plugin still functions.
    WP 3.3.2 and YARPP Version 3.5.1.

  4. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    What version of PHP are you guys using? Does this occur in the YARPP settings page as well?

  5. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    Also, please try this latest beta: http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.5.2b2.zip It fixes an issue which was recently introduced in 3.5.1 or so which affects some users. I'd appreciate your feedback.

  6. kaszeta
    Member
    Posted 1 year ago #

    The beta fixes the issue for me.

    (And I'm running on PHP 5.3.13)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic