WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[Plugin: Yet Another Related Posts Plugin] Error during upgrade/install (3 posts)

  1. Dougal Campbell
    Member
    Posted 3 years ago #

    I've been seeing a recurring problem for a while. When I try to upgrade yarpp, I get an error along these lines:

    `Warning: filesize(): stat failed for ssh2.sftp://Resource id #520/var/www/vhosts/dougal.gunters.org/wordpress/wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po in /var/www/vhosts/dougal.gunters.org/wordpress/wp-admin/includes/class-wp-filesystem-ssh2.php on line 305 Warning: filemtime(): stat failed for ssh2.sftp://Resource id #520/var/www/vhosts/dougal.gunters.org/wordpress/wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po in /var/www/vhosts/dougal.gunters.org/wordpress/wp-admin/includes/class-wp-filesystem-ssh2.php on line 300 Warning: file_get_contents(): Unable to open ssh2.sftp://Resource id #520/var/www/vhosts/dougal.gunters.org/wordpress/wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po on remote host in /var/www/vhosts/dougal.gunters.org/wordpress/wp-admin/includes/class-wp-filesystem-ssh2.php on line 155 Warning: file_get_contents(ssh2.sftp://Resource id #520/var/www/vhosts/dougal.gunters.org/wordpress/wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po): failed to open stream: Success in /var/www/vhosts/dougal.gunters.org/wordpress/wp-admin/includes/class-wp-filesystem-ssh2.php on line 155 Warning: file_get_contents(): Unable to open ssh2.sftp://Resource id #520/var/www/vhosts/dougal.gunters.org/wordpress/wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po on remote host in /var/www/vhosts/dougal.gunters.org/wordpress/wp-admin/includes/class-wp-filesystem-ssh2.php on line 155 Warning: file_get_contents(ssh2.sftp://Resource id #520/var/www/vhosts/dougal.gunters.org/wordpress/wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po): failed to open stream: Success in /var/www/vhosts/dougal.gunters.org/wordpress/wp-admin/includes/class-wp-filesystem-ssh2.php on line 155 Warning: filesize(): stat failed for ssh2.sftp://Resource id #520/var/www/vhosts/dougal.gunters.org/wordpress/wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po in /var/www/vhosts/dougal.gunters.org/wordpress/wp-admin/includes/class-wp-filesystem-ssh2.php on line 305 Warning: filemtime(): stat failed for ssh2.sftp://Resource id #520/var/www/vhosts/dougal.gunters.org/wordpress/wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po in /var/www/vhosts/dougal.gunters.org/wordpress/wp-admin/includes/class-wp-filesystem-ssh2.php on line 300
    Could not copy file. /var/www/vhosts/dougal.gunters.org/wordpress/wp-content/plugins/yet-another-related-posts-plugin/lang/yarpp-pt_PT.po

    Plugin install failed.

    </blockquote>
    
    What I've just found is that in my <code>wp-content/upgrade/yet-another-related-posts-plugin.tmp/yet-another-related-posts-plugin/lang/</code> directory, there is a file named 'yarpp-pt_PT.po
    with a [space] character actually at the end of the filename.

    Has anybody else seen this?

    I've had to download the zip and install manually, in order to work around this.

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. Dougal Campbell
    Member
    Posted 3 years ago #

    Gah. Sorry about the bad formatting. I guess the forums don't like code inside a blockquote.

  3. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm... there was an issue recently (beginning in 3.2) with the pt_PT localization file I accepted having a bad encoding or somesuch, which I've fixed on trunk (the latest dev version), so will be included with the next version. There isn't a good way for you to try the WP updater with that dev version, though... :/

    I wonder how common this issue is... if it's common, I may just want to push 3.2.2 with the following:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.zip

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic