WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] [Plugin: Yet Another Related Posts Plugin] Different results on a local install and online (4 posts)

  1. fzilbermann
    Member
    Posted 3 years ago #

    Hello,

    I first installed on the local installation ( XAMPP ) of the site I manage and it worked wonderfully after tweaking it a bit with the options provided. I then naturaly installed YARPP on the online site which is the same ( same files, same database but only online ) site. And the results are not the same at all. It seems that online the results returned are very weird. For example localy if a post of a tutorial is displayed, naturally the related posts returned by YARPP are tutorials ( eight of 'em, well all , with a score of about 10 to 20). Online no tutorial is returned, only 2 posts not really related with a score of 9 and 6.

    I'm very puzzled by this behavior, I double checked to make sure every option is the same localy and online, I tried &action=flush to reset the cache but no success.

    If someone can hint me to something, I'm rather sad, I was so glad YARPP worked so well !

    Thanks

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. fzilbermann
    Member
    Posted 3 years ago #

    I somehow managed to find how that happened looking at the yarpp tables in the database. The keyword cache table was filled with strange keywords, readable but clearly related to the Podcasting plugin I have installed. The local database table looked good with efficient keywords.

    The thing is localy I disabled automatic insertion of podcast after content ( because I don't need it anymore, I make the content display on somewhere on the page and the podcast video elsewhere ) but online I left it as it was although I was using the same technique to display content and video.

    I think somehow Yarpp was analysing the content containing the podcast instructions and was mistaken with that. Itried to tweak the priority level of 'add_filter("the_content")' of Podcasting which was, as expected lower than Yarpp's but it didn't worked.

    Well anyway putting Podcasting's "Player Location" setting to "Manual" is solving my issue so I guess I won't investigate any further.

  3. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 3 years ago #

    Great. What podcasting plugin was conflicting?

  4. fzilbermann
    Member
    Posted 3 years ago #

    Podcasting :-D

    I mean "Podcasting plugin"

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic