WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] [Plugin: Yet Another Related Posts Plugin] Database Errors Upon Activation (8 posts)

  1. SooBahkDo
    Member
    Posted 1 year ago #

    Hello,

    Great plugin!

    Just installed it on a multisite installation with about 60 sites and it works great except for one thing.

    When activating it network wide the server error logs begin filling up with these messages from each and every site on the network UNTIL a user accesses the plugin settings on each individual site and SAVES them, After that everything is happy and no more database errors in the logs. :)

    I tested this over several days by visiting various sites on the network and saving the YARP settings then monitoring the server logs the next day and in every case the errors disappeared for sites where a settings SAVE had occurred.

    Sidebar: In yellow notification box above the plugin settings box a brief message flashes that the YARP database had an erro rhar has been fixed.

    On a single site when a user activates YARP they probably go straight to it and save their settings as soon as it is activated, but on a multisite network if the super admin network activates it for all sites it could be weeks or months or never before other users even bother to explore the plugin much less activate it and save settings and until they do the server error logs are being flooded with errors.

    Could the plugin activation process perform a DEFAULT SAVE so that network wide activation on multisite would not flood the error logs?

    We had another WPMUDEV plugin behaving similarly upon network activation and after a half dozen reporting cycles with the developer, they finally got it resolved.

    Thanks for considering this.
    Phil D

    ********************************************

    This is one set of errors that appear in the logs when activating the plugin network wide on a multisite installation and which repeat until a YARP settings SAVE occurs then they do not occur anymore: (this set appears for every site on the network)

    [13-Sep-2012 03:05:02] WordPress database error Table 'soobabiz_soo1035702463884.wp_105_yarpp_related_cache' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'translation_ops' AND site_id = 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/blogs-mu/single.php'), the_content, apply_filters('the_content'), call_user_func_array, YARPP->the_content, YARPP->display_related, YARPP_Cache->enforce, YARPP_Cache_Tables->is_cached
    [13-Sep-2012 03:05:02] WordPress database error Table 'soobabiz_soo1035702463884.wp_105_yarpp_related_cache' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'translation_ops' AND site_id = 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/blogs-mu/single.php'), the_content, apply_filters('the_content'), call_user_func_array, YARPP->the_content, YARPP->display_related, YARPP_Cache->enforce, YARPP_Cache_Tables->update, YARPP_Cache_Tables->related
    [13-Sep-2012 03:05:02] WordPress database error Table 'soobabiz_soo1035702463884.wp_105_yarpp_keyword_cache' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'translation_ops' AND site_id = 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/blogs-mu/single.php'), the_content, apply_filters('the_content'), call_user_func_array, YARPP->the_content, YARPP->display_related, YARPP_Cache->enforce, YARPP_Cache_Tables->update, YARPP_Cache->sql, YARPP_Cache_Tables->get_keywords
    [13-Sep-2012 03:05:02] WordPress database error Table 'soobabiz_soo1035702463884.wp_105_yarpp_keyword_cache' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'translation_ops' AND site_id = 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/blogs-mu/single.php'), the_content, apply_filters('the_content'), call_user_func_array, YARPP->the_content, YARPP->display_related, YARPP_Cache->enforce, YARPP_Cache_Tables->update, YARPP_Cache->sql, YARPP_Cache_Tables->get_keywords, YARPP_Cache_Tables->cache_keywords
    [13-Sep-2012 03:05:02] WordPress database error Table 'soobabiz_soo1035702463884.wp_105_yarpp_related_cache' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'translation_ops' AND site_id = 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/blogs-mu/single.php'), the_content, apply_filters('the_content'), call_user_func_array, YARPP->the_content, YARPP->display_related, YARPP_Cache->enforce, YARPP_Cache_Tables->update
    [13-Sep-2012 03:05:02] WordPress database error Table 'soobabiz_soo1035702463884.wp_105_yarpp_related_cache' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'translation_ops' AND site_id = 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/blogs-mu/single.php'), the_content, apply_filters('the_content'), call_user_func_array, YARPP->the_content, YARPP->display_related, YARPP_Cache->enforce, YARPP_Cache_Tables->update, YARPP_Cache_Tables->related
    [13-Sep-2012 03:05:02] WordPress database error Table 'soobabiz_soo1035702463884.wp_105_yarpp_related_cache' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'translation_ops' AND site_id = 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/blogs-mu/single.php'), the_content, apply_filters('the_content'), call_user_func_array, YARPP->the_content, YARPP->display_related, WP_Query->query, WP_Query->get_posts

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    @SooBahkDo thanks for reporting this! I really appreciate it as I haven't run YARPP network wide myself.

    I figured out the source of this and just created a new beta which addresses this issue. I'd appreciate it if you could test it and see if it takes care of this issue... if all your sites now have gone through the YARPP settings page, you should be able to easily test this also by creating a new site.

    Here's the new beta:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.5.3b3.zip

    Thanks again for the report!

  3. SooBahkDo
    Member
    Posted 1 year ago #

    Hello Mitcho,

    Thanks for your prompt response.

    Glad to give it a test run, but I am encountering a file not found message trying to download the beta from the link above.

    Phil D

  4. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

  5. SooBahkDo
    Member
    Posted 1 year ago #

    Got it!

  6. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    Did that take care of the issue?

  7. SooBahkDo
    Member
    Posted 1 year ago #

    Hello Michael,

    Sorry for the delayed response.

    Unfortunately this issue persists.

    When the plugin is network activated then newly created blogs generatre a flood or error log messages blogs until the settings area is visited and saved. Afterwards all works fine, but until then the error logs get flooded.

    Thanks,
    Phil D

  8. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    @SooBahkDo thanks for the update. Sorry this hasn't been resolved.

    Are the errors you're getting the same as above? Could you post the new errors you're getting now? I'd like to try to make sure this issue gets resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic