WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] [Plugin: Yet Another Related Posts Plugin] 3.51 - error Call to a member function (11 posts)

  1. Martin
    Member
    Posted 2 years ago #

    Hi,

    Running latest 3.51 and getting this error on the post edit page:

    Related Posts:
    Fatal error: Call to a member function get_post_types() on a non-object in /home/xxxxxx/public_html/gajwp/wp-content/plugins/yet-another-related-posts-plugin/class-admin.php on line 237

    Any ideas?

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the report! Was this being displayed in the "related posts" metabox on the edit post screen? Or someplace else? Regardless, I believe I've fixed it in this beta:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.5.2b1.zip

  3. Martin
    Member
    Posted 2 years ago #

    Yeah, displayed in the meta box

  4. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 2 years ago #

    Great. Please do check whether that beta fixes it.

  5. Truth
    Member
    Posted 2 years ago #

    ^ 3.5.2b1 fixed the problem. Thanks!

  6. Evan Jacobs
    Member
    Posted 2 years ago #

    The beta fixed it for me as well.

  7. Decio
    Member
    Posted 2 years ago #

    Fixed here as well.

  8. Jeff Lambert
    Member
    Posted 2 years ago #

    Ah, missed that you had a beta fix for this as I was having this problem about two months ago. Applied it to my site and it fixed the problem.

    So, I'm updating a client that I've left back a few versions because of this error. Is this beta stable enough to push to a production site?

  9. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, that beta is stable.

    There is a more recent beta which fixes other issues as well, though: http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.5.2b2.zip . I'd appreciate any help with testing that new version too.

  10. aceintowson
    Member
    Posted 1 year ago #

    The command buttons (underline, bold, etc.) no longer appear on the edit page and the page's content is in html code rather than in visual. I've read in other threads that I should switch to "visual" mode but there is no "html/visual" button either. I'm using 3.51 and assume it was an earlier version that I was using when I wasn't having any problems with editing. Any suggestions?

  11. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    @aceintowson I'm sorry, your issue sounds completely unrelated to what has been discussed here. Please open a new thread.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic