WordPress.org

Ready to get started?Download WordPress

Forums

XML Sitemap & Google News feeds
[resolved] [Plugin: XML Sitemap Feed] Stylesheet CSS problem? (20 posts)

  1. G
    Member
    Posted 3 years ago #

    When I updated to latest version of xml sitemap feed 3.8, on WordPress MU 3, I was getting error for stylesheet on all my sites. The sitemap would not show, just css error.

    I resolved this by replacing reference to stylesheet in ver 3.8, with that of my previous ver 3.6.1. Now all sitemaps work fine.

    Replace in ver 3.8, line 12:
    <?xml-stylesheet type="text/xsl" href="'.XMLSF_PLUGIN_URL.'/sitemap.xsl.php?v='.XMLSF_VERSION.'&uri='.str_replace(get_option('home'),"",XMLSF_PLUGIN_URL).'"?>

    with this:
    <?xml-stylesheet type="text/xsl" href="'.get_option('home').'/'.str_replace(ABSPATH,"", XMLSF_PLUGIN_DIR).'/sitemap.xsl.php?v='.XMLSF_VERSION.'"?>

    http://wordpress.org/extend/plugins/xml-sitemap-feed/

  2. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Yes, there seems to be some problem with the & amp; in the stylesheet URL for some sites. Do you have any plugin like WP Minify or W3 Total Cache that enables minify on your site by any chance? As far as I can tell, that is the only commonality between the sites that show this problem.

    If you can give me a URL to your sitemap, I can take a look. Hopefully I can pin this weird issue :)

  3. Michael Bishop

    Posted 3 years ago #

    I'm not using any minify plugin and am experiencing the issue as well. Still sorting out other legacy sitemap files so I'm not ready to give any links.

  4. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    If you wish to keep the URL private but still would like me to take a look, you can send it to me via the contact form on http://4visions.nl/contact/ :)

  5. G
    Member
    Posted 3 years ago #

    Thanks RavanH for your emails/tips, I tried the latest 3.8.3 but still had same problem. Reverted to my above hack, and it works fine.

  6. G
    Member
    Posted 3 years ago #

  7. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    In the latest revision, I've completely done away with that & part of the stylesheet URI so the next update should work for you without having to hack again :)

    Thanks for your input!

  8. G
    Member
    Posted 3 years ago #

    hacked again the 3.8.5

  9. Frederick Townes
    Member
    Posted 3 years ago #

    Just wanted to note that W3TC does not minify .xml files by default.

  10. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    @Frederick
    In the case of XML Sitemap Feed, it's not a file but a feed... Does W3TC minify feeds?

  11. Frederick Townes
    Member
    Posted 3 years ago #

    Only when the option is selected on the page cache settings tab and the XML is generated dynamically.

  12. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    So that option is not set by default? Could you give me a (very) short description of which option (and where) a W3TC user should check to get caching of the dynamic XML feed? And I suppose that the cache is cleared upon each new publication?

    I do not use W3TC myself but I'd like to include it in the FAQ's of XML Sitemap Feed :)

  13. Frederick Townes
    Member
    Posted 3 years ago #

    There's an checkbox option on the page cache settings tab to cache feeds. They will expire according to the expires field value on the browser cache setting for HTML.

  14. G
    Member
    Posted 3 years ago #

    I tried hacking the new 3.8.7, no joy, same problem. I will stay with my hacked 3.8.5 for now.

  15. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Hi G, could you re-download http://downloads.wordpress.org/plugin/xml-sitemap-feed.3.8.7.zip (not the 3.8.7 version you downloaded before) and install that in your mu-plugins dir to see if it works now? If not, please wait with reverting to your hacked version and let me know so I can take a look at the incorrect URL output that is being generated... Thanks :)

  16. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    I've (finally) been able to reproduce the problem on another server running Apache 2.2.3 and PHP 5.1.6 on linux CentOS (no idea which version)... Any similarities with the server you are using? This looks like a bug in the WP internal function plugins_url() when installed in mu-plugins :(

    If I can find any hints about why/when this is happening, I can file a bugreport.

    Meanwhile, I applied your hack to my plugin. The latest 3.8.7 should be working on your server too :)

  17. G
    Member
    Posted 3 years ago #

    Hi RavanH, done as you suggested, still error. I will leave it as is for you to see, tell me what you think.

    http://gnetwork.com.au/sitemap.xml

  18. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Somehow, the intended changes did not make it into the zip... yet... No idea why. It's in SVN but not in the download, even after more than 20hours. Strange...

    I'll post a message when the zip with the development version has been correctly updated by the WP.org server.

    Thanks for you patience :)

  19. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

  20. G
    Member
    Posted 3 years ago #

    your 3.8.8 is a screaming success! lovely, thankyou.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic