WordPress.org

Ready to get started?Download WordPress

Forums

XML Sitemap & Google News feeds
[resolved] [Plugin: XML Sitemap Feed] Sitemap not working for all sites on WP Multisite (2 posts)

  1. hauruapai
    Member
    Posted 3 years ago #

    Hi,

    I have this plugin installed on a mulitsite WP using sub domains.

    On the main site http://inthenewsheadlines.com/sitemap.xml it does not give any URLs

    On http://naturaldisasters.inthenewsheadlines.com/sitemap.xml it gives errors

    On http://tennis.inthenewsheadlines.com/sitemap.xml it is fine as with most of the other sub domains.

    It is installed as Network Activate

    when viewed in a browser the sitemaps that show errors are also showing no URLs in Webmaster tools as well as the red x

    How can this be fixed?

    Thank you for your time.

  2. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    Looking at your main site, I notice the articles are all gathered from sub-sites. This would result in an XML Sitemap containing urls that are considered as 'outside' urls, which would make the sitemap invalid. But the fact that even the home URL is missing, suggest there is another problem occurring somewhere along the line...

    Do you have access to your servers error log files? If so, do you see any messages in the PHP error log after trying to load the sitemap?

    The error showing in sitemap http://naturaldisasters.inthenewsheadlines.com/sitemap.xml indicates your server needs more PHP memory to process all the posts on that sub-site. Do you know how much memory is allowed for PHP processes on your server?

    You are not the only one encountering this error so I have a workaround in the development version (3.9) that tries to increase the memory limit to 128MB (if not already that high) but it depends on your hosts setup if the increase is accepted. Also, 128MB might even be too little on some VERY large sites... Could you upgrade to the Development version on http://wordpress.org/extend/plugins/xml-sitemap-feed/download/ and let me know if that solves the issue?

    To increase the memory limit manually - depending on your providers server setup - you have several options:
    1. Increase the memory_limit value in your php.ini file to 128M ( see example tutorial for BlueHost users on http://tutorials.bluehost.com/memory/ )
    2. Add php_value memory_limit 128M to your .htaccess file.
    3. Add define('WP_MEMORY_LIMIT', '128M'); to your sites wp-config.php file.
    (example uses 128MB as limit, adjust if needed)

    Cheers :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic