WordPress.org

Ready to get started?Download WordPress

Forums

XML Sitemap & Google News feeds
[Plugin: XML & Google News Sitemap Feeds] Empty sitemap but sitemap-news works (5 posts)

  1. Floyd-out
    Member
    Posted 2 years ago #

    Hi,

    I've just installed the plugin, and the Sitemap for news works great (http://www.topito.com/sitemap-news.xml) but the general Sitemap does not work : http://www.topito.com/sitemap.xml (same here http://www.topito.com/?feed=sitemap)

    It's a basic installation of wordpress (no multi-site, no sub-directory) and I've tried to disable W3 total cache plugin and re-validate permalinks.

    Any idea how I could fix this ??

    Thanks for your help,

    http://wordpress.org/extend/plugins/xml-sitemap-feed/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Somehow, there is an internal server error occurring when the sitemap request is processed. Do you have access to error logs on your server or hosting account?

    Just to make sure, could you temporarily switch off the feedburner redirect? To make sure that is not causing interference...

    I'd like to ask you to install the latest development version and test again. If the error still occurs, please let me know.

  3. Floyd-out
    Member
    Posted 2 years ago #

    If I display errors in wp-config.php ( @ini_set('display_errors',1); ), then I don't have internal server error but the sitemap.xml is empty (code source empty).

    I tried to turn off feedburner redirect, but nothing happened.

    I've installed the development version and it's even worst : nothing works !

    - 404 error pages on http://www.topito.com/sitemap.xml and http://www.topito.com/sitemap-news.xml (I tried to re-save the permalinks settings)
    - error message "sitemap is not a valid feed"on this url http://www.topito.com/?feed=sitemap
    - no sitemap in the robots.txt

    I've tried to disable W3 total cache plugin and clear my cache, but that doesn't change anything...

  4. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Could you resave your permalink structure? Go to R├ęglages > Permaliens and save the settings without changing anything.

  5. Floyd-out
    Member
    Posted 2 years ago #

    I already did that but that doesn't work neither.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic