WordPress.org

Ready to get started?Download WordPress

Forums

XML Google Maps
gpx with removed tags is not working after edit from GPSprune (3 posts)

  1. SyncPulse
    Member
    Posted 2 years ago #

    Hello community this example is working
    one by one copy from android phone from the open gps tracker
    http://borisschmidtdyn.dyndns.org/GPSlogs/Track201203111336.gpx
    this copy edidited and exported by GPSprune (Linux Ubuntu 12.04LST)not
    http://borisschmidtdyn.dyndns.org/GPSlogs/Track201205271132_cut.gpx
    but the file works fine as drop down to google earth.

    fine: http://borisschmidtdyn.dyndns.org/wordpress/?page_id=7
    bad: http://borisschmidtdyn.dyndns.org/wordpress/?page_id=11

    some one a hint what to inside the gpx export?

    the kmz export is no alternaitve (also not working) from GPSprune because of speed and atitude profiles ..

    http://borisschmidtdyn.dyndns.org/GPSlogs/Tour1.kmz

    open for any advice
    ...ist there a file size size limit at google ..i didnt read this funny 2 hours waste time disclamer for my api api key in every detail?

    The OSM html cmd line is a very welcome feature

    Regrads SyncPulse ... Boris

    http://wordpress.org/extend/plugins/xml-google-maps/

  2. SyncPulse
    Member
    Posted 2 years ago #

    My file has more then 1MB but the switch to Mode 2 SAX inside the plugin did not work!

    Is there someting addional to install like Java ?
    http://www.saxproject.org/

    I tested some other plugins (not working out of the box) but this plugin has a nice speed diagramm feature. So I want to go with xml-google-maps!

    If I switch to Mode2

    Defines the GPX parse mode. To clear database content for Mode 2 simply switch this option an press save. Then reswitch this option and resave!
    Mode 1 DOM is a life time parsing and loads always the whole GPX file into your PHP application memory. For larger files you will often get an out of memory exception because of this (if your memory maximum is at 32mb, this happens already with files a little bit larger than 1mb).
    Mode 2 SAX reads the GPX file sequentially and saves all needed data into the database. For showing the map and all the other charts and tables, the plugin reads the data from the database (if file updatetime get changed, there will be a reparse). With the database its is no longer necessary to load always all the data. With this mode you get a really large database.

    This error is posted: Cannot get modified date from the file you like to parse! Like this, it is not possible to use this file that way!

    GPX Parse Mode 2 Max Rows Limit: 2000 or higher didnt change anything

    Regrads SyncPulse

  3. SyncPulse
    Member
    Posted 2 years ago #

    php.ini

    increasing the upload mode to more then factor x10 at /etc is no progress inside /etc

    php5/cli/php.ini:post_max_size = 80M
    php5/apache2/php.ini:post_max_size = 80M ..this should be the right one after restart of apache2 but any way ..more is better when time is less

    php5/cli/php.ini:upload_max_filesize = 20M
    php5/apache2/php.ini:upload_max_filesize = 80M

    so I will reduce it again later by factor 10
    still only mode 1 is working see first post => link = fine

    mode 1 ok
    mode 2 same error ..and i can see that data is uploaded to google!

    by the way bad forum admin you can only edit your last posting.. facebook style ...!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.