WordPress.org

Ready to get started?Download WordPress

Forums

XmasB Quotes
Cyrillic languages (6 posts)

  1. Den999
    Inactive
    Posted 3 years ago #

    hahaha, this version of the plugin is also no support for Cyrillic languages

  2. Den999
    Inactive
    Posted 3 years ago #

    look:

    Статистика Последние 5 добавленных цитат

    *
    ????????
    ???
    *
    ?????????? ????? ????????

    and:

    XmasB Quotes

    Число цитат: 2

    *
    ?????????? ????? ????????
    *
    ????????

  3. XmasB
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Den999,

    can you please give more details about this issue? I believe the reason for the missing support could be because the plugin uses a few methods for escaping certain characters that could cause problems with the HTML and also with the database. Do you use Cyrillic for the rest of your blog? I can try to debug my plugin to see where it fails. Hopefully I will find a solution for it.

  4. Den999
    Inactive
    Posted 3 years ago #

    Hi

    I have a blog in Russian langiage. Probably you need to enable "UTF-8" in the plugin.
    In addition, the description of the fields in your plugin is correctly in Russian.
    Example: Статистика Последние 5 добавленных цитат

    I think, u need to do this: copy some russian (or other cyrilics) in you clipboard and past in in your plugin. Then press "Save" button and you can see: ?????????????????????????

    Try this words: "Это проверка на русском языке, это кириллица"
    If u need more russian symbols, you can use google-translator : http://translate.google.com/#en|ru|

    Type some words on english and copy translated in you clipboard. Then test it.

    Remember: need a UTF-8 support in your blog. and, may be, your windows/linux/Mac MUST support cyrylic (if you can not see russian symbols right now and here - your OS (windows/linux/mac) do not support cyrylic).

  5. XmasB
    Member
    Plugin Author

    Posted 3 years ago #

    Hi again, sorry about the late reply.

    Ok, so I've testet this and it works just fine in my test installation. My blog is in UTF-8 and I can see the russian symbols here and in my own blog afer saving the as a quote. Both in the edit screen and by using the widget as a visitor.

  6. Den999
    Inactive
    Posted 3 years ago #

    Hi!

    May be a conflict of plugins? That's how I look it:
    (pictures)

    http://s56.radikal.ru/i154/1103/5c/0f36933f0696.jpg

    http://s015.radikal.ru/i333/1103/bc/cb62211b0779.jpg

    and widget (we can see no russians inside):

    http://i030.radikal.ru/1103/e9/29534cb21d53.jpg

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic