WordPress.org

Ready to get started?Download WordPress

Forums

WYSIWYG Widgets / Widget Blocks
[Plugin: WYSIWYG Widgets] HTML and Visual Tabs don't work and none of the WYSIWIG buttons show (12 posts)

  1. gruvii
    Member
    Posted 2 years ago #

    All that shoes up are the words "HTML" and "Visual" and the buttons to insert images, media, etc.
    See screenshot here

    http://wordpress.org/extend/plugins/wysiwyg-widgets/

    I am using multisite and tried this in Firefox and IE 9 with all other plugins turned off. I also tried it using the twenty-eleven theme to make sure it was not a theme issue.... Additionally, I deleted my cached, reloaded, etc.

  2. Danny van Kooten
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Gruvii,

    Thanks for the report.

    From the screenshots it looks like you're using WP 3.3? WYSIWYG Widgets is not yet compatible with WP 3.3, I'm currently looking into this.

    Kind regards, Danny

  3. Jason Lemahieu (MadtownLems)
    Member
    Posted 2 years ago #

    Danny: The new editor is muuuuch easier to use, however keeping some level of backwards compatibility is going to be a pain for a while. Here's a good article on using the new one:

    http://soderlind.no/archives/2011/09/25/front-end-editor-in-wordpress-3-3/

  4. mssbee
    Member
    Posted 2 years ago #

    Hey Danny, love the plugin! Hoping for an update soon as with WP 3.3 it is not only not showing any buttons or tabs, but also locking up all the widgets so they won't open.

  5. elsou
    Member
    Posted 2 years ago #

    When WYSIWYG Widgets will be compatible with WP 3.3 please ?
    Thanks !

  6. skyer2000
    Member
    Posted 2 years ago #

    Danny, it seems like you are always chasing the WordPress team as you maintain the single most valuable plugin I use for my clients. I really hope you are able to figure it out for 3.3, I updated a couple of sites before I noticed the plugin was incompatible.

  7. CarolineElisa
    Member
    Posted 2 years ago #

    Please please please let us know as soon as your fantastic plugin is compatible with 3.3.

    Thanks!

  8. ReneODeay
    Member
    Posted 2 years ago #

    I'm not using that widget, but have you tried the 'Use Google Libraries' plugin? it worked to bring back the editor buttons etc on the admin side. it might work.

  9. Danny van Kooten
    Member
    Plugin Author

    Posted 2 years ago #

    Just updated WYSIWYG Widgets to version 1.2, which should be fully compatible with WP 3.3. Let me know if you still experience any issues.

    http://wordpress.org/extend/plugins/wysiwyg-widgets/

  10. TheWatcher2
    Member
    Posted 2 years ago #

    Note that the widget doesn't work with WP 3.3.1. Clicking on the writing area does nothing and the widget refuses to respond to bring up the WYSIWYG editor. I certainly hope this issue can be solved, because this is a feature sorely needed for WP. Thanks.

  11. TheWatcher2
    Member
    Posted 2 years ago #

    I now noticed that after installing the tiny mce advanced text editor that the WYSIWYG Widgets finally showed the editor buttons, but nothing in the text box worked and no text could be entered. Please let me know if you have a work around. Thanks!

  12. TheWatcher2
    Member
    Posted 2 years ago #

    Okay, after some more playing around I got it to work, but with some quirks. After installing the tiny mce advanced text editor the WYSIWYG editor buttons showed up but didn't work. I then got the idea to allow pop-ups in Firefox, which then resulted in the widget working. However, there still are some potential bugs. The word wrap doesn't work in the window size--it allows words to spill over too far to the right and out of sight. Also, the text window doesn't seem to open up the way you state, but it just opens similar to the basic text editor widget that comes with WP. Hope this helps to get everything working.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic