WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WYSIWYG Text Widget] doesn't work in 2.71 (10 posts)

  1. mkmedia
    Member
    Posted 5 years ago #

    I've installed the plugin, I've tried to use it, but I get an error message (can still use it though)... but I can't include any media at all. I get redirected to a white page!

    http://wordpress.org/extend/plugins/wysiwyg-text-widget/

  2. jayroh
    Member
    Posted 5 years ago #

    Same here. looks like it should be opening via a lightbox or modal window of some sort, instead it's a full request to a new page.

  3. technopreneur
    Member
    Posted 5 years ago #

    i tried it in wordpress 2.7.1

    it worked for me after making some changes to the wysiwyg-text-widget.php

    // orig function at line ~ 115
    function widget_wys_text_init()
    {
    wp_enqueue_script('editor');
    wp_enqueue_script('editor_functions');
    wp_enqueue_script('quicktags');
    }

    edited//
    function widget_wys_text_init()
    {
    wp_admin_css( 'thickbox' );
    add_thickbox();
    wp_enqueue_script('editor');
    wp_enqueue_script('editor_functions');
    wp_enqueue_script('quicktags');
    wp_enqueue_script('media-upload');
    }

    I hope it will work for you guys also

  4. mael
    Member
    Posted 5 years ago #

    It worked for me.
    Nice tip !
    Did you send this to the plugin author ?

  5. abelcreative
    Member
    Posted 5 years ago #

    boy, I tried this with no luck - I'm on FF3/Mac - maybe that's the problem?

  6. Hiranthi
    Member
    Posted 5 years ago #

    @abelcreative: as it says on the author's plugin page

    Known issues

    • The plugin doesn’t work (on the admin end) in Google Chrome
    • The widget is a bit odd in Firefox. There’s sometimes an intermediate page that shows when you edit a widget, and you might have to click the “Visual” link to see the editor buttons. I’d like to fix these things but don’t have time at the moment (new baby = no time!).
  7. Hiranthi
    Member
    Posted 5 years ago #

    Btw, I tried it in FF3, Safari and IE7 (all winvista) but it doesn't work for me. Also tried the edit mentioned in a few posts back, but that didn't solve it either..
    A shame, because this is exactly what my client wants..

  8. bryan868
    Member
    Posted 5 years ago #

    Can someone make this work better?

  9. controlledchaos
    Member
    Posted 5 years ago #

    @technopreneur - I used your fix today, and the plugin is now working great in FF 3 on Mac.

  10. kmcadams
    Member
    Posted 5 years ago #

    This plugin doesnt work correcty for me - it only adds a widget to the first sidebar i am fairly new at building themes and i note that int widget php it looks for register_sidebar_widget my functions.php uses register_sidebar - not sure what the difference is between the two-

    Karen

Topic Closed

This topic has been closed to new replies.

About this Topic