WordPress.org

Ready to get started?Download WordPress

Forums

MailPoet Newsletters
[resolved] [Plugin: Wysija Newsletters] Disable comments on the 'You've subscribed!' page (7 posts)

  1. RubyGingerNut
    Member
    Posted 1 year ago #

    Hi there!

    I've been testing this plugin for a few hours now trying to disable comments in the 'You've subscribed!' page which comes along after the subscriber clicks on their confirmation email link. Could someone please advise on how to disable comments when new subscribers are diverted to the 'You've subscribed!' page?
    Any help from anyone would be much appreciated! Thank you.

    http://wordpress.org/extend/plugins/wysija-newsletters/

  2. Ben
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I think I answered you on our support site already.
    But basically the way to go would be to create a single-wysijap.php file in your theme folder and modify it to remove the part about the comment box.
    http://support.wysija.com/knowledgebase/customize-your-confirmation-pages/

    Hope this helps,
    Cheers,
    Ben

  3. HD1234
    Member
    Posted 1 year ago #

    fyi applying the following code:

    /* To hide the date and comments */:
    .wysijap .postmeta { display:none }

    to 2011 child style.css doesnt remove "This entry was posted by XXXXXX. Bookmark the permalink.", "Logged in as XXXXXX. Log out?", "Leave a Reply" or "Post Comment" field.

    Also, the alternate method suggested on the page link you provided of creating a single-wysijap.php file in the child theme folder, copy/paste page.php content and then editing or just saving (because there is no auther defined) didnt change anything either.

    Any suggestions?

  4. RubyGingerNut
    Member
    Posted 1 year ago #

    Hi I just updated my theme last week without backing up so I had to go through all this again. Anyway I did as per Ben's suggestion. I copied loop.php and renamed it to single-wysijap.php. Open up single-wysijap.php and commented out <?php comments_template( '', true ); ?>

    AND

    <p class="comment-number"><?php comments_popup_link( __( 'Leave a Comment', 'pilcrow' ), __( '1 Comment', 'pilcrow' ), __( '% Comments', 'pilcrow' ) ); ?></p>

    AND if you want to remove dates:

    " title="<?php echo esc_attr( sprintf( __( 'Permalink to %s', 'pilcrow' ), the_title_attribute( 'echo=0' ) ) ); ?>" rel="bookmark"><?php the_time( get_option( 'date_format' ) ); ?>
    <?php edit_post_link( __( 'Edit', 'pilcrow' ), '<span class="edit-link"> | ', '</span>' ); ?>

    Hope that helps!

  5. HD1234
    Member
    Posted 1 year ago #

    Thanks, I'll give it a try!

  6. patricklinton
    Member
    Posted 1 year ago #

    Hi,
    I have the same issues as HD1234 above - I need the mods to be within my child theme so that the next WP update doesn't remove them.

    Suggestions?

    Can you add the 'allow comments' option to your confirmation design page?

  7. MailPoet Staff
    Member
    Plugin Author

    Posted 1 year ago #

    I believe we've answered you through support.wysija.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic