WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
[Plugin: WPtouch] Multi-site..."home" links to default site (4 posts)

  1. matt6303
    Member
    Posted 1 year ago #

    I just downloaded and installed WPTouch 1.9.

    I'm finding that the "home" link in the menu of all of the sites in my multi-site setup are pointing to the Default site.

    Is there a setting that I can adjust, to have the "home" link point to the homepage of the site being viewed?

    http://wordpress.org/extend/plugins/wptouch/

  2. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    By "default site", do you mean the network's main site rather than the subsite? You may want to ensure that WPtouch is active on the subsite directly.

    Network installations should function just the same as stand-alone installations with their home buttons leading to the primary domain url.

  3. matt6303
    Member
    Posted 1 year ago #

    Thanks for replying.

    Correct - I have 6 total sites on my WordPress installation, but when viewing each site via WPTouch, the 'home' link directs to the Network's main site.

    In one case I specified a page, rather than "WordPress Settings", in the "Home Page Re-Direction" area of the settings, and that worked as planned. So I'm fairly certain that the plugin was active on the subsite(s) directly.

    Separate issue, but may be related...

    When the plugin is active and I click Mobile Theme "off" at the bottom while on the Main site of the network, it continues to display the mobile site. However, on any of my other sites when I click "off" it tries to send me to the URL using https:// and "a secure connection cannot be established." Perhaps this can aid in helping me find a solution, or perhaps it's a different problem entirely.

    Thanks again for taking the time to respond to the comments here!

  4. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Matt,

    The switch link behavior sounds like a cache plugin issue. Please add the list of user agents below to the 'rejected user agents' area of the cache plugin you're using, clear the cache and see if that helps.

    iphone
    ipod
    ipad
    pre
    pixi
    iemobile
    aspen
    incognito
    webmate
    android
    dream
    cupcake
    froyo
    blackberry9500
    blackberry9520
    blackberry9530
    blackberry9550
    blackberry 9800
    blackberry 9780
    blackberry 9850
    blackberry 9860
    webos
    s8000
    bada
    googlebot-mobile
    adsbot-google

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags