WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
[Plugin: WPtouch] How to turn off HTTPS (7 posts)

  1. AJHenderson
    Member
    Posted 1 year ago #

    I have a blog on a server that uses https for a different site and wptouch is automatically redirecting to the https site instead of my site. Is there a way to turn off the detection of https so that it behaves correctly?

    http://wordpress.org/extend/plugins/wptouch/

  2. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    Hi AJHenderson,

    Is this happening on a Multisite-enabled WordPress installation? We ask because a configuration on one site should not affect another website, in general.

  3. AJHenderson
    Member
    Posted 1 year ago #

    No, it is not a multi site install. The https page is an IIS based site on a completely different platform. For some reason though, when I tell wp-touch to go to the normal version, it loads the https site. With wp-touch disabled, everything works fine.

  4. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the info AJ. If you don't mind, please share the URL of the website in question and we'll take a look for you.

  5. AJHenderson
    Member
    Posted 1 year ago #

    http://Www.forgottensoldiers.us, though at the moment I have wp-touch disabled as it was breaking the site on mobile.

  6. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    We see that you're running WP Super Cache. For optimal performance with mobile sites, you'll want to disable caching plugins from caching mobile sites.

    To do this, first try enabling WPtouch support in WP Super Cache. If that isn't enough, then follow these instructions:

    1. In the Advanced tab of the WP Super Cache settings select *Mobile Device Support and click Update Status.

    2. Still in the Advanced tab, scroll down to Rejected User Agents area. Select the entire list of mobile user agents below, right-click and select ‘Copy’.

    iphone
    ipod
    ipad
    pre
    pixi
    iemobile
    aspen
    incognito
    webmate
    android
    dream
    cupcake
    froyo
    blackberry9500
    blackberry9520
    blackberry9530
    blackberry9550
    blackberry 9800
    blackberry 9780
    blackberry 9850
    blackberry 9860
    webos
    s8000
    bada
    googlebot-mobile
    adsbot-google

    Please note: If you have added support for additional mobile user agents in Advanced Options > Custom User Agents, you must also include those user agents in the “Rejected User Agents” area specified below.

    3. Then right-click and select ‘Paste’ inside the Rejected User Agents area to enter the user agent list.

    4. In the Tester and Contents tab, click Delete Cache to delete pages that were likely cached before applying the rejected user agents.

    WP Super cache should now be configured correctly to ignore the mobile user agents, while still caching pages viewed on a desktop browser.

    *Enabling Mobile Device Support alone seems to cache and serve mobile page separately to mobile devices. If you are seeing issues where mobile pages are being shown in your desktop browser or vice versa, please apply all the settings outlined above.

  7. abellsmith
    Member
    Posted 1 year ago #

    I'm having the same issue here, and have not installed any caching plugins yet. The only similarity I have with the above site is that I'm on a Windows server... and I'm also getting redirected to https --

    http://thewsga.org/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.