WordPress.org

Ready to get started?Download WordPress

Forums

WPGPlus
Getting "too many redirects" every time I post... (11 posts)

  1. stephensekula
    Member
    Posted 2 years ago #

    Hi John,

    It's me again. :-) Ever since the 0.8.4 update of WPGPlus, I've been getting the "too many redirects" problem again. It happens reliably every time I post. Nothing useful appears to be dumped to the debug log.

    I have tried disabling other plugins that also run in response to a new post - e.g. the StatusNet update plugin. However, the problem of too many redirects remains. Any suggestions how I could test this further to provide more useful information to you?

    Regards,
    Steve

    http://wordpress.org/extend/plugins/wpgplus/

  2. puffidredz
    Member
    Posted 2 years ago #

    same problem here. i have disabled all addons and still get the error. if i disable WPGPlus and try to post without it, i dont get the error

    Writing cookies from login get
    2012-07-25 19:01:02 : publish_to_gplus running, included wpgplus.php
    2012-07-25 19:01:02 : publish_to_gplus running, postID is 161
    2012-07-25 19:01:02 : wgplus_safe_post_google running, post_id is 161
    2012-07-25 19:01:02 : just requested the login info
    
    Buffer is
    WP_Error Object
    (
        [errors] => Array
            (
                [http_request_failed] => Array
                    (
                        [0] => Too many redirects.
                    )
    
            )
    
        [error_data] => Array
            (
            )
    
    )
  3. puffidredz
    Member
    Posted 2 years ago #

    i was able to resolve this by going back to version 0.8.3

  4. stephensekula
    Member
    Posted 2 years ago #

    I took a look at the differences between 0.8.3 and 0.8.4. They were minor changes, but one of them altered the number of redirects:

    sekula@handy:~/tmp$ diff wpgplus-0.8.3/gplus.php wpgplus/gplus.php
    36c36
    < 'redirection' => '5',
    ---
    > 'redirection' => '0',
    46a47,49
    > if(is_wp_error($buf)) {
    > wp_die($buf);
    > }

    I am going to try setting that back to '5' and see if that recovers the old behavior. Weird. My old problem was that this number was too high, and setting it to '0' made this problem go away...

    Clearly, there is something pathological going on with Google+.

    Steve

  5. stephensekula
    Member
    Posted 2 years ago #

    Yeah, setting '0' back to '5' fixed the problem. Again . . . weird . . . because in an older release my problem was exactly the opposite: setting it to '5' gave the 'too many redirects' error.

    Steve

  6. John Eckman
    Member
    Plugin Author

    Posted 2 years ago #

    I'm trying to stick to setting redirection to 0, because setting redirection to 5 causes errors for users whose hosts use PHP in Safemode, and don't allow cUrl to follow redirects.

    The issue is why that first call to Google plus requires a redirection at all, but that one will take some time to chase down.

    Unfortunately, it seems like google+ also behaves differently in different countries - google.de users don't just start on a different page but also seem to get different behavior.

    So, for now, if your host allows it, you can set redirects back to 5 (or even 1 or 2 would probably be enough) but that won't fix it for everyone.

  7. b_d_m_p
    Member
    Posted 2 years ago #

    Same problem. Downgraded to 0.8.3 but no luck. What next?

    Thanks.

  8. fable
    Member
    Posted 1 year ago #

    Please help me ! I've the same problem in Italy. This is debug report:
    Writing cookies from login get
    2012-12-05 22:33:46 : publish_to_gplus running, included wpgplus.php
    2012-12-05 22:33:46 : publish_to_gplus running, postID is 3736
    2012-12-05 22:33:46 : wgplus_safe_post_google running, post_id is 3736
    2012-12-05 22:33:46 : just requested the login info

    Buffer is
    WP_Error Object
    (
    [errors] => Array
    (
    [http_request_failed] => Array
    (
    [0] => Troppi redirect.
    )

    )

    [error_data] => Array
    (
    )

    )

    How do you suggest to solve the problem ?
    Thank you very much !

  9. gesko
    Member
    Posted 1 year ago #

    Same here. Installation will break jetpaks contakt form. Error "too many redirects"

  10. Pabloelbest
    Member
    Posted 1 year ago #

    Where can we edit rediretions? Thanks :)

  11. iBenshi
    Member
    Posted 1 year ago #

    I had the same issue with this plugin. Disabled it and it solved the "too many redirects" issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.