WordPress.org

Ready to get started?Download WordPress

Forums

WPGPlus
[resolved] Failing for German users (66 posts)

  1. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    Received comments on Google+ that this is failing for German users.

    Warnings being thrown:

    Warning: DOMDocument::loadHTML() [domdocument.loadhtml]: htmlParseEntityRef: expecting ';' in Entity, line: 60 in ..../wordpress/wp-content/plugins/wpgplus/gplus.php on line 72
    
    Warning: DOMDocument::loadHTML() [domdocument.loadhtml]: htmlParseEntityRef: expecting ';' in Entity, line: 60 in ....wordpress/wp-content/plugins/wpgplus/gplus.php on line 72
    
    Warning: DOMDocument::loadHTML() [domdocument.loadhtml]: htmlParseEntityRef: expecting ';' in Entity, line: 60 in ..../blog/wordpress/wp-content/plugins/wpgplus/gplus.php on line 72
    
    Warning: DOMDocument::loadHTML() [domdocument.loadhtml]: Input is not proper UTF-8, indicate encoding ! in Entity, line: 64 in ..../blog/wordpress/wp-content/plugins/wpgplus/gplus.php on line 72
    
    Warning: DOMDocument::loadXML() [domdocument.loadxml]: Input is not proper UTF-8, indicate encoding ! Bytes: 0xC4 0x6E 0x64 0x65 in Entity, line: 1 in ..../blog/wordpress/wp-content/plugins/wpgplus/gplus.php on line 139
    
    Warning: Cannot modify header information - headers already sent by (output started at ..../blog/wordpress/wp-content/plugins/wpgplus/gplus.php:55) in ..../blog/wordpress/wp-includes/pluggable.php on line 866

    Maybe an issue with how Google+ gets encoded in German? Some other characters in the stream which make the xml loading fail?

    http://wordpress.org/extend/plugins/wpgplus/

  2. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    I've just checked in a change - relaxing from loadXML to loadingHTML for part of the process, and hopefully suppressing warnings.

    Can any non-english Google+ users test this by downloading the development version from the plugin "other downloads" page?

  3. herb37
    Member
    Posted 2 years ago #

    I am using the German version of WP and the German of G+ too. I don't get any error message. A new post isn't written to G+.
    Do You please have a link to the "other downloads" page. I only found the version 0.6
    Thanks in advance
    Herbert

  4. draven666
    Member
    Posted 2 years ago #

    On my german blog the development version seems to run correctly without warnings.

  5. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    @herb37 to get the other downloads page click on "other versions" just below the ratings under "FYI" on the plugins page, or http://wordpress.org/extend/plugins/wpgplus/download/

    @draven666 meaning it successfully posts to Google+ or just throws no warnings?

  6. mbrucke
    Member
    Posted 2 years ago #

    Hi John,

    the development version works without a warning and publishes to g+! Good job ;)

    best regards Matthias

  7. herb37
    Member
    Posted 2 years ago #

    Hi John,
    Thanks for the link. I have installed the developer version on an other website haaving not so much other plugins). But nothing is seen on G+
    Looking to the debug.txt, I see:

    2012-02-16 07:02:05 : publish_to_gplus running, included wpgplus.php
    2012-02-16 07:02:05 : publish_to_gplus running, postID is 61
    2012-02-16 07:02:05 : wgplus_safe_post_google running, post_url
    2012-02-16 07:02:05 : wgplus_safe_post_google running, username is 108479808134314432774
    password is xxxxxxxx
    2012-02-16 07:02:06 : wgplus_safe_post_google running, past log in
    2012-02-16 07:02:11 : wgplus_safe_post_google running, past update
    2012-02-16 07:02:11 : publish_to_gplus done running

    I do not understand what is running so bad.
    Regards
    Herbert

  8. mbrucke
    Member
    Posted 2 years ago #

    Hi John,

    I noticed another issue with german language ;)

    I wrote something containing the Text "Home-Taste" in WordPress. This is then transmitted to G+ (so it works for me, hurray ;)). The text ends up as: ”Home-Taste”

    So the quote signs are treated wrong. I assume that &#8221 is UTF-8 for "?

    best

    Mats
    @herb37: I did nothing special (as you asked on twitter) but just installed the development version of the plugin. Perhaps we can chat via Twitter to solve your problem?

  9. herb37
    Member
    Posted 2 years ago #

    PHP 5 and cURL library are enabled.
    My WP version is 3.3.1 German language
    I have tried both the G+ id and my google eMail adress

    nothing is published to G+, publishing to the blog is running without any problem. the content of the debug.txt please see above

    Before publishing a new post there is one custom field with the name wpgplus_publish and the value yes
    after publishing there are two custom fields with equal content too the first one.

    Under preferences I setup at WPGplus my google email adress and the password.

    What can I check or do You see any mistake.

    Regards
    Herbert

  10. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    @herb37 the "wpgplus_publish" thing (duplicating) is an annoyance but not a problem.

    Your Google username should be your email address you use to sign in to google plus on the web.

    It is odd the debug file doesn't have a post url, but I can see in the code that's my mistake (but it shouldn't impact functionality, just incomplete debug file).

    Is PostID 61 a normal "post" type post? You're not using custom post types or anything are you? Can you share what post that is, on your blog?

    I don't see anything obvious - may need to push another development build with even more debugging on.

  11. herb37
    Member
    Posted 2 years ago #

    @John,
    Google username is my eMail address, ok.
    PostID 61 is http://seniorenforum-bayern.de/?p=61 on my blog.
    I am not using custom post types on this blog.

    On an other blog I am using custom post type. There I have the same problem. Nothing is published to G+

  12. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    Custom post types will be a problem - if you look at line 113 of gplus.php you'll see it checks to see if the current post is of type 'post' and if not stops trying to publish.

    Not sure what else may be going on here - sorry.

    If I do post another version with more debug in it I will post here.

  13. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    @herb37 (and anyone else using the development version and not getting posts appearing on Google+) - is there a cookies.txt file in your wpgplus plugin directory?

    I'm wondering if it is perhaps failing to get the appropriate cookie set?

  14. ariherzog
    Member
    Posted 2 years ago #

    I'm also having problems.

    1. Version 0.6 caused the same errors as reported for German users.
    2. I'm not German. I'm running WP 1.3.3 and the Thesis theme.
    3. I installed the development version. No errors but when publishing a post, it's not shared to my G+ feed.

    After publication, there is a duplication of custom fields -- https://skitch.com/ariherzog/8n3y4/post-publication -- which doesn't appear normal but maybe it is.

  15. ariherzog
    Member
    Posted 2 years ago #

    The debug file is not showing errors. Everything ran.

    What is the red flag in the cookies file? What should it look like?

  16. herb37
    Member
    Posted 2 years ago #

    @John,
    I have a cookies.txt
    But I do not know, what the content is meaning.

    @ariherzog,
    My debug.txt is shown above.
    Instaed of the G+ID I am using know my google-mail address.

    Within the custom field I do not have the wpgplus_message

  17. ariherzog
    Member
    Posted 2 years ago #

    John: The cookies file is not updating with new test posts I'm publishing.

  18. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    @ari and @herb37

    Is the cookies.txt in the wpgplus directory zero length, or does it have a size?

    I just release a 0.7 version with more debugging in it, but I think the issue may be with permissions on the cookies.txt file - delete the one that came with the plugin and it should create a new one next time you publish something.

  19. ariherzog
    Member
    Posted 2 years ago #

    Huh? If I delete the cookies file (which did have text in it) and publish a new post, a cookies file is not auto created.

  20. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    Well that's a problem.

    wpgplus uses cURL and needs to be able to write to and read from the cookie.

    I can look at trying to change how the cookie file gets created.

    In the meanwhile, can you create a blank cookies.txt and set its permissions to 644?

  21. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    ari - what does your debug.txt say after you delete the cookies file and then try to publish again?

  22. herb37
    Member
    Posted 2 years ago #

    @John,
    I have created a blank cookies.txt and set the permission to 644.
    After publishing a post, there is a cookies.txt with a lot of text and figures.

    The debug.txt now has more content than this morming (using the developer version).
    But nothing is published to G+

  23. ariherzog
    Member
    Posted 2 years ago #

    Herb and I are in the same boat.

    If I delete cookies.txt, then recreate it and set permission to 644, then publish a post, the cookies file is populated from libcurl but nothing is published to G+.

  24. ariherzog
    Member
    Posted 2 years ago #

    Debug file is updated with:

    2012-02-19 00:47:59 : publish_to_gplus running, included wpgplus.php
    2012-02-19 00:47:59 : publish_to_gplus running, postID is 7874
    2012-02-19 00:47:59 : wgplus_safe_post_google running, post_url
    2012-02-19 00:47:59 : wgplus_safe_post_google running, username is xxx
    password is yyy
    2012-02-19 00:48:01 : wgplus_safe_post_google running,  past log in
    2012-02-19 00:48:04 : wgplus_safe_post_google running,  past update
    2012-02-19 00:48:04 : publish_to_gplus done running
  25. ariherzog
    Member
    Posted 2 years ago #

    Does the debug file also need to be perm 644? It's 604 right now.

  26. herb37
    Member
    Posted 2 years ago #

    @ ariherzog,
    I guess we have the same problem.
    Starting with a clean cookies.txt I got:

    # Netscape HTTP Cookie File
    # http://www.netscape.com/newsref/std/cookie_spec.html
    # This file was generated by libcurl! Edit at your own risk.

    .m.google.com TRUE /app/plus TRUE 631152000 MEX EXPIRED
    accounts.google.com FALSE / TRUE 1392695430 GAPS 1:ukBLWL_POMsBzlY8qG_sG9QQrMzuoQ:zJLJ7j7hDIgmqfEv
    accounts.google.com FALSE / TRUE 0 GALX vKWrnjy9Ztk
    .google.com TRUE / FALSE 1345434630 NID 56=0asdB_oWFfOfR-c4mC4z08lKAzqdH4sc69XnIdGUkNs5Xa1VKSpUKbg8a5oesJpQN4Xpdoo2DUHg29QTRYlfWekXrNyrx-FZ-cPeKRN5QfYCcWVSjwh0dcEGh2D1mewK5TfRwhyK3SLA5I6WTI2h3kcOoK3aOws
    .google.com TRUE / FALSE 0 SID DQAAANAAAAD8Ht8QK9Zz0aaUbYtfuuRqpaeMZJqIFUyL2IAyQZNwgMO2y50jMQDYWmH6GvguM_dUyKMGKPQAB6vJDIIKKn7uj9IfvBjErRUrwxuD4sB5i3ZFaYkwGwKw_IuWrICZzd6hGTi48687o4tq0IClXg0dUpGK67UjJRnDBRbMt3IYKNAysyzDe6fEaHUyo8Yv_P8ZpBYjxuGoamx9U-D1WB-t7X0mejriNheonh2kiWo4OnyAttsZnEe55Af6EkwkuBFEbyH_g7r8hj6d2gME4POc
    accounts.google.com FALSE / FALSE 0 LSID s.DE:DQAAANIAAAABFOntCufs411AMUfrUVI8eT9_X3nhA9s2ZbNYGNBef3I3PF7YEZskHtJTvTZsqsUfxnwUhEGEBGUbUVg7vag7nMHhBF9ltmXQ_A3WuJvFLP1jQprBfpWoz2D0FfQrI0Ud1lhL3gN-vpiNxb7OmWRKyJN0rHWXihIPxJexG94VLaEwOwieyYysHsJybydFrLDoxD072G88tLHQcogEYl9nlF3OCme0odIdJaiiZFvJ2_iJt8TMbTX2xOEp0urC4ntwHmw1LDNcbmaRwlCMFbGXyCew1_XtyeWB16EpVjVTTw
    .google.com TRUE / FALSE 0 HSID Att_mzo_8Zq-AIYeI
    .google.com TRUE / TRUE 0 SSID AXgz5bXqhB0C4YME9
    .google.com TRUE / FALSE 0 APISID QLlingzyeifjdufs/ASf7XwmoMr4wmYs_3
    .google.com TRUE / TRUE 0 SAPISID sLVhZ4_fYyb1TQLy/A9_Af2jFopCFLziv7

    and for the debug.txt

    2012-02-19 03:50:29 : publish_to_gplus running, included wpgplus.php
    2012-02-19 03:50:29 : publish_to_gplus running, postID is 131
    2012-02-19 03:50:29 : wgplus_safe_post_google running, post_id is 131
    2012-02-19 03:50:29 : wgplus_safe_post_google running, username is schmidt.herb@googlemail.com
    password is xxxxxxx
    2012-02-19 03:50:30 : login data posted
    2012-02-19 03:50:30 : status code was 200
    2012-02-19 03:50:30 : wgplus_safe_post_google running, past log in
    2012-02-19 03:50:35 : Getting form for posting
    2012-02-19 03:50:36 : Got form, status was 200
    2012-02-19 03:50:36 : and base url is https://m.google.com/app/plus/x/qg1ric49ghcp/
    2012-02-19 03:50:37 : Posted form, status was 200
    2012-02-19 03:50:42 : wgplus_safe_post_google running, past update
    2012-02-19 03:50:42 : publish_to_gplus done running

    Both files have the permission 644

    Nothing was published to G+

  27. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    So the cookie looks good, and so long as the cookies are getting text filled in then the permissions are ok. (The permissions being wrong would prevent any text from being added to the cookie).

    However, I'm still not seeing any specific error in the debug logs.

    @Ari - your debug log posted above is from the older version - can you update to 0.7 and try another post?

    @herb37 - the statuc codes it is showing are 200, meaning "OK" - in other words, no error.

    I was hoping we'd see some other statuses, which would tell us something else was wrong - but I'm not seeing any.

    Are you entering something in the "Message for Google+ post: (use google+ markup)" box before you publish?

    Are you writing posts in the regular post edit screen?

    I've just checked in another development version newer that 0.7 - which outputs the whole response from Google+ to the form post - this one will create a much larger debug file, but should help us solve this mystery.

    Please do get the development version from wordpress.org/extend/plugins/wpgplus/download/ and install it, and share the debug output with me.

    (If you don't want to post it publically here, as it might contain sensitive info, you can email it to me - eckman.john -at- gmail.com.

  28. herb37
    Member
    Posted 2 years ago #

    @John,
    I am writing the posts in the regular post edit screen, without enabling the Wysywig-editor.

    I didn't enter something in the "Message Box".
    Regards
    Herbert

  29. herb37
    Member
    Posted 2 years ago #

    @John,
    I have sent an eMail via gmail to You.
    Herb

  30. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    Herbert - the new development version (newer than 0.7) does more debugging, including capturing what post-text it is trying to post.

    Since we're getting 200 OK status codes, looking at what is actually being posted and the full response from Google is the only way to try to find out what is happening.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags