WordPress.org

Ready to get started?Download WordPress

Forums

WPBook
Won't post to facebook fanpage wall (35 posts)

  1. mikejds
    Member
    Posted 3 years ago #

    Hi

    I was upto 5 o'clock in the the morning scratching my head. (not much hair left now)

    It will post to my App but not my fanpage wall.
    http://www.facebook.com/pages/The-Silly-Sausage/153157574708737?v=app_113718315351104

    I have checked permissions and they all look fine.

    Where should I start?

  2. mikejds
    Member
    Posted 3 years ago #

    Had another go tonight but had no joy.

    I'm not getting any error messages or anything so am at a loss what it could be.

    Any help would be appreciated.
    Thanks
    Mike

  3. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    When you go to the "check permissions" link, is the Fanpage to which you are trying to post listed? Does it say permissions have been granted?

    If you go into "edit page" mode on the Fan page, is your application listed?

    Have you added the application to the Fan page as a tab?

  4. mikejds
    Member
    Posted 3 years ago #

    Hi John.
    Thanks for the help.

    When you go to the "check permissions" link, is the Fanpage to which you are trying to post listed?
    Does it say permissions have been granted?

    Yes. This is what I've got...

    You've indicated you wish to publish to this page: 153157574708737
    This page has granted stream.publish permissions to this app.

    You are also listed as the admin of these pages:
    •The Silly Sausage (153157574708737), This page has granted stream.publish permissions to this app.

    You can use the page IDs of any of these pages in the WPBook settings to publish to that page's wall.

    If you go into "edit page" mode on the Fan page, is your application listed?

    Yes its listed.

    Have you added the application to the Fan page as a tab?

    Yes its in the tab and the app. is showing posts fine.

    Any other ideas?
    Thanks
    Mike

  5. mikejds
    Member
    Posted 3 years ago #

    Was keen to get this plugin on my site.
    But I've checked and checked again.
    I just can't get it to work.

    Time to move on I think.
    Too many hours wasted.

  6. mikejds
    Member
    Posted 3 years ago #

    Not giving up just yet....

    Tried yet again.

    This time when I published a post it through up an error.

    Caught exception in actually publishing to page 153157574708737: attachment-href URL is not properly formatted Error code: 100

    What url is it referring to?

    Thanks
    Mike

  7. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Attachment-href would be the image attached to the post, I think.

    What was the post you were trying to publish? Did it contain images?

  8. mikejds
    Member
    Posted 3 years ago #

    All it said was...
    "this is a test"

    No images.

  9. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm. I have not seen that particular error message before - a quick google suggests it might be missing the domain part of the post url.

    Anything custom in your blog in terms of what the WordPress settings are for WordPress address (URL) or Site address (URL) in general settings?

    Looking at the urls of posts in your application view, they seem to have an extra slash: http://apps.facebook.com/thesillysausage//uncategorized/test-19/

    Do you have a trailing slash in your canvas callback url in FB settings or your "Facebook canvas URL" in WPBook settings?

    When I try to go to one like this:
    http://www.thesillysausage.co.uk/index/funny-quotes/funny-facebook-status-updates/my-best-friend/

    I get an error: "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

  10. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Looks like the page is supposed to be:
    http://www.thesillysausage.co.uk/index/category/funny-quotes/funny-facebook-status-updates/

    So maybe there is something about how you are using permalinks?

    WPBook thinks the page should be:

    http://www.thesillysausage.co.uk/index/funny-quotes/funny-facebook-status-updates/my-best-friend/

    Where your blog puts it at:
    http://www.thesillysausage.co.uk/index/category/funny-quotes/funny-facebook-status-updates/

    Something non-standard going on here that must be interfering with how WPBook expects things - sorry.

    Once we get nailed down what's happening then perhaps we can figure out how to work around it.

  11. mikejds
    Member
    Posted 3 years ago #

    Hi John,

    Do you have a trailing slash in your canvas callback url in FB settings or your "Facebook canvas URL" in WPBook settings?

    I made a mistake there.
    There was a trailing slash in my WPBook settings.
    I've now removed it and reposted.
    The error is no longer throwing up. (clever you)
    Unfortunately posts are still not showing on FanPage wall.

    So maybe there is something about how you are using permalinks?
    I do have permalinks set different to the default.
    Custom Structure: /%category%/%postname%/
    (does this look okay?)

    I would really like to keep my permalinks set like this if possible.

    Thanks for your time.
    Mike

  12. mikejds
    Member
    Posted 3 years ago #

    Is that one slash too many again?

    I'm useless at coding.

  13. mikejds
    Member
    Posted 3 years ago #

    Okay....

    For now I've changed permalinks back to default.
    (no extra slashes at the end)

    Its still not showing on the FB Page wall.

    Hope this may help though?

  14. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Still seeing some extra slashes from somewhere - if I click on your application's home link it goes to:

    http://apps.facebook.com/thesillysausage// - note the double slash at the end there.

    My guess is the setting in WordPress -> Settings -> WPBook:

    Facebook Canvas Page URL, NOT INCLUDING "http://apps.facebook.com/"

    You should have just thesillysausage in that box.

    But none of that explains why you can't publish to your fan page wall.

    Here's a test for all the permissions. Go to http://developers.facebook.com/docs/reference/rest/stream.publish and find the "Test Console" at the bottom of the page. (Best to do this logged into Facebook as you).

    Choose your FB application from the dropdown for "Application"

    Enter "testing in console" in the "message" box - nothing for attachments or action_links for now.

    Put your pageID (153157574708737) as the "target_id" and leave the "uid" field blank.

    Hit the "Call method" button.

    This should either give you a result - a "stream id" (and a test post on the wall of your fan page) or an error - let me know what that error is.

    If it works in the test console and not in production we may have a FB bug. (Though I can't imagine since it works well for others - more likely we have some other problem).

    Is it possible that your web hosting server is unable to reach Facebook? Some hosting providers block outbound traffic from the web server.

  15. mikejds
    Member
    Posted 3 years ago #

    It threw this error.

    { "error_code": 200, "error_msg": "The user hasn't authorized the application to perform this action", "request_args": [ { "key": "target_id", "value": "153157574708737" }, { "key": "method", "value": "stream.publish" }, { "key": "access_token", "value": "2227470867|2.q9KAyYI4m4A7yxzIhYMfzg__.3600.1284670800-1315132473|J5lOogHI2GstLeDFW5IFkjFgziQ" }, { "key": "format", "value": "json" } ] }

  16. mikejds
    Member
    Posted 3 years ago #

    BTW I also remove the / from my Facebook Canvas Page URL.

  17. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Once again this suggests a permissions problem - that your FB ID has not granted stream.publish permissions.

    What does the *first part* of the "check permissions" link inside WordPress show when you visit it - should be http://apps.facebook.com/thesillysausage/?is_permissions=true

    Not the part about the page, but the part about your UserID - have you clicked on the "Grant permissions for your userid." link? When you do, what happens?

    That link's destination should look something like this:

    http://www.facebook.com/connect/prompt_permissions.php?api_key=c92f14bdc277ef2b775e9711e38999e1&display=popup&ext_perm=read_stream,publish_stream,offline_access&extern=1&next=http://apps.facebook.com/openparenthesis/?catch_permissions=true

    Except of course it will point to your app in "next" and it will have your API key.

    When you click on the grant permissions for your userid, Does your FB app load with an infinite session key showing?

    Another test:

    Go to the test console here: http://developers.facebook.com/docs/reference/rest/users.hasAppPermission

    Again, choose your app from the drop-down, put "publish_stream" in the "ext_perm" box, and put your userid in the "uid" box. Click "call method"

    If you have granted permissions, you should get a 1. If not, you will get a 0 or potentially some other interesting error message.

  18. mikejds
    Member
    Posted 3 years ago #

    Ran through everthing there and it all seems okay.

    What does the *first part* of the "check permissions" link inside WordPress show when you visit it - should be http://apps.facebook.com/thesillysausage/?is_permissions=true

    Yes it does.

    have you clicked on the "Grant permissions for your userid." link? When you do, what happens?

    That link's destination should look something like this:

    http://www.facebook.com/connect/prompt_permissions.php?api_key=c92f14bdc277ef2b775e9711e38999e1&display=popup&ext_perm=read_stream,publish_stream,offline_access&extern=1&next=http://apps.facebook.com/openparenthesis/?catch_permissions=true

    Except of course it will point to your app in "next" and it will have your API key.

    Yes it looks good.

    When you click on the grant permissions for your userid, Does your FB app load with an infinite session key showing?

    Yes.

    The test console gave a 1.

  19. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm. Very strange.

    Let's look at Facebook's permissions table for the page in question. Go to http://developers.facebook.com/docs/reference/rest/fql.query, choose your app, and put:

    select read_stream,publish_stream,offline_access from permissions where uid=153157574708737

    In the query box - make sure your app is selected.

  20. mikejds
    Member
    Posted 3 years ago #

    [ { "read_stream": 0, "publish_stream": 1, "offline_access": 0 } ]

  21. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    And if you run the same query with your userid where the uid= is, do you get three "1"s?

  22. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Did you say at one point it was working publishing to your app's wall? Or did you just mean it is visible in the app?

    Has WPBook *ever* been able to post to *any* wall in FB? (Your personal wall for example - check the box to publish to your personal wall and then unpublish and republish a test post - you can keep using the same one if you unpublish and republish it)

  23. mikejds
    Member
    Posted 3 years ago #

    Yes.

    [ { "read_stream": 1, "publish_stream": 1, "offline_access": 1 }

  24. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry - double posted on your there. I assume your "yes" was to the one about running the query with your userid.

    What about the other question - have you ever been able to publish to any walls?

    I'm beginning to think the issue is that your webhost doesn't allow curl of remote f_open calls, or blocks outbound traffic from the web server.

    Have you ever run one of the auto-tweet plugins? Do you know if your server has curl installed and accessible for use by your account?

  25. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    To test this, install the core control plugin - http://wordpress.org/extend/plugins/core-control/ - and activate it.

    It adds a Tools section to your blog's left nav - go to the core control page, and enable the HTTP Access Module 1.0.

    The go to the HTTP Access Module page (/wp-admin/tools.php?page=core-control&module=http) and see what it says.

    Mine says:

    PHP HTTP Extension	Not Available
    cURL	Available	Disable Transport | Test Transport	Primary GET
    Primary POST
    Primary GET(non-blocking)
    Primary POST(non-blocking)
    PHP Streams	Available	Disable Transport | Test Transport
    PHP fopen()	Available	Disable Transport | Test Transport
    PHP fsockopen()	Available	Disable Transport | Test Transport

    You will need to be able to either user cURL with POST or fopen() for this to work - this is a requirement of the Facebook PHP client

  26. mikejds
    Member
    Posted 3 years ago #

    Did you say at one point it was working publishing to your app's wall? Or did you just mean it is visible in the app?

    I have the app. in a tab on my fanpage wall.
    This is working okay.

    Has WPBook *ever* been able to post to *any* wall in FB? (Your personal wall for example - check the box to publish to your personal wall and then unpublish and republish a test post - you can keep using the same one if you unpublish and republish it)

    Not yet no.

    I just tried posting to my personal wall for the first time and it failed.

    I did notice something though...
    When in wordpress post editing.
    When I check the box (yes) Publish this post to Facebook Wall?
    After I publish the box 'unchecks' itself.

    Not sure if thats relevant?

  27. mikejds
    Member
    Posted 3 years ago #

    :)

    I assume your "yes" was to the one about running the query with your userid.

    Yes it was.

    Have you ever run one of the auto-tweet plugins?

    Yes and it works fine.

    Do you know if your server has curl installed and accessible for use by your account?

    TBH I have no idea.

    I have installed the core plugin and enabled HTTP Access Module 1.0.
    How do I get to the HTTP Access Module page?

  28. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Click on "core control" in the tools section of left-nav, then at the top of that page you should see a link labelled "external HTTP access" right below the "Core Control" header, to the right of "Main page" - these are subpages of Core Control.

  29. mikejds
    Member
    Posted 3 years ago #

    PHP HTTP Extension Not Available
    cURL Available Disable Transport | Test Transport Primary GET
    Primary POST
    Primary GET(non-blocking)
    Primary POST(non-blocking)

    PHP Streams Available Disable Transport | Test Transport
    PHP fopen() Available Disable Transport | Test Transport
    PHP fsockopen() Available Disable Transport | Test Transport

  30. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm. I'm at a loss, mate.

    Assuming you've checked the "Show errors posting to Facebook Stream" wpbook should show you any error it encounters, or unexpected returns from FB.

    If Facebook is just silently dropping your wall posts without any error I'm at a bit of a loss as to why.

    It looks from what you've posted in that cURL is available and able to do POST requests - so the Facebook client should use that fine.

    Try clicking the "Text Transport" link in the "cURL" section - it just retrieves a doc from an external host.

    That's really the last thing I can even think to try.

    Can you also see your WordPress database? You could look in the wp_post_meta table and see if there are any entries where the meta_key is _wpbook_page_stream_id or _wpbook_user_stream_id - my guess is you won't see any, as WPBook only adds those when it has successfully published to a wall.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags