WordPress.org

Ready to get started?Download WordPress

Forums

WPBook
Upgraded plug-in, not working (read the update notes) (12 posts)

  1. AardvarkGirl
    Member
    Posted 3 years ago #

    I ran the update of the WPbook plug in yesterday and now it isn't working, and I'm also having errors making posts.

    1. Was running WP 3.1.1 when I ran the update, however I had not made a blog post in a while so not sure if it worked after I updated from Wp 3.0.5 to WP 3.1.1

    2. When I went into the plug-in settings each time I tried to use the link

    If you are having issues, please begin by Checking permissions for stream publishing, reading, and offline access.
    I got a red/pink error box on Facebook (can't remember error now, something about try back later).

    3. I found the update notes for the plug-in so decided to totally kill my app on facebook and start all over. I deactivated the plug-in, reactivated it and started the set up process all over on FB's side by creating a new app and putting in the new info/settings into WP plug-in settings.

    4. When I try the link for

    If you are having issues, please begin by Checking permissions for stream publishing, reading, and offline access.
    I get this...
    http://www.facebook.com/4oh4.php The page you requested was not found..

    5. When I tried the link for

    http://graph.facebook.com/YOUR_USERNAME
    It prompts me to download a file with out an extension. When I open the file in note pad it says "{
    "error": {
    "type": "OAuthException",
    "message": "(#803) Some of the aliases you requested do not exist: username"
    }
    }"

    6. Even when I put what I think my Facebook User ID in that spot and hit SAVE it doesn't save anything there.

    Oh, I just noticed it is not saving my new 'canvas page' url either (it is keeping the old).

    7. So , I totaly deleted the plug-in, reinstalled it, and it fires right up with my old settings. :-\

    Now what?

    http://wordpress.org/extend/plugins/wpbook/

  2. AardvarkGirl
    Member
    Posted 3 years ago #

    I ended up going into my database and emptying out the "wp_options --> wpbookAdminOptions" record, and it allowed me to do a 'fresh' set up, and then it let me put in the new information... (And yes I did a back up of my database first) BUT - when I did a test post it went from ".../post-new.php" to ".../post.php" with the browser error page "The website cannot display the page".

    I checked permissions and granted them... *sigh*

    While the post does show on the WP blog, it does not show up on Facebook.

    I even went back and double checked my 'personal profile' ID number, and then the ID number of the page (which seem to be one and the same now according to the 'how to find your facebook id' link provided on the plug in instructions.

    *** Edited to say:

    When I logged out of Facebook and Googled my user name I actually got a different ID number than the method used in the 'article' mentioned above. http://www.facebook.com/StartingPointStables and then I clicked on my photos link which took me to this url... http://www.facebook.com/r.php?profile_id=100001466875489&next=http%3A%2F%2Fwww.facebook.com%2FStartingPointStables - I'm guessing my personal ID number is listed after id= (?)

    The page I want to post to ishttp://www.facebook.com/pages/A-Starting-Point-Stables/137164249658446 so I assume that number at the end is the page

    ARG...

    Ok, went back to facebook on the 'grant permissions page' and though I had granted permission before this is what this page is now saying:

    This page is where you can check and grant extended permissions, which enable WPBook to publish to your personal wall and/or to the walls of fan pages.

    The Facebook profile ID you are currently logged in to Facebook as is 100001466875489. You have defined 100001466875489 as your Facebook user id in WPBook Settings.

    FB profile 100001466875489 has granted these permissions:

    •offline_access - no
    •read_stream - no
    •publish_stream - no
    •manage_pages - no

    An access token for this user has been stored.

    You've indicated you wish to publish to this page: 137164249658446

    Fatal error: Uncaught CurlException: 60: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed thrown in D:\Inetpub\wwwroot\defaultweb\startingpointstables.com\wp-content\plugins\wpbook\includes\client\facebook.php on line 614

    :-(

  3. AardvarkGirl
    Member
    Posted 3 years ago #

    One more try, I changed where I wanted posts to go, from my PAGE to my personal WALL. WordPress did the post as normal (didn't produce the 'not found' page) - and when I checked permissions again facebook granted it fine... but still no post on my personal wall.

    When I changed it back to posting to my PAGE - the posting function in wordpress had the hiccup ('not found') and when I re-checked the permissions in Facebook I got the 'fatal error' again.

    I'm givin' up for the night.

  4. AardvarkGirl
    Member
    Posted 3 years ago #

  5. AardvarkGirl
    Member
    Posted 3 years ago #

    Anyone?

  6. Brooke Dukes
    Member
    Plugin Contributor

    Posted 3 years ago #

    I'm 98% sure this is a setup problem (or maybe a server problem) and not a problem with WPBook. First things first, is your Canvas url working at all? Ie can you visit http://apps.facebook.com/yoururl? If not get that resolved first.

    If you can see the sapp what does it show the WPBook theme or just a mirror of your site? If it's the WPBook view that means that WPBook is talking to Facebook so we can move on to to permissons. If not, check your settings.

    If your app canvas page is working fine then try the check permission link. You are getting a "no" where you should be getting a yes which I think is reflective of the setup problem.

    I'm sure you found the complete install instructions at http://wpbook.net/docs but just incase there is the link.

    Once you have your canvas view up and running we can trouble shoot your wall post view.

    Asside: The phpinfo error is my fault it should be <?php phpinfo() ?> not <?php echo php_info() ?> but I'm not thinking this is a curl issue.

  7. AardvarkGirl
    Member
    Posted 3 years ago #

    If you can see the sapp what does it show the WPBook theme or just a mirror of your site? If it's the WPBook view that means that WPBook is talking to Facebook so we can move on to to permissons. If not, check your settings.

    sapp... I assume you mean app (Sorry, I have a head cold and am on benadryl right now). Yes, I guess I can see the app? I see a gear looking icon on the left side of my facebook screen, and when I click that I get a page with the text of my website's home page.

    I've checked my settings - and I said above in my posts that I was confused as to how to determine my personal USER ID, but I tried both my personal and the pages.

    When I go to my canvas page URL it shows me the same thing I mentioned above, the text from the home page of my website.

  8. AardvarkGirl
    Member
    Posted 3 years ago #

    Hello? :(

  9. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    @AardvarkGirl - not sure where to start with this one.

    I assume from all the above that you are using WordPress 3.1.1 and the latest WPBook.

    Can you tell us:

    1. What is the URL of your blog/wordpress install outside Facebook?

    2. What is the url of your Facebook application? (apps.facebook.com/something)

    3. What do you have set in Facebook as the "canvas callback URL" for your FB application?

    4. On your app canvas page (apps.facebook.com/whatver) you said you see text from your blog homepage - is it in your normal theme or is it in a WPBook theme?

    5. What do you *currently* see on the "check permissions" page (which you get to from WPBook settings page inside WordPress)

  10. AardvarkGirl
    Member
    Posted 3 years ago #

    1. http://www.startingpointstables.com/ (outside of Facebook... I'm assuming you are just asking the URL of my WordPress site)

    2. http://www.facebook.com/apps/application.php?id=205562169478587

    3. http://apps.facebook.com/wpforspsblog/ and it is listed this way on the Facebook app page and within wordpress

    Facebook Canvas Page URL, NOT INCLUDING "http://apps.facebook.com/" wpforspsblog/ Visit this canvas page

    4. It does not look like my WordPress site (as in what it would look like as if it were pulled in from an iframe)... it is just 'text'.

    5. I believe the same exact thing I posted above a week ago...

    Last week

    This page is where you can check and grant extended permissions, which enable WPBook to publish to your personal wall and/or to the walls of fan pages.

    The Facebook profile ID you are currently logged in to Facebook as is 100001466875489. You have defined 100001466875489 as your Facebook user id in WPBook Settings.

    FB profile 100001466875489 has granted these permissions:

    •offline_access - no
    •read_stream - no
    •publish_stream - no
    •manage_pages - no

    An access token for this user has been stored.

    You've indicated you wish to publish to this page: 137164249658446

    Fatal error: Uncaught CurlException: 60: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed thrown in D:\Inetpub\wwwroot\defaultweb\startingpointstables.com\wp-content\plugins\wpbook\includes\client\facebook.php on line 614

    Today:

    This page is where you can check and grant extended permissions, which enable WPBook to publish to your personal wall and/or to the walls of fan pages.

    The Facebook profile ID you are currently logged in to Facebook as is 100001466875489. You have defined 100001466875489 as your Facebook user id in WPBook Settings.

    FB profile 100001466875489 has granted these permissions:

    •offline_access - no
    •read_stream - no
    •publish_stream - no
    •manage_pages - no

    An access token for this user has been stored.

    You've indicated you wish to publish to this page: 137164249658446

    Fatal error: Uncaught CurlException: 60: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed thrown in D:\Inetpub\wwwroot\defaultweb\startingpointstables.com\wp-content\plugins\wpbook\includes\client\facebook.php on line 614

    If this is an issue getting the unique 'id' for a user and the page to which I want the posts made to, I can't get this to work (from the WP Plugin page);

    "Note: if you don't know your ID you can get it by visiting http://graph.facebook.com/YOUR_USERNAME
    Replacing the "YOUR_USERNAME" with your Facbook login. (More info on finding your Page ID)."

    A. If I plug-in my 'user name' that is on my personal FACEBOOK ID I get an error message that says:

    " Unable to download StartingPointStables from graph.facebook.com - unable to open site - site not found or available"

    http://graph.facebook.com/StartingPointStables

  11. AardvarkGirl
    Member
    Posted 3 years ago #

    Also I have this plug-in installed on another site that is running 3.0.5 and we have NOT upgraded the plug-in, and it is no longer working. Does it need to be updated and reconfigured as well?

  12. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    So the issue is that your permissions are all no, but the reason that seems to be the case is likely the other errors thrown in the page you link to above, namely:

    Fatal error: Uncaught CurlException: 60: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed thrown in D:\Inetpub\wwwroot\defaultweb\startingpointstables.com\wp-content\plugins\wpbook\includes\client\facebook.php on line 614

    This means that the Facebook php client is failing. Googling the specific error turns up this discussion of an issue some webservers have with how the Facebook client works.

    In WPBook settings, we've build in a workaround for this. Under "stream debug options" there is a checkbox labeled "Disable Facebook SSL verification" - try checking that and saving your settings, then revisit the permissions page.

    You should see at the bottom of that page a link which says "To correct any of these, Grant or re-grant permissions for your userid. (This is required if you intend to publish to your personal wall OR any fan pages.)" - you should now be able to click that link, and next time you visit the permissions page it should be updated to say "yes" for permissions.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags