WordPress.org

Ready to get started?Download WordPress

Forums

WPBook
Need help :) (6 posts)

  1. davidhanscom
    Member
    Posted 2 years ago #

    I keep getting a message that says I need to grant a new access token and I have tried to follow all the instructions on here available and just keep coming up empty. Please, any assistance on getting this up and running properly. Thank you.

    http://wordpress.org/extend/plugins/wpbook/

  2. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    You'll need to provide more info than just "keep coming up empty."

    Have you changed the setting in Facebook for the "remove offline_access" migration, under advanced settings for your Facebook application?

    When you go to grant a new access token, what happens? Does WPBook indicate success, or failure?

    What do you see on the "check permissions" page (link is on your WPBook settings page).

    Have you tried removing the Facebook app from your Facebook account and the trying to re-authorize it?

  3. davidhanscom
    Member
    Posted 2 years ago #

    I have followed the instructions completely. When I click on "checking permissions" this is what shows up in FB:

    This webpage is not available
    Google Chrome could not load the webpage because davidhanscom.com took too long to respond. The website may be down, or you may be experiencing issues with your Internet connection.
    Here are some suggestions:
    Reload this webpage later.
    Check your Internet connection. Restart any router, modem, or other network devices you may be using.
    Add Google Chrome as a permitted program in your firewall's or antivirus software's settings. If it is already a permitted program, try deleting it from the list of permitted programs and adding it again.
    If you use a proxy server, check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server, adjust your proxy settings: Go to the wrench menu > Settings > Show advanced settings... > Change proxy settings... > LAN Settings and deselect the "Use a proxy server for your LAN" checkbox.
    Error 7 (net::ERR_TIMED_OUT): The operation timed out.

    So I do not even see the screen to be able to re-grant permission. I know my website is accessible so not sure why I am getting this. I have also tried to follow the instructions on this page http://wpbook.net/docs/upgrade/ but my advanced settings do not look the same when I go to them. I have also tried removing and creating a new app.

  4. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    There are lots of things which could be at play here.

    What is the url of your blog outside Facebook?

    What is the url of your Facebook application?

    Is your blog accessible via HTTPS?

    What do you have set in Facebook application settings as the canvas url, and what do you have set as the secure canvas url? What do you have set as the application namespace?

    Does your application canvas page load correctly when not trying to set permissions?

    Have you validated that "YOUR profile ID" and app ID are correct in your WPBook settings?

    What is the url target of the "checking permissions" page from WPBook settings inside WordPress (looks something like: http://apps.facebook.com/openparenthesis/?is_permissions=true&wp_user=1 )

  5. davidhanscom
    Member
    Posted 2 years ago #

    What is the url of your blog outside Facebook?

    http://davidhanscom.com

    What is the url of your Facebook application?

    https://developers.facebook.com/apps/257957657641482

    Is your blog accessible via HTTPS?

    Not sure, but going to say maybe no? It is a WP Blog site hosted on Go Daddy

    What do you have set in Facebook application settings as the canvas url, and what do you have set as the secure canvas url? What do you have set as the application namespace?

    http://davidhanscom.com/
    https://davidhanscom.com/
    wpbookdavid

    Does your application canvas page load correctly when not trying to set permissions?

    it gives me a blank page, nothing shows on the page

    Have you validated that "YOUR profile ID" and app ID are correct in your WPBook settings?

    I have, it is correct

    What is the url target of the "checking permissions" page from WPBook settings inside WordPress (looks something like: http://apps.facebook.com/openparenthesis/?is_permissions=true&wp_user=1 )

    https://apps.facebook.com/wpbookdavid/?is_permissions=true&wp_user=1

  6. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, so your canvas app page is http://apps.facebook.com/wpbookdavid/ and that seems to load, as does a page for an individual post (http://apps.facebook.com/wpbookdavid/achieve-your-goals-for-success-step-by-step/ ) though I'm not sure what impact the modal requiring me to share the link or wait 60 seconds has on the app - may be an issue.

    When I try to visit https://davidhanscom.com/ I get an error: Error 103 (net::ERR_CONNECTION_ABORTED): Unknown error.

    Which is the same error I get when I try to visit your permissions page.

    If you don't have an SSL version of your blog you can't use WPBook.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags