WordPress.org

Ready to get started?Download WordPress

Forums

WPBook
[resolved] Full Posts Pages Refuse To Load (12 posts)

  1. Chukwudi Emmanuel Udegbunam
    Member
    Posted 3 years ago #

    My application (http://apps.facebook.com/strictlyonlinebiz/) seems to be working fine but when I click to read the entire post eg http://apps.facebook.com/strictlyonlinebiz/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/, Facebook doesn't load the post and keeps going round and round in an endless loop :-(

    Any suggestions please

  2. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry for the delayed response - this took some debugging.

    So when you request this url: http://apps.facebook.com/strictlyonlinebiz/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/

    Facebook requests an iframe from your blog with this src address:

    http://www.strictlyonlinebiz.com/blog/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/?fb_sig_in_iframe=1&fb_sig_base_domain=strictlyonlinebiz.com&fb_sig_locale=en_US&fb_sig_in_new_facebook=1&fb_sig_time=1284664691.2337&fb_sig_added=1&fb_sig_profile_update_time=1277048365&fb_sig_expires=1284670800&fb_sig_user=1825518&fb_sig_session_key=2.w8Z9E4qN8Vz6x_jcI5v4fA__.3600.1284670800-1825518&fb_sig_ss=xUPScIDVY3Undu7iO09C7Q__&fb_sig_cookie_sig=3cf2868b9f415ed5abac403b56239076&fb_sig_country=us&fb_sig_api_key=f8a72d89b2fd1158004e49bd6c6b7a0e&fb_sig_app_id=127890133926704&fb_sig=56aa366e33f3b962ceffaca0cab47fe1

    Most of that cruft in the querystring is added by Facebook, but note the base_domain is strictlyonlinebiz.com and the url to your blog looks correct.

    Your blog responds with a 301 redirect header:

    HTTP/1.1 301 Moved Permanently
    Date: Thu, 16 Sep 2010 19:18:07 GMT
    Server: Apache mod_fcgid/2.3.5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
    X-Pingback: http://www.strictlyonlinebiz.com/blog/xmlrpc.php
    X-Powered-By: W3 Total Cache/0.9.1.2
    X-Mobilized-By: WordPress Mobile Pack 1.2.3
    Link: <http://wp.me/pLutj-tG>; rel=shortlink
    Set-Cookie: wpmp_switcher=desktop; expires=Fri, 16-Sep-2011 19:18:08 GMT; path=/
    Vary: Accept-Encoding,User-Agent
    Location: http://apps.facebook.com/strictlyonlinebiz/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/
    Cache-Control: max-age=0
    Expires: Thu, 16 Sep 2010 19:18:07 GMT
    Content-Encoding: gzip
    Content-Length: 7663
    Keep-Alive: timeout=5, max=100
    Connection: Keep-Alive
    Content-Type: text/html; charset=UTF-8
    ----------------------------------------------------------
    http://apps.facebook.com/strictlyonlinebiz/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/

    Which requests the facebook url again, which reloads a request for the iframe, which gets redirected, etc. - a complete loop.

    The question is, why does your blog respond with a 301 redirect?

    It doesn't, if you strip everything out of your querystring. But then it also loses the permalink filter, which is required for this all to work.

    Are you doing something to "canonicalize" the url of each post? Any plugins that are designed to avoid your site being framed into another person's site?

  3. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

  4. Chukwudi Emmanuel Udegbunam
    Member
    Posted 3 years ago #

    Thanks for replying man. I deactivated http://wordpress.org/extend/plugins/wordpress-mobile-pack/ and temporarily removed the 301 redirect but the loop thing persists :-(.

    Can you send me a link to someone's app that works so I can see how things would look if the app were to function properly.

  5. Chukwudi Emmanuel Udegbunam
    Member
    Posted 3 years ago #

    THe URL is being canonized by All In One SEO plugin

  6. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    You might try removing that, or deactivating the "canonical" parts of it.

    My app is here:
    http://apps.facebook.com/openparenthesis/

    which maps to:

    http://www.openparenthesis.org/

    and also publishes to my wall and (often but not always) the wall of the WPBook fan page in Facebook.

  7. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    I'm also still seeing the redirect - using Live HTTP headers in Firefox to capture the stream of requests and responses:

    GET /blog/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/?fb_sig_in_iframe=1&fb_sig_base_domain=strictlyonlinebiz.com&fb_sig_locale=en_US&fb_sig_in_new_facebook=1&fb_sig_time=1284670283.456&fb_sig_added=1&fb_sig_profile_update_time=1277048365&fb_sig_expires=1284674400&fb_sig_user=1825518&fb_sig_session_key=2.dz0HOz3waZZvzIO0vkhFiA__.3600.1284674400-1825518&fb_sig_ss=bqW9CoifkEkF3OeWQscLpw__&fb_sig_cookie_sig=cfd8a0be986b5fb2c211709478512913&fb_sig_country=us&fb_sig_api_key=f8a72d89b2fd1158004e49bd6c6b7a0e&fb_sig_app_id=127890133926704&fb_sig=469d35a3590c1afb94d7f0fb377c7938 HTTP/1.1
    Host: www.strictlyonlinebiz.com
    User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    Referer: http://apps.facebook.com/strictlyonlinebiz/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/
    Cookie: 127890133926704_user=1825518; 127890133926704_session_key=2.w8Z9E4qN8Vz6x_jcI5v4fA__.3600.1284670800-1825518; 127890133926704_expires=1284670800; 127890133926704=4a072dd08c8f681232259fd41d380f90; base_domain_127890133926704=strictlyonlinebiz.com; wpmp_switcher=desktop; __utma=126679503.1441232194.1284578240.1284578240.1284664680.2; __utmz=126679503.1284664680.2.2.utmcsr=apps.facebook.com|utmccn=(referral)|utmcmd=referral|utmcct=/strictlyonlinebiz/; ki_u=652e5212-80b2-0261-2630-b42b36a6f457; ki_t=1284579981621%3B1284579981621%3B1284579981621%3B1%3B1; __utmc=126679503; base_domain_127890133926704=strictlyonlinebiz.com; 127890133926704=3cf2868b9f415ed5abac403b56239076; 127890133926704_user=1825518; 127890133926704_ss=xUPScIDVY3Undu7iO09C7Q__; 127890133926704_session_key=2.w8Z9E4qN8Vz6x_jcI5v4fA__.3600.1284670800-1825518; 127890133926704_expires=1284670800; fbsetting_127890133926704=%7B%22connectState%22%3A1%2C%22oneLineStorySetting%22%3A3%2C%22shortStorySetting%22%3A3%2C%22inFacebook%22%3Afalse%7D
    
    HTTP/1.1 301 Moved Permanently
    Date: Thu, 16 Sep 2010 20:51:19 GMT
    Server: Apache mod_fcgid/2.3.5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
    X-Pingback: http://www.strictlyonlinebiz.com/blog/xmlrpc.php
    X-Powered-By: W3 Total Cache/0.9.1.2
    X-Mobilized-By: WordPress Mobile Pack 1.2.3
    Link: <http://wp.me/pLutj-tG>; rel=shortlink
    Set-Cookie: wpmp_switcher=desktop; expires=Fri, 16-Sep-2011 20:51:19 GMT; path=/
    Vary: Accept-Encoding,User-Agent
    Location: http://apps.facebook.com/strictlyonlinebiz/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/
    Cache-Control: max-age=0
    Expires: Thu, 16 Sep 2010 20:51:19 GMT
    Content-Encoding: gzip
    Content-Length: 7664
    Keep-Alive: timeout=5, max=99
    Connection: Keep-Alive
    Content-Type: text/html; charset=UTF-8
    ----------------------------------------------------------
    http://apps.facebook.com/strictlyonlinebiz/strictlyonlinebiz-top-blog-posts-of-the-week-27/1840/
  8. Chukwudi Emmanuel Udegbunam
    Member
    Posted 3 years ago #

    The thing is I reactivated them after I tested the url and the loop of a thing still persisted. Could be a problem with my permalink or something?

    Anyway, not to worry. I've signed up for networked blogs so I'll be using their services in the interim. Thanks a lot for your supoort. Totally appreciate it ;-)

  9. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    I'm 90% certain it's a plugin conflict - more likely with the canonical feature of all in one SEO, or something else which is causing the redirection.

    WPBook uses a wordpress filter to change the permalink of each post to be the inside Facebook permalink - but for some reason your blog is constantly redirecting to that permalink. Most blogs just accept that the url they loaded doesn't match the permalink they expect.

    Taking a really quick look at All in One SEO, I didn't see it doing any redirection, just adding a canonical meta tag - shouldn't be a problem

    This would be some kind of plugin which is designed to make sure that what is loaded matches the permalink - usually frame-busting or maybe even the caching plugin W3 Total Cache?

    If you disable all other plugins and it still happens, let me know. ;)

    Then try re-enabling them one at a time until you find out which one it is.

  10. Chukwudi Emmanuel Udegbunam
    Member
    Posted 3 years ago #

    I'm making use of Scott Yang's Permalink Redirect since I've changed my blog's permalink structure 2 times in the past. Maybe that's the cause of the problem.

    The last time I deactivated the plug in, I had a tough time fixing things later on so I'm scared on deactivating it now. :-(

    Thanks anyway ;-)

    P.S: If it's possible to add a feature to have the entire post read ONLY @ the main site instead of facebook, that would help a lot ;-)

  11. johneckman
    Member
    Plugin Author

    Posted 3 years ago #

    Now you mention it! It's almost certain that Permalink Redirect is the culprit.

    From the plugin page:

    A WordPress plugin that replies a 301 permanent redirect, if requested URI is different from entry’s (or archive’s) permalink. It is used to ensure that there is only one URL associated with each blog entry.

    By definition your posts inside FB will have a url different than the entry's normal permalink.

    If you want to send users to your external blog, use the "promote external permalinks" option and WPBook will link to your external blog - the FB app view will still exist, but the wall excerpts will link to your external blog.

  12. Chukwudi Emmanuel Udegbunam
    Member
    Posted 3 years ago #

    I'm using that option already. My only fear is that my readers will click the more link which appears immediately after the post and then land on the "loopy page". It'd be nice if we could have the possibility of deactivating that link and having just the link to our blogs.

    Excellent plugin and support ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic