WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WPBook] : Caught Exception: User must have accepted TOS Error code: 200 (7 posts)

  1. PowerPro
    Member
    Posted 4 years ago #

    The site I've just finished re-designing is http://nenethomas.com

    Here is the application page:

    http://apps.facebook.com/nenethomas/

    The posts are showing up on the app page as you can see.

    But...when a post is generated, this is the error that shows up:

    Caught exception in checking extended permissions for page: User must have accepted TOS Error code: 200

    And the post is not showing up on the fan page here:

    http://www.facebook.com/#!/pages/Nene-Thomas-Illustrations-Inc/137911276220090?ref=ts

    I'm sure this has to do with the fact that I wasn't able to finish the instructions because I couldn't find some of the things that were referenced.

    For instance, I was able to enable Pages and User Profiles in Authentication... however...

    I did not find my application's About page and I don't see a "Page built by" link... so I need some help with that please in order to finish connecting the dots on this.

    Thank you!

  2. PowerPro
    Member
    Posted 4 years ago #

    The error also comes up when posting a page...and I didn't set it to post pages to Facebook.

    Help please. :S

  3. PowerPro
    Member
    Posted 4 years ago #

    Okay potentially good news... but a new question arises.

    I believe I have it added however...all I see is a box on the fan page.

    Am I misunderstanding this plugin? I thought that the blog posts would populate the wall.

  4. PowerPro
    Member
    Posted 4 years ago #

    On edit...

    I'm still getting the error message:

    Caught exception in checking extended permissions for page: User must have accepted TOS Error code: 200

    And after trying a new blog post, it still did not show up on the fan page.

  5. PowerPro
    Member
    Posted 4 years ago #

    I've turned off the error notifications to make it easier to post things... but I still need help getting blog posts show up on the Wall.

    Any help would be greatly appreciated!

  6. PowerPro
    Member
    Posted 4 years ago #

    Okay I have an update! I think it's now solved.

    For the help of others (and myself in the future if/when I have the same problems), I'll post things that I and reviewed to help figure this out but honestly, I don't know exactly what I did that worked.

    Here's one of the threads I referenced:

    http://wordpress.org/support/topic/386468?replies=22

    I ended up at this page because I had come across this post that provided some information about creating a Facebook app and having content posted to your wall...

    http://tech.karolzielinski.com/publish-post-of-facebook-page-wall-as-a-page-not-a-user-python-facebook-rest-api

    But I got an error with those instructions too. Error 100.

    So I reviewed what was said on this thread here:

    http://wordpress.org/support/topic/386468?replies=22

    And saw there was a manual hack for the theme/index.php page

    I tried that, and clicked the link to create the permissions, but I came up with the same page that told me what my Id was and that I'd need to enter it into WPBook's settings page on WordPress. There was the link to click to trigger extended permissions and then "Success" when that was clicked. However, I did that before and the only thing I was able to connect was to my personal FB page.

    So I changed theme/index.php back to the way it was before... and I tried clicking on the link in the WPBook set up to get the permissions to work again...but THIS TIME it was different.

    Now what I don't know was whether or not the old theme/index.php was the one it was relying on or the new one...but whatever...

    The point is...this time in addition to giving me my ID, there was a NEW link on the page that dealt with granting STREAMING PERMISSIONS that was not there before.

    So I clicked on it and lo and behold, I got the Facebook prompt to allow to post to the Fan Page Wall!

    I went to my fan page to confirm that this worked. I clicked on Edit Page in my fan page, looked at my application... did NOT see "additional permissions"...but when I clicked on Application Settings, a new tab was there for additional permissions. And sure enough, the settings were in place to post to the wall.

    I went back to the blog and posted an entry ...and it posted to the Wall. Success!

    Only hitch now...and I'll see if others have had a problem with this or not...but previous posts did not move over and I did check that box and post the number of previous posts to go. Beyond that...we're good.

  7. johneckman
    Member
    Posted 4 years ago #

    Sorry - just catching up with this whole thread.

    "previous posts did not move over" - not sure what you mean.

    WPBook doesn't provide a mechanism for automatically posting to the wall for posts which were already published - you'd have to unpublish and republish each post for that to happen.

    If all is working, can you please close the thread as resolved?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic