WordPress.org

Ready to get started?Download WordPress

Forums

WPaudio MP3 Player
Tips that might help (4 posts)

  1. biberkopf
    Member
    Posted 2 years ago #

    I have been using wpaudio before WP3 and shared a lot of the experiences aired in this thread. And now I seem to have ironed out my troubles. So I would like to share my findings with you (as of WP3.4.1 + WPAudio 3.1):

    1) You should make the change in the minified jQuery-code as mentioned in these threads

    http://wordpress.org/support/topic/no-mp3-play-button-just-a-link/page/2?replies=41

    http://wordpress.org/support/topic/plugin-wpaudio-mp3-player-does-not-work-in-wp-341?replies=6

    They are more less pointing to the same solution, but in this:

    http://wordpress.org/support/topic/does-not-work-with-latest-jquery-solution-provided?replies=4

    mrienstra has an interesting poing that the code might be case sensitive so an '.MP3'-extension will be ignored. I have not tested it. But good point.

    And in this flomincucci points out that she needed to do the changes in "both js files (wpaudio.js and wpaudio.min.js)". Interesting point.

    2) If you're still having trouble with the download button?!

    Here's what I found:

    The documentation mentioned that dl="0" will suppress the download link:

    [wpaudio url="/thepath/soundfile.mp3" text="the_title" dl="0"]

    Subsequently, I falsely assumed that dl="1" would activate the download function. But this turned out to disable my download link instead. So you simply have to leave it out an rely on the default behaviour which includes the default button.

    Hope this will cut a corner for some.

    http://wordpress.org/extend/plugins/wpaudio-mp3-player/

  2. oblax
    Member
    Posted 1 year ago #

    nice post biberkopf. Do you know how to play all the songs inside a directory in random pick?

  3. eaugustine
    Member
    Posted 1 year ago #

    I found another issue. I did make the change in both of the .js files, changing: {jQuery('a[href$=.mp3]').addClass('wpaudio');} to {jQuery('a[href$=".mp3"]').addClass('wpaudio');}

    But I noticed that my javascript files were both inactive and things were still not working. In the wpaudio.php file, there is a line that references the filepath, but it didn't match up with the actual filepath. So change this:
    define( 'WPAUDIO_URL', WP_PLUGIN_URL . '/wpaudio-mp3-player' );
    to
    define( 'WPAUDIO_URL', WP_PLUGIN_URL . '/wpaudio-mp3-player.3.1' );

    Together, those two changes fixed it for me.

  4. biberkopf
    Member
    Posted 1 year ago #

    @oblax No, I'm affraid I can't fix that. But for somebody who knows his or her php or javascript I believe it shouldn't be to hard. If you name your files 1.mp3, 2.mp3, 3.mp3 [...], n.mp3 all you have to do is to make a random logic that that pics a number between 1 and n, and insert it as the filename. But it's not really a wpaudio question. So perhaps you can find som shortcode that will do it for you.

    @euaugustine Good point. I haven't had the problem myself. I wonder why???

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic