WordPress.org

Ready to get started?Download WordPress

Forums

WP2Cloud
[resolved] Can't install ClouSE (6 posts)

  1. AWOL
    Member
    Posted 1 year ago #

    Hi,
    I am really interested in trying to get this to work but I am stuck on the installation of ClouSE. I believe I have done everything correctly but when i run the Install query in SQL
    INSTALL PLUGIN ClouSE SONAME 'ha_clouse-5.5.14.so';
    I get this message
    #1142 - INSERT command denied to user 'xxxxx'@'localhost' for table 'plugin'

    I am on shared hosting, and I have already asked my host (JustHost) if I should be able to do this and they said I can. The only thing is that the MySQL version is not the same as any of the ha_clouse... files, so is that what the problem is? It is the 5.1.65-community-log version so how am i meant to do this? Please help as I really need this!

    http://wordpress.org/extend/plugins/wp2cloud-wordpress-to-cloud/

  2. Artem Livshits
    Member
    Plugin Author

    Posted 1 year ago #

    Hi AWOL,

    ClouSE only supports MySQL v5.5.14+.

    Can you move to a more recent version of MySQL?
    Does your hoster plan to upgrade MySQL?

    It is expensive for us to support a wide range of MySQL versions. As we have not seen a good number of requests for the older version support from our Beta users, we have not added it.

  3. AWOL
    Member
    Posted 1 year ago #

    Hi,
    Thanks for your answer. I think the problem is because I am on shared hosting, and as far as I know I cannot upgrade the MySQL and have to wait for JustHost to do it. I'm not even sure that is the reason it wouldn't allow me to install given the message i got, so i think that possibly I do not have the permissions to carry out the installation. I would think that there will be quite a lot of other potential 'customers' for your plugin that will be in the same boat, although i am a little surprised that JustHost does not have a more up to date version of MySQL.

    I am now trying out another plugin to achieve the same thing in a slightly different way, and easier too, but I don't know yet if it will work as I wish. Thank you for your efforts anyway and if my host ever updates MySQL I will take another look.

  4. Artem Livshits
    Member
    Plugin Author

    Posted 1 year ago #

    Hi AWOL,

    You make a good point. Thank you for the feedback.

    If you could contact your hosting provider we'll try to see how to enable a solution that will work for all parties.

  5. kindnation
    Member
    Posted 11 months ago #

    Any plan to support 5.1.x? My control panel uses 5.1.69 and i dont think i can change it without breaking it. And does this support Multisite?

  6. Artem Livshits
    Member
    Plugin Author

    Posted 11 months ago #

    Hi kindnation,

    We looked into it and it looks like integrating with MySQL 5.1.x is a significant amount of work (the plugin APIs got significantly changed in 5.5.x). We'll look at it again after we get ClouSE out of Beta.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.