WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-UserOnline] WP useronline 2.7.2 (51 posts)

  1. Large Purse
    Member
    Posted 3 years ago #

    2.7.2 fatal errors and I have reloaded previous version until 2.7.2 works

    http://wordpress.org/extend/plugins/wp-useronline/

  2. scribu
    Member
    Posted 3 years ago #

    For future reference, it would be really useful if you actually posted the error text when reporting a problem. Thanks.

  3. beardedgit
    Member
    Posted 3 years ago #

    Probs here too:

    %MOSTONLINE_DATE% always returns current time and date.

  4. scribu
    Member
    Posted 3 years ago #

    @beardedgit: can't reproduce.

  5. beardedgit
    Member
    Posted 3 years ago #

    Hi scribu

    I've reinstated the output in the sidebar of my blog ( http://beardedgit.com/ )

    The code I'm using is:

    Highest number of Users browsing this site at one time:<br />%MOSTONLINE_COUNT% on %MOSTONLINE_DATE%
    <br /><br />
    %USERS% browsing now:

    Does that help?

  6. infected
    Member
    Posted 3 years ago #

    There are some php errors after manually update from 2.6. I can't remember what they're about. I deactivated and activated it again and they arent shown anymore. But now the plugin doesnt count any users. No registered users, no visitors, no bots. It shows always 0 Users online.

    PS: Server runs on php5; WP 2.9.2, wp-useronline 2.72

  7. steff3107
    Member
    Posted 3 years ago #

    I actually updated WP Users Online from 2.6x to 2.72. As descriped by "infected", the new version doesn't count any users.

  8. Tecno
    Member
    Posted 3 years ago #

    The automatic update did not work,(fatal error ) but the plugin is curiously active, but the settings page is not accessible ("Empty form Error on Page-navi on line 38" This is the message)
    Deleted and reloaded plugin manually: no installation problem, but always 0 users online

  9. scribu
    Member
    Posted 3 years ago #

    Try installing the development versions of both plugins:

    WP-PageNavi (2.73-alpha).

    WP-UserOnline (2.73-alpha).

  10. beardedgit
    Member
    Posted 3 years ago #

    Damn. Tried 2.73-alpha and the most-online count has reset.

    Could live with losing that if the rest worked, but it doesn't.

    I'm scrubbing the whole shebang, so don't go looking for it in the sidebar like I suggested above.

  11. Tecno
    Member
    Posted 3 years ago #

    All done
    I installed Wp-PageNavi 2.73 beta and Wp-UserOnline2.73beta
    everything works
    No problem to install, no errors in admin panel
    only ..online users are always "0"

  12. scribu
    Member
    Posted 3 years ago #

    @beardedgit: sorry to hear that.

    @steff3107 and @Tecno: It looks like the database table is not created / updated.

    Your best bet would be to uninstall the plugin (from the WP admin) and then re-install it.

  13. Bubbles00
    Member
    Posted 3 years ago #

    Do we have to install both the plugins again even if one is giving error? I got the fatal error after upgrading the wp-useronline plugin to version 2.71

    Fatal error: Call to undefined method scbOptions::get_key() in /home/user/public_html/wordpress/wp-content/plugins/wp-useronline/admin.php on line 56

    but my wp-page navi works fine. I tried deleting the useroline plugin and uploaded the alpha version mentioned here but could not activate it.

    I got this message: Plugin could not be activated because it triggered a fatal error.

    What to do? Please help.

  14. evilpixy
    Member
    Posted 3 years ago #

    Did inactivate - reactivate : still 0 visitors
    Uninstalled the plugin and installed it again : still 0 visitors
    Completely removed the plugin, downloaded it and installed it : still 0 visitors

    So, what do we do now...can this be fixed or should I just download another "visitors" plugin that works?`

    /EvipPixy

  15. beardedgit
    Member
    Posted 3 years ago #

    @scribu:

    No problems, I'll monitor this thread and reinstall when it's fixed. The annoying thing is that I had the previous version running just fine for months with no hassle, reporting everything accurately and displaying correctly. It only broke when somebody "fixed" it.

    Incidentally, I use the "Changelogger" plugin ( http://www.schloebe.de/wordpress/changelogger-plugin/ ) which keeps saying of all of your recent revisions "Compatibility with WordPress 2.9.2: 100% (according to its author)". Clearly this is incorrect, so it might be worth you looking into this, as it's either an erroneous claim or a fair statement based on erroneous source data. Either way, for the punter it's a let-down when things go t1t5-up.

    Good luck getting this sorted.

  16. infected
    Member
    Posted 3 years ago #

    Alpha still doesn´t work. 0 User count.

    It only broke when somebody "fixed" it.

    *Thumbs Up!*

  17. scribu
    Member
    Posted 3 years ago #

    To anyone who's seeing 0 visitors:

    I could really use an admin account to take a look at the database table for myself (I need to be able to edit the plugin files). My email is scribu@gmail.com

  18. maitremo
    Member
    Posted 3 years ago #

    Hi again, Scribu,

    And in any case thank you for your work !

    So, I have only my own pwd and login to ftp and so on, and don't know how to create one just for you, but what I can say is that :

    - I had a table named "useronline" before, and no more now (only "users" I think)

    - I have had the same problem once, a long time ago, with Lesterchan, and he answered me by the php code to create the table manualy, and it worked -I don't find the topic on Lesterchan forum, but it was there, and I think it's the same kind of problem.

    Perhaps can you tell us what table we are suposed to have, and how to create it if we don't have ?

  19. Tecno
    Member
    Posted 3 years ago #

    I compared the databse of two sites with different versions of wp-useronline (2.7.0 and 2.7.2)
    The site database with the latest version of the plugin, there is no table wp-useronline

  20. maitremo
    Member
    Posted 3 years ago #

    I found the old topic on the forum : http://forums.lesterchan.net/index.php/topic,3011.msg22546.html#msg22546

    Do you think we have to run the same request now ?

  21. maitremo
    Member
    Posted 3 years ago #

    OK : IT WORKS !!!

    It was the same problem that the older one, exposed in this topic : you just have to apply it (go to your database with phpmyadmin, create the table following the Lestechan code) , and then disable and re-activate Useronline, and users are there again !

    5sorry for my bad english, it's joy !)

  22. Tecno
    Member
    Posted 3 years ago #

    Thank's maitremo, but..
    I do not think most users can do this!

    this is a mistake of this plugin and are trying to solve
    manually edit the database is not the policy of wordpress

    That's i think

  23. evilpixy
    Member
    Posted 3 years ago #

    Can't someone create a simple hot-fix? I'm not ready to play around in my database file (i.e just a simpla coder, not über-micro-super-haxxor)

    Please....maybe a 2.73 could fix it problem?

  24. Tecno
    Member
    Posted 3 years ago #

    but..

    I tried that .. (like the old topic on the forum : http://forums.lesterchan.net/index.php/topic,3011.msg22546.html#msg22546 )
    It does not work
    Now when I activate the plugin I receive a statement of "fatal erorr"

    The plugin works strangely, but users are always "0"

  25. Tecno
    Member
    Posted 3 years ago #

    Off topic ..
    I have many websites!

    In one of these after the first update (2.7.1) the site went down for "fatal error"!
    I removed the plugin from automatic update and installed it manually, and everything went fine .. But only in that site!
    Sorry!

  26. Bafan
    Member
    Posted 3 years ago #

    I think that ... the right thing to do is install the old version ..

    http://wordpress.org/extend/plugins/wp-useronline/download/

    ( I recommend the 2.62 version )

  27. scribu
    Member
    Posted 3 years ago #

    @MaitreMo: please note that the table structure has changed.

    @Tecno: please post the exact text of the fatal error.

    The database table is supposed to be created when activating the plugin.

    If you get a fatal error on activation, the table will likely not get created.

    What MySQL version do you guys have?

  28. evilpixy
    Member
    Posted 3 years ago #

    @ Scribu - MySQL version: 4.1.22

  29. Tecno
    Member
    Posted 3 years ago #

    the exact text (italian):
    Il plugin non può venir attivato perché genera un errore fatale.
    (Traslate: The plugin could not be activated because it triggered a fatal error.)
    There are no other indications
    but..

    - the plugins is active in a WP Plugins list (but doesn't work correctly - users always zero)

    -Version MySQL: 5.0.82sp1-log

  30. Tecno
    Member
    Posted 3 years ago #

    error on
    UserOnline Options

    Warning: Empty name in /web/htdocs/www.mysite.it/home/wp-content/plugins/wp-pagenavi/scb/Forms.php on line 38

    (if a try to install the beta version of plugins (PageNavi,UserOnline), this error vanished, but the plugin doesn't work)

Topic Closed

This topic has been closed to new replies.

About this Topic