WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-UserOnline] Link leads to back-slashed link and 404 page (11 posts)

  1. sleeplessinDC
    Member
    Posted 4 years ago #

    I've installed version 2.61. The link to the Users Online page now includes a repeat of the link with back slashes surrounding it and takes me to a 404 Not Found page. This didn't happen in version 2.50. No other links to other pages on this site do this.

    The link is generated as:
    http://www.stc-access.org/\"http://www.stc-access.org/useronline/\"

    Here is what shows up when I view source:

    <div id="useronline-3" class="widget widget_useronline"><h4>Users Online</h4>

    </div>

    1. WordPress Version 2.9.1
    2. Theme Name Dojo 5.1.3 by Scott Vandehey
    3. Blog URL http://www.stc-access.org
    4. Problem Plugin Name And Version WP-UserOnline 2.60
    5. PHP And MYSQL Version PHP 5.2.12, MySQL 5.0.88-userstats-log

    http://wordpress.org/extend/plugins/wp-useronline/

  2. sleeplessinDC
    Member
    Posted 4 years ago #

    Corrections: The version I'm using of WP-UserOnline is 2.61
    I didn't use the correct tagging to show the code that shows when I view the source. Here it is with the correct tagging:

    <br />
    <pre><code><div id="useronline-3" class="widget widget_useronline"><h4>Users Online</h4><ul>
    <li><div id="useronline-count"><a href=\"http://www.stc-access.org/useronline/\" title=\"2 Users\"><strong>2 Users</strong> Online</a></div></li>
    </ul>
    </div>
  3. scribu
    Member
    Posted 4 years ago #

    Try updating the plugin settings.

  4. bseidner
    Member
    Posted 4 years ago #

    I am have sort of the same problem but this is what shows up as the link:
    http://www.seidnershouse.com/%22http://www.seidnershouse.com/index.php/useronline//%22
    I updated the settings and still is the same. The database shows the correct url. My url is suppose to be http://www.seidnershouse.com/index.php/useronline/

  5. bseidner
    Member
    Posted 4 years ago #

    I have found the fix when updating the plugin it keeps the old User(s) Online: template. To fix it click the restore default template then save settings.

  6. mvdstroom
    Member
    Posted 4 years ago #

    Same problem for me, does not work anymore after update. I get a messed up URL like: "http://www.dixiclan.nl/%22http://www.dixiclan.nl/?page_id=226\%22"

    Settings are all default, and even tried to update settings. Did not help!

  7. scribu
    Member
    Posted 4 years ago #

    @mvdstroom: try deleting the plugin from the WP admin and then reinstalling it.

    Note: deleting the plugin using FTP won't have the same effect.

  8. thegreatco
    Member
    Posted 4 years ago #

    I didn't have to delete mine, I just hit the restore defaults button. That fixed it. Thanks @bseidner

  9. lbyd
    Member
    Posted 4 years ago #

    Try this, works fine for me:
    WP-Admin -> Settings -> UserOnline

    In Useronline Templates you will find this
    User(s) Online:

    <a href=\"%USERONLINE_PAGE_URL%\" title=\"%USERONLINE_USERS%\">%USERONLINE_USERS% Online</a>

    Just remove all back-slashed:

    <a href="%USERONLINE_PAGE_URL%" title="%USERONLINE_USERS%">%USERONLINE_USERS% Online</a>

    Work for me
    http://listenbeforeyoudie.com

  10. Michael Johansen
    Member
    Posted 4 years ago #

    Just try to click the restore default template then save settings.
    That should do the trick :)

    Michael

  11. dutchblogger
    Member
    Posted 4 years ago #

    changed \ to solution lbyd. works now fine
    johan
    http://www.manindezorg.nl

Topic Closed

This topic has been closed to new replies.

About this Topic