WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: wp-Typography] WP-Typography Problems.... (12 posts)

  1. genesteinberg
    Member
    Posted 4 years ago #

    All right, I like the concept, as an old typography professional who worked in that field in the 1970s and 1980s.

    Two problems.

    It nearly doubles the time it takes for WordPress to render the page.

    It ads the last word or two at the beginning of a headline, so "Newsletter Issue #503" will have a 503> at the beginning of that headline.

    Clues?

    Answers?

    Peace,
    Gene Steinberg

    http://wordpress.org/extend/plugins/wp-typography/

  2. kingjeffrey
    Member
    Posted 4 years ago #

    Gene,

    Both of these issues are addressed in the wp-Typography FAQs, but I'll summarize here:

    1. There is a tremendous amount of processing that is done for each page load. Load times are slower. My experience, for a normal blog post, load times remain below 1 second. For a complicated front page, it can near 2 seconds. I highly recommend you use WP Super Cache with wp-Typography.
    2. You are seeing the extra characters at the beginning of each title because your theme uses the wrong function to provide the title attribute to the headings' links. Your theme uses the_title() which provides the post title after any plugin filtering. This will cause complications whenever injected in an HTML attribute. Your theme should use the_title_attribute() which provides the post title without plugin processing. If you are uncomfortable editing your themes, you can enter h1 and h2 into the excluded HTML elements field in the wp-Typography settings to turn off all typographic processing of your headings.
  3. genesteinberg
    Member
    Posted 4 years ago #

    1. We use a caching plugin, and have a powerful dedicated server. But load times are still around 1 second. We're used to a fraction of that.

    2. I didn't do the theme. That person left us a long, long time ago. I welcome help, but will make that change in the meantime.

    Peace,
    Gene

  4. kingjeffrey
    Member
    Posted 4 years ago #

    With the caching plugin, the load time will be the same for the first page load. After that, no processing will occur until the cache expires. Note that if you view the source, often themes include a timer output at the bottom. That output is cached as well. So if it takes 1 sec. for the first load, it will continue to say "1 sec." as long as the cached version is served (even though the cached version is loading much quicker).

    To edit the theme, log in as an administrator and go to: Appearance > Editor. You will typically want to edit the following files (if they exist):

    • archive.php
    • index.php
    • page.php
    • search.php
    • single.php

    In each file, search for the code that looks something like this:

    <h2><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><?php the_title(); ?></a></h2>

    There may be some variations. For instance, the h2 tags may be h1 or h3... It should be changed to:

    <h2><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h2>

    Save the files, and you should be good to go.

  5. genesteinberg
    Member
    Posted 4 years ago #

    Files are modified.

    I'll try the plugin again shortly.

    Peace,
    Gene

  6. kingjeffrey
    Member
    Posted 4 years ago #

    Best of luck.

  7. genesteinberg
    Member
    Posted 4 years ago #

    OK, not bad. But our archiving plugin, Smart Archives Reloaded, takes 5 seconds to load a page, whereas it's less than .5 second without your plugin.

    Peace,
    Gene

  8. genesteinberg
    Member
    Posted 4 years ago #

    OK, here's an update:

    I see that the the_title_attribute() command is not actually standard in the default or classic WordPress themes. When I use them for titles, they no longer recognize manual line breaks. How do I resolve that?

    I'd love to try this thing, especially with the promise of 25% better performance, but it would be helpful to have a better understanding of what I need to do to get it to work and not break my setup.

    Peace,
    Gene

  9. jamesjm
    Member
    Posted 4 years ago #

    You're actually better off not using title="" on your links. When you do have them included, users of screenreaders are likely to hear it as well as the linked text.

    e.g. Permanent Link to 10 Tips To Improve Your Loading Time, 10 Tips To Improve Your Loading Time.

    Imagine that for all the articles/links on your front page!

  10. genesteinberg
    Member
    Posted 4 years ago #

    Hmmm... Well, if you have a few moments to possibly help me with the theme/css files, I'd be delighted to work this out. My PHP/theme/css skills are little to none.

    Peace,
    Gene

  11. genesteinberg
    Member
    Posted 4 years ago #

    Meantime, I want to prevent your plugin from working on the following page:

    http://www.macnightowl.com/the-mac-night-owl-archives/

    And:

    http://www.macnightowl.com/newsletter/the-tech-night-owl-newsletter-archives/

    It slows them down a lot, especially the first.

    Suggestions?

    Peace,
    Gene

  12. kingjeffrey
    Member
    Posted 4 years ago #

    Gene,

    As far as I am aware, WordPress does not provide a means for plugins to know what page is being processed. As such, there is no way to directly block a URL from processing.

    You could edit that page and wrap the entire content area in a <div class="noTypo">, and verify the class "noTypo" is included as an excluded class in the wp-Typography options page.

Topic Closed

This topic has been closed to new replies.

About this Topic