WordPress.org

Ready to get started?Download WordPress

Forums

WP to Twitter
WP-to-Twitter: plugin install (7 posts)

  1. massimo6342
    Member
    Posted 2 years ago #

    Hi there, I uploaded the wp-to-twitter folder to my /wp-content/plugins/ directory but it does not show in my installed plugin list. If I try to install it (again) as new it says that it is already installed. What am I doing wrong? Thank you for your help, Massimo

    http://wordpress.org/extend/plugins/wp-to-twitter/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 2 years ago #

    Does the directory (and files) have read permissions on the file server?

  3. massimo6342
    Member
    Posted 2 years ago #

    Joe, thank you for your reply and excuse me for the long delay in answering but I manage just the WordPress part of a site and I had to ask the site manager for the info.
    As fa as I can understand all plugins are in the same situation including the plugins folders:
    public_html: read, write exec for owner permission, read, exec for group permission, none for public permission
    wp-content: same as above but read for public permission
    plugins: same as wp-content
    wp-to-twitter: read, write exec for owner permission, read, exec for group permission, read, exec for public permission
    None of the above folders have the "subfolders included" marked.
    I checked other different working plugins folders and they share the same definitions.
    Thank you very much for your help, Massimo
    P.S. I have the "images" of the above analysis and, if required, I can send them to you via email.

  4. Joe Dolson
    Member
    Plugin Author

    Posted 2 years ago #

    Well, that should be fine. Odd. Are you in a multi-site installation? If you are, it needs to be network enabled before it'll show up for a sub-site.

  5. massimo6342
    Member
    Posted 2 years ago #

    Joe, thanks again. We have a main site (http://www.associazioneamuse.it/) and WordPress is installed on the server running the main site in a proper folder. We also registered the address of the WordPress site (http://www.romaduenews.it/) and our provider reroutes people asking for the latter to the correct folder of the main site. I hope this is understandable (not sure about the terminology) and answers your question. I am sorry but all sites are in Italian. Thanks, Massimo

  6. Joe Dolson
    Member
    Plugin Author

    Posted 2 years ago #

    All right. With the URL, I was able to take a look and I found that you have WP to Twitter nested one directory too deep -- it's at /wp-content/plugins/wp-to-twitter/wp-to-twitter/ -- it should be at /wp-content/plugins/wp-to-twitter/. Move it one directory down and I'm guessing you should be fine.

    Also, you may want to consider locking your directory structure from being browseable - from a security standpoint.

  7. massimo6342
    Member
    Posted 2 years ago #

    Joe, thank you very much. We followed your suggestion, wp-to-twitter appeared on our plugins list and I was able to activate it. Our site is now happily twitting. Thank you again for your help and suggestions, ciao Massimo

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic