WordPress.org

Ready to get started?Download WordPress

Forums

WP to Twitter
Support requests won't send (5 posts)

  1. stevemagruder
    Member
    Posted 2 years ago #

    When I send a support request, it lands on a 404 page.

    Perhaps related, at the beginning of the support section, after "Support requests without a donation will not be answered, but will be treated as bug reports.", it shows the following warnings:

    Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /home/webcomm/public_html/wp-includes/functions.php on line 4339
    
    Warning: fopen(http://www.webcommons.biz/wp-content/plugins/bwp-minify/min/?f=wp-content/themes/mandigo/style.css&ver=empty) [function.fopen]: failed to open stream: no suitable wrapper could be found in /home/webcomm/public_html/wp-includes/functions.php on line 4339
    
    Warning: fread(): supplied argument is not a valid stream resource in /home/webcomm/public_html/wp-includes/functions.php on line 4342
    
    Warning: fclose(): supplied argument is not a valid stream resource in /home/webcomm/public_html/wp-includes/functions.php on line 4345

    Here's system info:

    PHP Version: 5.2.17
    Server Software: Apache/2.2.21 (Unix) mod_ssl/2.2.21 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
    User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0

    Please let me know if there's any additional info I should send.

    http://wordpress.org/extend/plugins/wp-to-twitter/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 2 years ago #

    You know, I've seen that set of errors once before; and I couldn't trace it to anything in my plug-in at all. I do note that another plug-in is referenced in those errors - is that generating any errors, as well?

  3. stevemagruder
    Member
    Posted 2 years ago #

    No other errors are appearing from the Better WordPress Minify plugin. From all indications outside of this issue, this plugin is working as it should.

  4. stevemagruder
    Member
    Posted 2 years ago #

    I deactivated Better WordPress Minify to send the report, so you can see the plugins I'm using that may trigger the other issue (page edit tweets when page not edited).

    But even with that gone, these warnings are appearing:

    Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /home/webcomm/public_html/wp-includes/functions.php on line 4339
    
    Warning: fopen(http://www.webcommons.biz/wp-content/themes/mandigo/style.css) [function.fopen]: failed to open stream: no suitable wrapper could be found in /home/webcomm/public_html/wp-includes/functions.php on line 4339
    
    Warning: fread(): supplied argument is not a valid stream resource in /home/webcomm/public_html/wp-includes/functions.php on line 4342
    
    Warning: fclose(): supplied argument is not a valid stream resource in /home/webcomm/public_html/wp-includes/functions.php on line 4345

    These are possibly appearing because my host expects their users to use cURL instead of the standard remote file functions.

  5. Joe Dolson
    Member
    Plugin Author

    Posted 2 years ago #

    Actually, I've got this issue resolved -- I don't know why BWM is preventing the form from submitting, but the fopen errors are coming from the call which is fetching theme and plug-in information in your support request. It's because you're on a host that disallows URL wrappers for file queries. I have a fix, and will take care of this soon.

    Thanks -

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic