WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP to Twitter] Quotes in title truncate Tweet after " (7 posts)

  1. edwardnh
    Member
    Posted 4 years ago #

    When my post title contains quotation marks in the title (""), I get a tweet that truncates the title at ". Is there anyway to fix this - or is this a WordPress problem?

    http://wordpress.org/extend/plugins/wp-to-twitter/

  2. Joe Dolson
    Member
    Posted 4 years ago #

    I'll check on it - quotes are a pain, and frequently cause problems - I'll have to see exactly where this problem is coming from before I can answer with any specificity. Could well be my fault!

  3. Joe Dolson
    Member
    Posted 4 years ago #

    Are you using straight quotes, or are you cutting/pasting and providing some other type of quote? I have not been able to reproduce this problem, and I'm wondering if you're doing something other than simply typing quote marks in the title.

  4. edwardnh
    Member
    Posted 4 years ago #

    Joe, I might have a title like Whitney Tilson: "A pullback of some sort is likely" (http://www.creditwritedowns.com/2009/11/whitney-tilson-a-pullback-of-some-sort-is-likely.html)

    WordPress reads this as Whitney Tilson: "A pullback of some sort is likely" (note: I just had the & quot sign before A and after likely, and it was replaced by the text editor here.)

    So what happens when I go to post this is the Tweet comes out Whitney Tilson: &q

    And that's it. It truncates the title because it get's stopped out somehow. I have avoided using "" in titles for this reason now, but here's a tweet showing you:

    http://twitter.com/edwardnh/statuses/10236249441

  5. edwardnh
    Member
    Posted 4 years ago #

    Joe, here is another example from a recent tweet:

    Links: 2010-03-18 – Overheating in Asia and more on China http://bit.ly/bgVvco #Asia #China #financialnews $$

    http://twitter.com/edwardnh/statuses/10664526922

    It shows up in the valid way on Twitter Search but on TweetDeck it does not. Any thoughts as to whether it's a TweetDeck problem?

    The #hashtag thing is fixed though!

  6. Joe Dolson
    Member
    Posted 4 years ago #

    So you're actually typing in the entities for quotes, rather than typing quotes - is that correct? That could be causing the problem, actually - WordPress normally takes care of quotes, so I wasn't checking for entities. I'll look into that.

  7. edwardnh
    Member
    Posted 4 years ago #

    Joe, it's more that I use Live Writer and the entry titles with quotes show up this way in the WordPress header.

Topic Closed

This topic has been closed to new replies.

About this Topic