WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: wp Time Machine] Installation failed on WP 2.9.2 (21 posts)

  1. nicolargo
    Member
    Posted 4 years ago #

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected ')', expecting '(' in /home/www/nicolargo.com/blog/wp-content/plugins/wp-time-machine/wp-time-machine.php on line 556

    http://wordpress.org/extend/plugins/wp-time-machine/

  2. paulgpetty
    Member
    Posted 4 years ago #

    Nico --

    I'm working on an update to message what that error is really about:

    PHP 5

    ... the plugin requires PHP 5 running on your server.

    Sorry for the inconvenience.

    You may want to see if it's possible to turn on PHP 5 ...

    Media Temple makes switching from PHP 4 to 5 a breeze, for example.

    Paul

  3. paulgpetty
    Member
    Posted 4 years ago #

    ... as a follow up, for what it's worth the plugin now gracefully checks for & alerts Admins when the plugin will turn out to be incompatible.

    This is a part of version 1.3.0 & should be noted here shortly:

    http://wordpress.org/extend/plugins/wp-time-machine/changelog/

    Paul

  4. aco_pa
    Member
    Posted 4 years ago #

    Using PHP 5.3.2 and WP 2.9.2, I get this error message using plugin version 1.3.0.

    Parse error: syntax error, unexpected '}' in /srv/www/htdocs/wp-content/plugins/wp-time-machine/includes/wpTimeMachineCore.php5 on line 585

  5. paulgpetty
    Member
    Posted 4 years ago #

    Hello,

    I just checked ... my host (MediaTemple.net w/ Grid Service is using 5.2.6) ...

    I'll set up 5.3.2 shortly & debug what you're seeing there.

    Paul

  6. paulgpetty
    Member
    Posted 4 years ago #

    @aco_pa:

    I just committed an update for the plugin:

    Version 1.3.2 resolves an issue I was able to reproduce ...

    It may or may not be the same issue you experienced.

    If you're willing let me know how installation goes with the new version.

    An easy way to install it aside from the method you chose previously is as follows (IF you have ssh access & subversion installed / available):

    Just navigate to your plugins direct via ssh & type this and hit enter:

    svn co http://plugins.svn.wordpress.org/wp-time-machine/trunk/ ./wp-time-machine

    Look at the readme.txt to verify versions ...

  7. aco_pa
    Member
    Posted 4 years ago #

    Thanks Paul,

    Sorry for the delay, I checked out revision 228585, the readme says 1.3.3. I still get the same error.

    Parse error: syntax error, unexpected '}' in /srv/www/htdocs/wp-content/plugins/wp-time-machine/includes/wpTimeMachineCore.php5 on line 605

  8. brokenflipside
    Member
    Posted 4 years ago #

    very similar error here as well...

    Parse error: syntax error, unexpected '}' in C:\...\Test\wp-content\plugins\wp-time-machine\includes\wpTimeMachineCore.php5 on line 673
  9. paulgpetty
    Member
    Posted 4 years ago #

    aco_pa,

    Can you try the latest revision (at 1.7.0 as of this writing).

    brokenflipside,

    Can you re-test with latest & provide the version of PHP running on your site? Are you using XAMPP or something or a real host via Windows?

    Paul

  10. aco_pa
    Member
    Posted 4 years ago #

    Thanks for all your work. I have high hopes for this. Looks like I get the same error. Is there anything else I can give you to help with your debugging?

    Parse error: syntax error, unexpected '}' in /srv/www/htdocs/wp-content/plugins/wp-time-machine/includes/wpTimeMachineCore.php5 on line 673

  11. paulgpetty
    Member
    Posted 4 years ago #

    aco_pa,

    Can you upload a file called info.php w/ just this code in it & post the response you see here?

    <?php phpinfo(); ?>

    Paul

  12. maartenzuidland
    Member
    Posted 4 years ago #

    Hi,

    I'm having the same issues with the plugin. I'm not really finding any documentation on this issue, but this thread.

    I've just updated to the 1.7.3 version, and still see the same error before activating.
    my phpinfo can be found at http://www.maartenzuidland.nl/phpinfo.php
    (short version: php 5.3.2, on freebsd 8.0 with apache 2.2.14 and mysql 5.5.4)

    the one catch though, the website I want to use the plugin on, can be reached through http://www.parochiedrunen-elshout.nl, but is hosted on the exact same machine (virtual host). Not sure if this will be any help, but to make sure you can have all the information you might possibly need.

  13. paulgpetty
    Member
    Posted 4 years ago #

    maarten --

    If you're willing try updating to the latest version 1.7.7 ...

    I've been testing with PHP 5.2.6 & 5.3.1 and the plugin works; I'll upgrade to 5.3.2 shortly as that seems to be pretty popular or at least where most people seem to have trouble.

    But I'm also optimistic that the latest build might work too,

    Paul

  14. number3nl
    Member
    Posted 4 years ago #

    Hi Paul,
    I noticed that the plugin was moved to 1.7.7 so I tried to get it working again. No luck. Is there a way to see if the files get generated at all? The files do not get moved over to dropbox.

    Also when clicking on backup it only takes about 2 secs before it tells me that its done. Not very believable IMHO, I mean dumping my database normally takes about 10 secs (and up to a minute) depending on the traffic on my hosting provider.

    So I am not sure if the backup files get generated at all... they are not showing up at the dropbox account.

    Also is it possible to have a "test" button. To validate that the remote copy (using FTP, Dropbox or S3) works at all... This would enable the user to pinpoint the "issue" before getting back to you.

    Thanks for your work on this.

  15. maartenzuidland
    Member
    Posted 4 years ago #

    Hi Paul,

    just upgraded to 1.7.8 through the automatic upgrade process, and unfortunately it still gives me the error upon activating the plugin :(

    Parse error: syntax error, unexpected '}' in /usr/local/www/www.parochiedrunen-elshout.nl/wordpress/wp-content/plugins/wp-time-machine/includes/wpTimeMachineCore.php5 on line 644

  16. paulgpetty
    Member
    Posted 4 years ago #

    Hi

    I just released version 1.7.9 ... If you could update the plugin & test it; I would be grateful.

    I think this resolves a serious issue with PHP 5.3.x ...

    maartenzuidland, I'm not sure this will address your issue with the plugin; so I'm anxious to here how it goes.

    Paul

  17. maartenzuidland
    Member
    Posted 4 years ago #

    Unfortunately, still no.... Same error...

    I've checked the following:
    * I didn't parse .php5 before, added this to my configuration
    (which should not be an issue, as you require the content of the file, and it gets parsed through the original php file.... right?)

    * I had different file permissions, now changed all contents and subfolders to 774 (upload user is in the same group as the webserver user) (To be sure...)

    * add the plugin to another domain I run on the same server (is a replication of the other version though from a while back) and reproduced the error there.
    * and to be sure, just created a fresh instance....

    when I try to load the plugins/wp-time-machine/includes/wpTimeMachineCore.php5 file directly in the browser, I see no code or output (not sure if I would see anything, but it does not give me any errors either

    I can provide you access to a test environment I have, which has the same issues... But we're better to not discuss that on the forum.

  18. maartenzuidland
    Member
    Posted 4 years ago #

    It loads!

    what have I changed? I've edited the file plugins/wp-time-machine/includes/wpTimeMachineCore.php5 to replace all instances of <? to <?php

    In my php.ini I have turned the shortened use explicitly off...

    I'm now trying to get the FTP part working....

  19. maartenzuidland
    Member
    Posted 4 years ago #

    I've been going through the source code, because I saw some problems with my FTP workings.

    Most likely related to my setting in php.ini: "<?=" I've replaced all the instances with "<?php echo "

    I'm now trying to figure out why my sql files are empty...

    btw. the changes I'm proposing should also work on servers who have the shortening turned on. I see you used a mix between the shortening and long form in your code.

  20. paulgpetty
    Member
    Posted 4 years ago #

    maarten,

    I just checked in 1.8.1 ... the only change is removing all PHP shorthand ...

    Thanks for the catch,

    Paul

  21. paulgpetty
    Member
    Posted 4 years ago #

    Also,

    I can be reached at paulgpetty [ at ] gmail [ dot ] com ...

    I'm working out some debugging feedback, but if you have Firefox & Firebug you can look at AJAX responses there & search for pre tags in the response to see existing feedback ...

    Paul

Topic Closed

This topic has been closed to new replies.

About this Topic