WordPress.org

Ready to get started?Download WordPress

Forums

WP-Table Reloaded
[resolved] [Plugin wp-table-reloaded] Won't save any setting changes, including page nav (11 posts)

  1. antorera
    Member
    Posted 1 year ago #

    Hello, The search function on the table is really helpful, especially for my table of 1300 rows!

    I'm using the javascript options built into the table for such a large list (search, etc.). It seems that the default number of rows shown is 10. But we want to open the page with 25 rows of data. However, any time I change any of the settings, it doesn't take. I try to update changes or save and go back, with no effect. I even tried uploading a new table and it didn't work.

    I also can't save any data changes I make in the table.

    The table is located here.

    We have the memory limit set at maximum in the wp-config file, so don't think it's a size issue.

    Any ideas would be appreciated. Thanks.

    http://wordpress.org/extend/plugins/wp-table-reloaded/

  2. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for your post, and sorry for the trouble!

    Very likely this is due to a change in the default configuration in PHP 5.3 that was done recently. This can unfortunately cause the troubles that you describe, especially in large tables.
    Please take a look at http://wordpress.org/support/topic/plugin-wp-table-reloaded-cant-saveupdate-long-tables where you can find ideas on this. Especially the change of the "max_input_vars" setting might be necessary.

    Best wishes,
    Tobias

  3. antorera
    Member
    Posted 1 year ago #

    Hi,

    Thanks for your quick response!

    I actually had found that post after submitting my query. I put the max_input_vars setting in the .user.ini file in the public_html folder with a setting of 10000.

    However, it's still not working. Any other ideas?

  4. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    it might be possible that .user.ini is not the correct way to change this on your server. You might want to contact your webhost company to get assistance with changing the "max_input_vars" setting.

    As a quick workaround, you could start with a new (empty) table and change the JavaScript setting to what you want. Then import the CSV file again and choose to replace that table during the import.

    Regards,
    Tobias

  5. antorera
    Member
    Posted 1 year ago #

    Hello,

    I worked with my hosting company to put the max_input_var setting in the appropriate place but it's still not working. Even worse, when I update, it removes all the other settings I had in place already, including the javascript features.

    I also tried your other workaround but that didn't work either.

    What is the difference between Update Changes and Save and Go back? Does it matter the sequence?

    Any other ideas? This is a great plugin, but it would be really useful to be able to control how many rows are shown and have the ability to edit it after it's been imported. I can't even change the table name or description.

    Thanks,
    antonella

  6. antorera
    Member
    Posted 1 year ago #

    I tried the workaround again and now I am able to get the 25 rows. I didn't follow the correct steps the first time around.

    So it seems that I can make changes to small tables and save them. The problem is on larger tables. Any other ideas on how to handle the larger table? The search function is awesome for just such large tables. It would be great to be able to edit the data without having to import each time I need to make a simple change.

    Thanks.

  7. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    the only difference between "Update Changes" and "Save and Go Back" is the page that you will be taken to. When clicking "Update Changes", you will stay on the "Edit" screen, while clicking "Save and Go Back" will bring you to the "List of Tables". The actual saving process is the same for both.

    Now, regarding your problem: If changing the "max_input_vars" variable didn't help, this is likely caused by one of the other reasons that are mentioned in the links in the post that I linked to above, e.g. the Suhosin PHP extension. Other than that I don't have ideas on this unfortunately. Sorry :-(

    Regards,
    Tobias

  8. mikelyon@mlyon.com
    Member
    Posted 1 year ago #

    I'm having the same problem, I believe, on http://blochcancer.org/resources/big-list-of-cancer-resources/

    The table has 400 rows and can no longer be edited -- an attempt to update or save changes results in "Error 404 - Page Not Found" for http://blochcancer.org/wp-admin/tools.php?page=wp-table-reloaded&action=edit&table_id=11

    Shorter tables can be edited without a problem.

    This is quite serious for us, of course, and we could use some assistance!

  9. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    this 404 error is very likely the result of some sort of "hacking prevention" system that is installed on your server. Due to the large amount of data that is sent to the server during the request, it assumes that a hacking attempt is going on (which it isn't of course).
    I suggest that you contact your webhost company to have them make that system less strict, or e.g. put the WordPress admin area on a white list.

    Regards,
    Tobias

  10. mikelyon@mlyon.com
    Member
    Posted 1 year ago #

    Thanks, Tobias, VERY much! You were correct - my host wrote:

    We have checked the logs and found that the issue was related to mod security. We have whitelisted the rule which was causing the error for your domain. Please have a check now.

    All is working fine now! Much appreciated!

    -- Mike

  11. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Mike,

    awesome! Very cool that your webhost was so helpful here and found the issue - and fixed it!

    Best wishes,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic