WordPress.org

Ready to get started?Download WordPress

Forums

WP-Table Reloaded
[resolved] Row Limitations (12 posts)

  1. Don Elliott
    Member
    Posted 2 years ago #

    We ran into an issue with the tables only being able to allow 141 rows. After reading the forum I found this post: http://wordpress.org/support/topic/plugin-wp-table-reloaded-cannot-save-changes-for-big-table which narrowed the issue down to an issue with Suhosin, a PHP security extension. The solutions all dealt with modifying the php.ini file, which our client did not have access to.

    The solution we found was to add this line to the root .htaccess file:

    php_flag suhosin.simulation On

    Works great now!

    http://wordpress.org/extend/plugins/wp-table-reloaded/

  2. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Don,

    thank you for sharing this possible solution to this ugly problem with Suhosin! Really nice and easy!
    I'll gladly point other users with this issue to this post.

    Best wishes,
    Tobias

  3. Don Elliott
    Member
    Posted 2 years ago #

    No sweat, it's a great plugin! You can see how we used it here: http://www.dryflydistilling.com/find-dry-fly/

    It's a combination of custom post types, custom fields, and your plugin. Very manageable for the client.

  4. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    very cool! I really like the styling of the tables! Great job!

    Best wishes,
    Tobias

  5. ekillian
    Member
    Posted 2 years ago #

    great info...

    php_flag suhosin.simulation On in .htaccess solve the rowcut issue.
    Thank you

  6. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    sweet! :-) So, Don, thanks again for sharing this solution!

    Regards,
    Tobias

  7. longnha
    Member
    Posted 2 years ago #

    Hello,

    Thank you for the information but I would like to ask where did you add that line in .htaccess?

    When I edit .htaccess and add the line right above '</IfModule>' it always result error!

    Thank you.

  8. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    I'm not an .htaccess expert, but right at the end of the file should be a proper place. Putting it inside an </ifModule> clause should not be necessary.

    Regards,
    Tobias

  9. longnha
    Member
    Posted 2 years ago #

    Hi Tobias,

    Thank you for your response.

    When I add the line it always result error 500.

    According to this post http://imagevuex.com/documentation/troubleshooting/ It mean that the extensions has been disabled. Yes, I asked my host do so.

    In sum up, suhosin is not really the one that cause the problem in my case. Now I have no ideal how to fix the issue. My bad luck. :(

  10. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    ah, that's too bad :-(
    Here's another thread with a different solution:
    http://wordpress.org/support/topic/plugin-wp-table-reloaded-cant-saveupdate-long-tables

    Maybe that helps...

    Best wishes,
    Tobias

  11. longnha
    Member
    Posted 2 years ago #

    Hi Tobias,

    I read many threads and usually there always have error message but in my case there have no message, even in error_log.

    When I make the change in the table and either click "Update change" or Save and go back", it turn me back to edit table page, with no change at all to the table!

    I'm searching for php.ini file but there have no such file in my proof directory. I will contact my host hope they could make few change with php.ini file as suggestion in this thread http://wordpress.org/support/topic/plugin-wp-table-reloaded-cant-saveupdate-long-tables?replies=4

    Thank you for your answer.

  12. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    yes, that is probably be the best idea then. Maybe your webhost can help.

    Best wishes,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic