WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP-Table Reloaded] Menu hidden under tables. (12 posts)

  1. itarride
    Member
    Posted 2 years ago #

    I've checked the forum finding this topic, which is exactly my problem: http://wordpress.org/support/topic/plugin-wp-table-reloaded-drop-down-menu-hidden-behind-table?replies=14, but now I'm wondering if there's a way to fix this without disabling the DataTables support?? Thanks in advance.

  2. itarride
    Member
    Posted 2 years ago #

    Back posting, i've resolved the issue using this instructions: http://datatables.net/forums/discussion/3730/z-index-problem-for-menu/p1

  3. TobiasBg
    Member
    Posted 1 year ago #

    Hi,

    sorry for the late answer. Unfortunately, I just found this thread as it wasn't tagged properly. Maybe my answer will help people searching for this issue...

    Great to see that you found a solution in the DataTables forums! Yes, the z-index has to be changed here, so that the menu will be above the table controls.

    Regards,
    Tobias

  4. jjswol
    Member
    Posted 1 year ago #

    Sorry for this stupid question but I don't know how to fix my problem. Coulumn 2 of table ID=1 has shrunk and I can't figure out how to get to back. Here is what I have in my plugin options.

    .wp-table-reloaded-id-1 td {
    font-family: arial;
    font-size: 13px;
    color: #000000;
    }

    .wp-table-reloaded-id-1 .column-2 {
    width: 5000px;
    }

    .
    .wp-table-reloaded-id-1 .row-hover tr:hover td {
    background-color: #FCFE00!important;
    }

    .wp-table-reloaded-id-7 td {
    font-family: arial;
    font-size: 13px;
    color: #000000;
    }

    .wp-table-reloaded-id-8 td {
    font-family: arial;
    font-size: 13px;
    color: #000000;
    }

    .wp-table-reloaded-id-9 td {
    font-family: arial;
    font-size: 13px;
    color: #000000;
    }

    Can you please help me? Thank you. John S

    My site is at http://www.twinstrivia.com and my problem is the "Today in Twins History" page.

  5. TobiasBg
    Member
    Posted 1 year ago #

    Hi John,

    is this still an issue? Everything looks good to me in that table.

    Regards,
    Tobias

  6. jjswol
    Member
    Posted 1 year ago #

    Thank you for responding Tobias. Yes it still is an issue. When the page first loads it looks OK but the searcgh box is missing. Then when the page completed loading the search box appears but column 2 shrinks in size and it should be wider covering the entire blue shaded area.
    When I disable the JS library the search box goes away and the column 2 width is then correct.

    Do I need to do this?
    If you are using the DataTables JS library for that table, you will also need to add the following code to the "Custom Commands" textfield of the "DataTables JavaScript Features" section on the "Edit Table" screen for the table in question!

    "bAutoWidth": false

    If so, where do I put the "bAutoWidth": false line?
    Thanks again, John S

  7. jjswol
    Member
    Posted 1 year ago #

    I added the "bAutoWidth".false line to the Custome Commands text field but it did not solve the issue.
    John

  8. TobiasBg
    Member
    Posted 1 year ago #

    Hi John,

    I still can't reproduce this. What browser are you experiencing this problem with? And can you maybe create screenshot to visualize this for me?

    Also, I'm not quite sure what you mean with "entire blue shaded area". Do you mean that the text inside the cell leaves some space on the left and right side? That's due to the default padding that the tables in your theme get. To change that, please try adding

    .wp-table-reloaded-id-1 th,
    .wp-table-reloaded-id-1 td {
      padding: 4px !important;
    }

    to the "Custom CSS" textarea on the "Plugin Options" screen of WP-Table Reloaded.

    The loading process of the "Search" text box seems to be correct. It just takes some time to load and initialize everything on this large table.

    The "bAutoWidth": false should not be necessary, but it can't hurt for now.

    Regards,
    Tobias

  9. jjswol
    Member
    Posted 1 year ago #

    I tested it with Google Chrome and Firefox and the page "Today in Twins History" displays correctly. When I use my main browser IE9 it has the issue I have been talking about. I can not do a screen print because I have my site set up not to allow the copy feature to work. Any ideas?
    Thank you again,
    John

  10. TobiasBg
    Member
    Posted 1 year ago #

    Hi John,

    thanks for that information. In IE9, I was able to reproduce this. Unfortunately, I have no idea what is happening here, but my assumption is that it is related to the DataTables JavaScript library. Therefore, it might be the best at this point to ask the developers of that library (WP-Table Reloaded just includes it) for help, in the forums at http://www.datatables.net. Could you do that?

    And about that "not allowing the copy feature": (Sorry that I have to disappoint you.) Something like this does not really exist. Screenshots are always possible and even copying can be achieved rather easily. The code that you use to prohibit it only makes it slightly harder for those who really want to copy things.

    Regards,
    Tobias

  11. jjswol
    Member
    Posted 1 year ago #

    Thank you for your help Tobias. It appears that Datatables.net requires you to buy support time and I can not afford that at this time. I may have to either live with the issue or turn off JS which seems to resolve the issue but then I lose my search box. I will have to determine the lesser of the two evils I guess. I appreciate there is no way tp totally prrevent the copy feature but it does keep seem people from doing it. Have a great day. John Swol

  12. TobiasBg
    Member
    Posted 1 year ago #

    Hi John,

    no, the support there in the forums is free. The support time that you can buy will just assure you a timely response, while using the free support might take some time until you get an answer.
    You can just register at http://datatables.net/forums/ for free.

    Regards,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Topic