WordPress.org

Ready to get started?Download WordPress

Forums

WP SyntaxHighlighter
[resolved] ruins the visual editor (12 posts)

  1. Moogle Stiltzkin
    Member
    Posted 3 years ago #

    I'm using 3.2

    Although i did test this on the previous wp version as well.

    The syntax highlighter spoils the visual editor, and out of 20 or so quick tags, only 3 or so are shown.

    I tried to reset the plugin, disable, re-enable, delete/reinstall, deactivate all plugins, but none of these methods worked.

    It's a nice plugin but i wish it could be used without this sort of bug :{

    Right now i don't have any syntax plugin *sob sob sob

    http://wordpress.org/extend/plugins/wp-syntaxhighlighter/

    i was using the latest 1.3.8.2

  2. redcocker
    Member
    Plugin Author

    Posted 3 years ago #

    As I contacted Moogle Stiltzkin san via E-mail, I wrote information for other users.

    In ver.1.3.8.2 or older, "Wp SyntnaxHighlighter" doesn't highlight your code in the excerpts.
    *excerpts = category, archives and search results
    It's a feature.

    If you are using the theme which conveniently makes extracts(excerpts) from contents for SyntnaxHighlighter and if you want to get highlighted in the excerpts, Mail to me.
    I will send you developing version.

    And ver 1.3.9 or ver 1.4 will has new setting options to get highlighted in the excerpts.

  3. Moogle Stiltzkin
    Member
    Posted 3 years ago #

    i tested it, and it works great :D

    Then the site looks more standardized, because doesn't matter if your viewing the content view main site url, an article page, or maybe tag page, category, exercepts, it will always show the code highlighted with redcocker's syntax highlighter :D

    kudos

  4. redcocker
    Member
    Plugin Author

    Posted 3 years ago #

    Now ver.1.3.9 is ready.
    This version also allows you to highlight your code in Categories, Archives or Search result.

  5. Moogle Stiltzkin
    Member
    Posted 3 years ago #

    Hm, i'll check it out.

      *update

    Works fine no issues.

    Theres even an option now to ask you if you want it to show in categories, archive etc. Nice.

    By the way, any plans to add in a auto drop down for the top right where the ? button is located. So you can copy the code, or share it ?

    I noticed on some wordpress sites, they have this, but i don't know what plugin they use.

  6. redcocker
    Member
    Plugin Author

    Posted 3 years ago #

    Hi, Moogle Stiltzkin san

    >By the way, any plans to add in a auto drop down for the top right >where the ? button is located.

    Does it means show/hide toolbar(? icon) on mouseover?

    >I noticed on some wordpress sites, they have this, but i don't know >what plugin they use.

    Could you let me know the site that has this function.

  7. Moogle Stiltzkin
    Member
    Posted 2 years ago #

    http://wpcodesnippets.info/blog/lets-build-a-page-navigator.html

    Here you go :}

    See the toolbar in the top right corner of the code thingy has some useful buttons.

    Show in pop up, copy, etc :}

  8. Moogle Stiltzkin
    Member
    Posted 2 years ago #

    Also has select all and print function as well.

  9. redcocker
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, Moogle Stiltzkin san

    Through the setting panel, switch from 3.0.83 to 2.1.382 and enable "Toolbar".
    The useful toolbar will be shown on mouseover.

  10. Moogle Stiltzkin
    Member
    Posted 2 years ago #

    Gasp.

    Your right !!! wow i feel like such a muppet for not noticing this.

    So how come 3.0.83 is not using that toolbar :d ?

    Any cons using 2.1.382 over 3.0.83 ?

  11. redcocker
    Member
    Plugin Author

    Posted 2 years ago #

    >So how come 3.0.83 is not using that toolbar :d ?

    Alex Gorbatchev only knows.
    http://alexgorbatchev.com/SyntaxHighlighter/whatsnew.html

    However I know someone(most users?) don't like 3.0.83.
    So this plugin has both version.

  12. Moogle Stiltzkin
    Member
    Posted 2 years ago #

    Mystery solved. Well it seems to work without any issues, so i will be using that 2.1.382 :D thx redcocker sama.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic