WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Survey And Quiz Tool] Additional Text Bug (7 posts)

  1. Joshuwar
    Member
    Posted 3 years ago #

    Hi,

    I'm using this plugin at the moment, and there seems to be an issue with updating the $questionAdditional field.

    If I update this field on a question I've just written, a new question with the same other fields is generated, with different additional information.

    Also, perhaps I'm getting something wrong, but using this field to insert images doesn't seem to work.

    I'm looking into this, but wanted to report it so you know. Will update with any findings.

  2. Joshuwar
    Member
    Posted 3 years ago #

    Another Bug: the custom theme directory seems to be wrong (this could do with more documentation generally). It also seems to use a multisite blog id even when on a single instance.

  3. Backie
    Member
    Posted 3 years ago #

    I've pinpointed the addition info not updating, didn't create teh sql query properly. Seems no one really uses that feature any where, as this bug must have been in there for ages. Thanks for pointing it out. Also added the stripslashes which I seem to forgotten to add in the default section.php veiw for quizzes.

    On the note of the custom theme, directory seems to be correct on my installs. The use of the site id even on single instances means if the user ever decides to multi site that install the plugin won't break. Since people would bitch more if did than they will over having the 1 when it's a single site install.

    Commiting and tagging a new release just now.

  4. Joshuwar
    Member
    Posted 3 years ago #

    Nice one Iain- thanks for the support!

    Ah- I've merged with my other changes and there's still an issue with the additional text query- it no longer generates new questions, but it still doesn't save the new values- if you leave the question admin page and then return to it, the original additional text persists.

  5. Fubra
    Member
    Posted 3 years ago #

    Hi,

    Works fine for me, so I suspect if you're modifying the code, the issue may be there.

  6. Joshuwar
    Member
    Posted 3 years ago #

    I've only been changing section.php for styling, and wp-suvery-and-quiz-tool.php, to rename some admin options, certainly nothing which would break a query. I'll have a go with a clean install and get back to you.

  7. Min En
    Member
    Posted 3 years ago #

    Apologies for hijacking this thread. I can't find Fubra's contact information anywhere on the web.

    Hi Fubra,

    Can you provide me an email address to contact you at? You can email me at lohminen[at]gmail[dot]com.

    I'm interested in customizing a survey-cum-questionnaire with indexable search results.

    Thanks.
    Best Regards,
    Min En

Topic Closed

This topic has been closed to new replies.

About this Topic