WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Edit
After 3.1 upgrade, plugin broken. (11 posts)

  1. tempor
    Member
    Posted 3 years ago #

    After the 3.1 upgrade Wp Super Edit stopped working. In the new post section appears nothing anymore.

    I've been using this excellent plugin for a long time now and after many upgrades this is the first time it is broken.

    I had to disable it to be able to post.

  2. Jess Planck
    Member
    Plugin Author

    Posted 3 years ago #

    I'm pasting this reply in hopes we can a solution. So far the only issues I have that I can reproduce are:

    • Turn off TinyMCE 2.x compatibility plugin.
    • Some problems with translations on multi-site configurations.
    • Some older configurations may need to have the database files reinstalled.

    This version of WP Super Edit has been tested on WordPress 3.1 and I may have introduced some issues affecting older versions of WordPress. If so you may want to check the "Other Versions" and downgrade to an older version.

    http://wordpress.org/extend/plugins/wp-super-edit/download/

    I'm also interested to see if this is a PHP4 issue.

    So, I would appreciate if you can use a tool like Firebug to check for javascript errors. Also check the source in your edit post / page screen and check for any unusual includes or errors for other plugins. I am often seeing other plugins introduce errors. There are some older plugins that were introduced to work with WP Super Edit, but I don't think they have been upgraded.

    Javascript issues can be found on the post / page edit screen either between the <head> tag or before the closing <body> tag. You will find the primary controlling javascript for the editor associated with the tinyMCEPreInit values present toward the end of the html before the closing body tag.

  3. Jess Planck
    Member
    Plugin Author

    Posted 3 years ago #

    I was finally able to reproduce an issue causing the editor to malfunction on older websites using WP Super Edit.

    I couple versions ago I moved the "Custom CSS Classes" and "Super Emoticons" from being just "TinyMCE" plugins to being separate "WordPress Plugins". This was done because those two (and other personal ones) have functionality that requires more access to the WordPress internals, so they have to be activated as separate WordPress plugins.

    This fixed an issue dealing with callback functions that I shouldn't have been doing in the first place. Unfortunately it looks like it broke some sites that may have had these active for a long time.

    The easiest solution is to reload WP Super Edit.

    1. Make a note of the Editor Plugins activated and the position of the buttons for your editor.
    2. Go to the WP Super Edit Options tab and press the Uninstall WP Super Edit Database Tables button. This will remove the tables for WP Super Edit from your database.
    3. Go to the WordPress plugins area and make sure that WP Super Edit is the only active plugin. If the Theme Classes or Emoticon plugins are active, deactivate them.
    4. Go back to the Settings > WP Super Edit area and press the Install WP Super Edit button.
    5. If you want to use the WP Super Edit Theme Classes or Emoticon plugins, go back to the WordPress plugin area and activate those plugins.

    Unfortunately this will clear out all settings for the buttons and plugins that you may have had previously. You have my sincerest apologies.

    If you are brave, before you do any of this do a backup of the wp_super_edit_users table in your database. That table stores the actual button configurations, so you may be able to replace that table AFTER the reinstall and get some of your user's configurations working as before. I haven't tested this, but it should work.

  4. tempor
    Member
    Posted 3 years ago #

    I will try and get back to you then,

    thanks.

  5. tempor
    Member
    Posted 3 years ago #

    I'm pasting this reply in hopes we can a solution.

    Some info concerning what you said:

    -Turn off TinyMCE 2.x compatibility plugin.
    I never had that ON

    -Some problems with translations on multi-site configurations.
    This is not a multisite and it is using one language only

    -PHP4 issue
    No this is a PHP5 site

    -"Custom CSS Classes" and "Super Emoticons"
    I never had them active

  6. pdavisnwa
    Member
    Posted 3 years ago #

    Same problem as described above. I did what you said to do ev3rywh3re. However, when I turned every option back on, it still gave me a blank editor area and no buttons.

    I did it twice, exactly as you stated. Fail both times. But, the second time I started turning off options on the Configure Editor page. I found that the Font Tools option caused everything to blank out.

    Hope this helps.

  7. Dverski
    Member
    Posted 3 years ago #

    Yep, same problem here, the Font Tools is doing the damage. Going back to version 2.38. No issues with it, whatsoever. :)

  8. Jess Planck
    Member
    Plugin Author

    Posted 3 years ago #

    I always forget that Font Tools is not "really" a TinyMCE plugin. I just patched up Font Tools in WP Super Edit 2.4.1, you'll need to activate the WP Super Edit Upgrade Utility plugin or reinstall the database tables to fix.

  9. Dverski
    Member
    Posted 3 years ago #

    Did everything as told my man, still not as it should be. The editor is back on, but the Font Select and Font Size buttons are missing.

    I updated the database, uninstalled and re-installed the plugin, used the Upgrade Utility, checked, unchecked and re-checked the fields. Nothing.

    I can see the buttons in the plugin settings but not in the post editor.

  10. Jess Planck
    Member
    Plugin Author

    Posted 3 years ago #

    Yea, let's try that again with version 2.4.2. Activate the Upgrade Utility. I had to hit it twice on my development site for some stupid reason :P

    If not try a reinstall. Let me know if you have any warnings or issues.

  11. Dverski
    Member
    Posted 3 years ago #

    Done. Everything working like a charm. Highly appreciated. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic