WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Zero Cache Files (12 posts)

  1. genesteinberg
    Member
    Posted 6 years ago #

    I'm having a weird one.

    For the longest time, I've used WP SuperCache with success.

    I have two blog installs. One at macnightowl.com, and another at macnightowl.com/newsletter. Both installations are near-identical, except for minor configuration changes in the theme file to reflect the different locations of the blog files.

    With the installation of WP 2.5 in both folders, your plugin stopped delivering information about the file being cached, although cache files are being created in the macnightowl.com installation.

    So:

    <!-- 26 queries. 0.617 seconds. -->
    <!-- Dynamic Page Served (once) in 0.614 seconds -->

    For macnightowl.com/newsletter, zero cached files, nothing in the Cache folder. Write privileges and installations are identical, and the .htaccess files of both represent the different locations of the installations.

    Can you suggest a solution for someone who isn't an expert at PHP stuff? Or something to look for?

    Peace,
    Gene Steinberg

  2. genesteinberg
    Member
    Posted 6 years ago #

    All right, I solved part of it. The configuration was messed up by HyperCache, no currently active.

    But I'm still seeing this display at the bottom of a page's source:

    <!-- 26 queries. 0.617 seconds. -->
    <!-- Dynamic Page Served (once) in 0.614 seconds -->

    No indication of caching, even though cached files are being created.

    This is a symptom that began with WP 2.5, and I'm using the latest version of your plugin.

    Peace,
    Gene

  3. You're probably logged in. Users with login or commenter cookies don't get served super cached files, only half cached (WP-Cache only) files.

  4. genesteinberg
    Member
    Posted 6 years ago #

    No difference either way.

    Remember, this worked fine with previous versions of WordPress.

    Peace,
    Gene

  5. Roy
    Member
    Posted 6 years ago #

    Never noticed, but the source of my site also doesn't say anything about cache. The WP-cache part of my administration has lists of cached pages and I have to delete a page from that to see a change (in design for example), so I suppose they are cached.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    All right, I solved part of it. The configuration was messed up by HyperCache, no currently active.

    If you messed around with another cache system, then it's hard to say what might have gotten messed up. So here's my advice:
    1. Remove all the caching plugins entirely. Remove the advanced-cache.php file from the wp-content folder. Remove any CACHE references from wp-config. Delete the contents of the cache directory. Basically, go back to an uncached setup.
    2. Install the caching plugin you want fresh.

    Basically, caching plugins integrate fairly thickly with the WordPress system, so removing them or switching them can be a bit trickier than a normal plugin. Best to start from an uncached mode and then do a fresh install.

  7. genesteinberg
    Member
    Posted 6 years ago #

    Been there; done that. I removed it carefully, thoroughly.

    Peace,
    Gene

  8. conc
    Member
    Posted 6 years ago #

    I have a similar problem here. Two blogs (WP 2.5, I'll call them Blog A (not working) and blog B (working)), both using the same theme and having minor configurations differences (currently Blog A has XML Sitemap installed while Blog B does not). Previously, Blog A had WP-Cache installed but not working, while Blog B didn't have any cache installed.

    The one that had WP-Cache installed (Blog A) does not cache at all. I carefully removed all of it, commented the line define ('WP_CACHE',true) on wp-config.php, removed cache directory, advanced-cache.php from wp-content etc. Then I installed and configured WP-Supercache the way I did for Blog B but it didn't work.

    I edited wp-cache-phase1.php and wp-cache-phase2.php to add a line like 'error_log("here",3,"/tmp/errorlog")' at the very start of the files and it didn't produce a single line on the file on Blog A. However, it did produce the lines normally for Blog B. When I added that error_log entry on wp-cache.php it worked fine for both blogs.

    So far, it looks like Blog A is not even calling the cache functions. Any idea on where should I hook error_log to discover what's going on?

  9. theoreticalken
    Member
    Posted 6 years ago #

    Maybe here's a clue. I had the same issue where the supercache directory was created, but those pages were never served. (No super cache comment at the bottom of the source.)

    Since my wordpress folder is in the public level of my site, I modified the HTACCESS file to add the /wordpress directory reference to the appropriate lines in both areas (upper section only example below).

    This did the trick, and now the super cache comment appears at the bottom of the page source.

    RewriteCond %{DOCUMENT_ROOT}/wordpress/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wordpress/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]

    Maybe this is a fix or clue for you all (Gene?).

  10. genesteinberg
    Member
    Posted 6 years ago #

    I'll await more input on that, but I'll keep it in mind.

    Peace,
    Gene

  11. conc
    Member
    Posted 6 years ago #

    Solved for me!!!

    In my case, it was the same issue as described by jdandrea in this post

    I just needed to edit my wp-config.php in order to place

    define('WP_CACHE', true);

    above

    require_once(ABSPATH.'wp-settings.php');

    In my case, the define line was the last one in wp-config.php in Blog A whereas it was correctly above in blog B. Just by doing that it started working again. Hope this helps you ppl!

  12. genesteinberg
    Member
    Posted 6 years ago #

    In my particular situation, folks, things seem to be fully functional. Thanks for all the advice.

    No specific solution, other than two version updates since the problems began.

    Peace,
    Gene

Topic Closed

This topic has been closed to new replies.

About this Topic