WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
www version of page not updating (4 posts)

  1. idoubtit
    Member
    Posted 1 year ago #

    Since I installed WP-supercache plugin, the www version of my page is static. All links there point to the right place but the blog does not update. All is well on the non-www link which I always use anyway but, that's super annoying. Webhost said they should be the same.

    Could the plugin be the cause of it? My webhost tried to help but could not.

    See the difference
    http://www.doubtfulnews.com (stuck)
    http://doubtfulnews.com (updating)

    Notice in the www version, only the index page is stuck not updating. All the links go to do the non www site which is correct. Weird. Any ideas?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    You should redirect all traffic to the non-www site as you're splitting pagerank between them if people link to the www one. If non-www is where WordPress expects to serve data then this is normal behaviour.

  3. idoubtit
    Member
    Posted 1 year ago #

    That does not work. My web host does a loop if I redirect. It SHOULD be fine. The webhost told me a redirect is not necessary.

    And, the www mobile theme is working fine.

    When I disabled and re-enabled the plugin, the www index page refreshed but does not refresh with new posts. All the links on the www go to the non-www URLs.

    Definitely something in the plugin that is making it do this.

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    idoubtit - you should test out another webhost then because a redirect is required. WordPress expects your blog to be at one address, not two, and so does the plugin. That's why the www index page doesn't refresh.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic