WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] wp-supercache only serves wp-cache pages?? (5 posts)

  1. serialboxhpc
    Member
    Posted 5 years ago #

    I am using the latest version of wp-supercache and noticed that even though I have the .htaccess file set up properly, and the settings for supercache are set to ON... my pages are only being cached by wp-cache.

    <!-- Dynamic Page Served (once) in 2.501 seconds -->
    <!-- Cached page served by WP-Cache -->

    I dont have any other caching plugins installed. I am testing it from a computer/browser that has never logged in to the admin section of this wordpress site. no files/folders are getting created in the cache/supercache folders and the permissions are set to 777 recursively though those folders.

    Only the wp-cache-adf9404ec5577a901bdafe7a94126a86.html type files are getting created in the /cache folder

    any help would be appreciated.

    thanks

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    That's not supercache, that's the original WP-Cache. That text doesn't exist in the supercache plugin.

    You probably had WP-Cache installed before?

  3. serialboxhpc
    Member
    Posted 5 years ago #

    thanks for the reply but thats slightly incorrect. supercache uses aspects of wp-cache. In the supercache admin section there is a setting called "half-on" which uses wp-cache instead of supercache.

    Logged in users receive wp-cache pages and other visitors would get supercached pages.. my issue was wp-cache pages were being served to everyone.

    To fix the problem I deleted my cache folder and recreated it. That seemed to do the trick.

    thanks for the suggestions

  4. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Haha, I know! I maintain the plugin and wrote the supercache bit!

    The text "Cached page served by WP-Cache" isn't in the current release (or since release 0.8.2 a long time ago)

    Glad you got it fixed regardless.

  5. serialboxhpc
    Member
    Posted 5 years ago #

    hah well whaddaya know :) thanks again for the response. I forgot to mention that I did upgrade supercache after getting those errors which also may have fixed the prob. Guess I was getting my versions confused.

    On a side note... this is the single greatest plugin ever created for WordPress. thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic