WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] WP-Super-Cache DOES NOT work with 2.7! (52 posts)

  1. Inscrd
    Member
    Posted 5 years ago #

    Paleo - I had the same problem. I disabled all my plug-ins, then re-enabled them after upgrading. Enabling the cache isn't enough; you also need to turn it on in the configuration page under the settings menu. The new layout threw me and it took a while to find.

  2. senator94
    Member
    Posted 5 years ago #

    I don't think WP Super Cache is working with the latest 2.7 stable release.

    I totally uninstalled WP super cache then re-installed it step by step.
    It looks like it is working but nothing is caching.

    WP-Cache

    * 0 cached pages
    * 0 expired pages

    WP-Super-Cache

    * 0 cached pages
    * 0 expired pages

    I am not getting my footer either at the bottom of the page.
    Sample
    <!-- Dynamic Page Served (once) in 1.044 seconds -->
    <!-- Cached page generated by WP-Super-Cache on 2008-12-11 01:02:25 -->

    I have these plugins installed
    Akismet
    All in One SEO Pack
    Dagon Design Sitemap Generator
    Google XML Sitemaps
    Related Posts
    Simple Trackback Validation
    WordPress Database Backup

    Everything worked before when I have 2.6.5

  3. senator94
    Member
    Posted 5 years ago #

    I got it to work.

    I had to delete my wp-config define WP Cache.

    I had to change wp-config chmod 777 and wp-content folder to chmod 777 and let the plugin script do its thing.

    Working now!

  4. dipetersen
    Member
    Posted 5 years ago #

    I just upgraded to 2.7 and tried to install it. This is the error that I received:

    Installing Plugin: WP Super Cache 0.8.6

    Downloading plugin package from http://downloads.wordpress.org/plugin/wp-super-cache.0.8.6.zip

    Unpacking the plugin package

    Fatal error: Cannot redeclare class pclzip in /home/content/html/wp-admin/includes/class-pclzip.php on line 171

  5. Paleo Pat
    Member
    Posted 5 years ago #

    Mine still working fine. But it does seem that it does make more super-cache pages, than standard WP-Cache pages.

    Just letting you know.

  6. Donncha O Caoimh
    Member
    Posted 5 years ago #

  7. Mike Schinkel
    Member
    Posted 5 years ago #

    Hi donncha:

    I was about to get past the readlink() problem my Windows Vista test machine by adding this code to the top of my wp-cache.php file:

    if (!function_exists('readlink')) {
    	// Define readlink() for Windows servers
    	function readlink($file) {
    		return $file;
    	}
    }

    Maybe you could add and create a newer version?

  8. artesea
    Member
    Posted 5 years ago #

    I had wp-cache installed, and today my webhost blocked the site as the CPU cycles were too high.
    So I downloaded WP Super Cache, via the automated download and upon activation I got the redeclare error. Realising I needed to remove wp-cache it noticed that it hadn't been caching any pages.
    As there were no updates for it, I went ahead remove wp-cache and replaced it with WP Super Cache. But still I get no pages cached.
    So there is a chance the "problem" might be in the old wp-cache code.

    Going to try a full remove plugin, delete line from wp-config.php, reinstall.

  9. artesea
    Member
    Posted 5 years ago #

    Attempts to remove and start again failed.
    However installing it on my own blog (which has never had either wp-cache or WP Super Cache) worked first time. Both WP2.7, both hosted by Dataflame, both running PHP5.*, just on different servers.

    Have started disabling plugins (other site has quite a few enabled) to see if it starts working, but nothing so far.

  10. artesea
    Member
    Posted 5 years ago #

    Have de-activated every plugin and its still not working.
    I also have no sign of advance-cache.php or the supercache folder on my server.
    Any tips on removing all traces of this and wp-cache from my WordPress install so I can try a final retry?

  11. artesea
    Member
    Posted 5 years ago #

    Yay, finally got it working after a bit of Googling.
    Turns out my advanced-cache.php was pointing in the wrong place, but due to having a permission of 0000 WP Super Cache couldn't do anything with it.
    Logged into cPanel on my webserver and deleted the linked file. Re-enabled the plugin and within seconds I have:

    WP-Cache
    * 6 cached pages
    * 0 expired pages

    WP-Super-Cache
    * 1 cached pages
    * 0 expired pages.

  12. grokcode
    Member
    Posted 5 years ago #

    I was having the problem where no pages where being cached also. After a bit of digging I found that advanced-cache.php was a broken symbolic link. Fixing that and now everything is working like a charm.

    The broken symbolic link was my fault, since I installed 2.7 in public_html/test, then after it was working, moved it to public_html/grokcode which is where my live version goes. The sym link was still pointing to somewhere in public_html/test. Hope that helps someone.

    And great job on the plugin donncha! http://grok-code.com has survived a slashdoting and some crazy stumble and reddit action thanks to this plugin. You rock!

  13. regerar
    Member
    Posted 5 years ago #

    I'm having a strange problem that no one else using any other plugin seems to be having... When i try ti update my settings, i.e. turn on caching, i am immediately taken to my General Settings page. When i return to the wp super cache settings page, it is still turned off, and all defaults are still on. I have tried turning off all other plugins and i still get this problem. I also get this problem with a few other plugins, too. They are all new downloads to me, so I have never used them before (i.e., they've never worked for me).

    Is this a WP problem, or something to do with my server? obviously it isnt your plugin, or the other plugin it happens to either. I'm really lost, and have been searching through forum pages for a good 6 ours now and haven't found ONE post dealing with this issue I am suffering from :-/

    any help would be greatly appreciated. Thanks.

  14. jdandrea
    Member
    Posted 5 years ago #

    Greetings! For a li'l while I was in the same boat: WP 2.7 (latest), plus the very latest wp-super-cache, both htaccess files and wp-config prerequisites in order, permissions all correct, PHP safe mode off ... but I was not getting any cache love. :(

    Then I found the culprit - a symlink in wp-content:

    advanced-cache.php -> /nfs/c01/h02/mnt/####/domains/my.domain.com/html/wp-content/plugins/wp-super-cache/wp-cache-phase1.php

    Only one problem. It doesn't exist. Instead, I changed it to be relative to wp-content vs. filesystem root-relative:

    advanced-cache.php -> plugins/wp-super-cache/wp-cache-phase1.php

    Ta-dah, it works! So if you think you've done everything there is to do, check your symlink for advanced-cache.php. You never know. :)

    Meanwhile, thanks to Donncha for all the sweat equity he put into this plugin. Essential ammo for any WP site.

  15. doog
    Member
    Posted 5 years ago #

    Donncha, first, thank you for your outstanding work on SuperCache, it IS a lifesaver for shared-hosting users (like anyone on BlueHost!).

    Second - I'm running the latest WP (2.7), did the plugin update and started getting two lines of errors (sorry, didn't catch them, our content managers immediately started howling in pain and I had to scramble to get it settled down) but I definitely remember seeing a reference to PEAR.

    Turned the plugin off (deactivated) and ONLY the errors came up. I removed the supercache code from the htaccess file and got the site running again, but am now concerned (terrified? my heart is still fluttering) that the plugin may not work right.

    Any suggestions? Aside from a nice break and a cold towel on the forehead?

    WHEW. Fun morning!

  16. doog
    Member
    Posted 5 years ago #

    And just an aside, to anyone who gets upset about things in WordPress not working - have you *ever* seen *any* commercial software company provide this transparent and speedy a response?

    I know it's upsetting when things don't work, but abusing folks that spend their precious time to bring us FREE software isn't right. It doesn't just offend the software author, it's upsetting to the whole community that RELIES on those authors.

    Perhaps the measure of that pain is how *important* WordPress becomes to us, we forget all the effort that goes into creating and maintaining it.

    Paleo Pat, I understand being upset. Trust me. I have a dozen folks watching our site like a hawk and 85K users viewing it. All I can say is save the vitriol for the clowns at Microsoft who charge TOO MUCH for products that often just DON'T WORK, but because it's a 'standard' we have no say.

    Always feel free to run up the red flag and ask for help though, there are many here to help. We'll be your staunchest allies.

  17. doog
    Member
    Posted 5 years ago #

    Donncha, here's what my htaccess file looked like while the error was occurring, if it's any help:
    ---
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]

    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>

    # END WPSuperCache

  18. doog
    Member
    Posted 5 years ago #

    Ah...! Remembered I can get at my error_log file - here's the errors WP-Supercache threw in WP 2.7 after I updated the plug in:

    [09-Jan-2009 10:12:27] PHP Warning: include(/home1/cualumor/public_html/wp-content/plugins/wp-super-cache 2/wp-cache-base.php) [function.include]: failed to open stream: No such file or directory in /home1/cualumor/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 48
    [09-Jan-2009 10:12:27] PHP Warning: include() [function.include]: Failed opening '/home1/cualumor/public_html/wp-content/plugins/wp-super-cache 2/wp-cache-base.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home1/cualumor/public_html/wp-content/plugins/simpleflickr/phpFlickr/PEAR') in /home1/cualumor/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 48

  19. grokcode
    Member
    Posted 5 years ago #

    Actually, now that I look a bit closer. The plugin isn't working. After logging out I load the page and get

    <!-- Dynamic Page Served (once) in 0.986 seconds -->
    <!-- Cached page generated by WP-Super-Cache on 2009-01-09 17:51:50 -->

    Then loading the same page again I get

    <!-- Dynamic Page Served (once) in 0.996 seconds -->
    <!-- Cached page generated by WP-Super-Cache on 2009-01-09 17:55:03 -->

    When I believe it should be saying "Cached page served by WP-Super-Cache" as per this other thread http://wordpress.org/support/topic/191683

    I have the shiney new 0.8.7 and WP 2.7.

  20. slushpilejs
    Member
    Posted 5 years ago #

    I have yet to see an actual apology here from Paleo Pat. If you're going to pull the "man up" card, you should at least have the decency to say "I'm sorry" and possibly, "I'm a stupid, reactionary blowhard, and you're more of a man than me to put up with my childish bullshit." Feel free to cut and paste.

  21. henry1357
    Member
    Posted 5 years ago #

    hello can anyone help
    i am trying to create this file but dont know where to start can anyone help please.

    Thanks H
    newb

    wp-content/cache does not exist

  22. robaland
    Member
    Posted 5 years ago #

    Hello all,

    Looking for a little guidance on creating a cache. Originally, I was attempting to activate my wp stats through my dashboard. However, I was receiving this message:

    wp-content/cache does not exist: please make sure that the "wp-content/cache" directory is created.

    I downloaded and installed the Super Cache plug-in and received this message:

    WP Super Cache Manager
    Warning! /home/trhou2/public_html/blog/wp-content/advanced-cache.php does not exist or cannot be updated.

    * 1. If it already exists please delete the file first.
    * 2. Make /home/trhou2/public_html/blog/wp-content writable using the chmod command through your ftp or server software. (chmod 777 /home/trhou2/public_html/blog/wp-content) and refresh this page. This is only a temporary measure and you'll have to make it read only afterwards again. (Change 777 to 755 in the previous command)
    * 3. Refresh this page to update /home/trhou2/public_html/blog/wp-content/advanced-cache.php

    If that doesn't work, make sure the file /home/trhou2/public_html/blog/wp-content/advanced-cache.php doesn't exist:

    1. Open /home/trhou2/public_html/blog/wp-content/plugins/wp-super-cache/advanced-cache.php in a text editor.
    2. Change the text CACHEHOME to /home/trhou2/public_html/blog/wp-content/plugins/wp-super-cache/
    3. Save the file and copy it to /home/trhou2/public_html/blog/wp-content/advanced-cache.php and refresh this page.
    Cannot continue... fix previous problems and retry.

    I walked through the steps, making sure I had the right permissions set, etc. Here is the code for the advanced-cache.php

    <?php
    # WP SUPER CACHE 0.8.9.1
    function wpcache_broken_message() {
    if ( false == strpos( $_SERVER[ 'REQUEST_URI' ], 'wp-admin' ) )
    echo "<!-- WP Super Cache is installed but broken. The path to wp-cache-phase1.php in wp-content/advanced-cache.php must be fixed! -->";
    }

    if ( !include_once( 'CACHEHOME' . 'wp-cache-phase1.php' ) ) {
    if ( !@is_file( 'CACHEHOME' . 'wp-cache-phase1.php' ) )
    register_shutdown_function( 'wpcache_broken_message' );
    }
    ?>

    Any ideas how to fix my broken super cache? I welcome any and all ideas. Thank you for your time. I certainly appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic