WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] Cache not cleared when editing a Page (6 posts)

  1. AndrewRussell.net
    Member
    Posted 2 years ago #

    I'm having trouble getting WP-Super-Cache (version 1.0) to clear cached pages when they are edited.

    Here is a log of me first editing a post, and then editing a page:
    http://pastebin.com/KgneTufs

    They both say they are clearing cache. But only updating the post actually successfully removes files from the cache (as listed on the "Contents" tab). Updating the page does not seem to remove anything.

    Could it be something to do with the weird "andrewrussell.nethttp:/andrewrussell.net" seen in the log on lines that I would expect to be removing files from the cache? Obviously these are not valid directories.

    I have the following settings turned on: mod_rewrite, compress, don't cache for known users, cache rebuild, mobile device support, clear all cache files on publish or update, extra homepage checks.

    I have WordPress set up with relocated wordpress and wp-content directories (each are in their own directories, at the root of my site). Maybe this has something to do with the weird path in the log?

    Everything else to do with caching seems to be working fine. (Fantastic plugin, by the way.)

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Can you try the development version? I fixed a problem in it related to slashes in the path to the cached files, that may help.

  3. James Revillini
    Member
    Posted 2 years ago #

    Same issue here - updates to pages do not refresh the cached page. So just to confirm, the plugin should be doing this by default? Are there any settings I need to double-check? I know I do NOT have 'Clear all cache files when a post or page is published or updated.' checked. but that should be ok, right?

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, the cache should be updated immediately when you edit a page. Try the dev version.

  5. AndrewRussell.net
    Member
    Posted 2 years ago #

    Donncha: Switching to the dev version seems to have fixed this issue.

    Thanks very much :)

  6. G
    Member
    Posted 2 years ago #

    yes Donncha, with the latest dev version the cache is updated immediately after editing a page - thanks!

    the problem of deleting cache using the button on network admin page remains for me -->
    http://wordpress.org/support/topic/plugin-wp-super-cache-unable-to-delete-cache-in-10?replies=22#post-2626363

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic