WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Why clear the cache? (8 posts)

  1. Drawer
    Member
    Posted 6 years ago #

    Hello, trying to understand all about this -read your main page and lots of questions posted here.

    I see that index is on the do not cache list, even though it seems like it should be cached.
    I see that the warning in red that I am writable has not been fixed by many people, and 755 is ok.
    I have 2 questions left. It looks like I should enable compression, is that right? Calling my server to ask takes an hour. If it doesn't much matter I'll turn it off.
    Also: if creating the cache is the point (by me reading my own pages), why should or would I need to delete or clear it? I've seen that mentioned a bit here.

    I look forward to understanding this better when you have the chance to reply!

  2. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Yes, you should enable compression, but it doesn't work all the time which is why it's disabled by default.

    The cache has to be cleared or cleaned up because of stale data - sidebar data, categories and tag archives, etc.

  3. Drawer
    Member
    Posted 6 years ago #

    Thank you, Donncha!

    So to make the cache, I should look at all my own pages, is that right? And then the readers can see my cache, I believe.

    I will have a small blog to start with - is once a week about right for me to clear and then re-cache my pages?

    Forgot to ask another important question: will this also cache my own admin pages? On my first blog, 2.2, the admin pages are SO slow. I am just starting this new blog on 2.5, so hope it will be faster.

    Thanks again for your prompt response.

  4. Donncha O Caoimh
    Member
    Posted 6 years ago #

    There's no need to go visiting your own site. Whatever pages are visited by anyone will be cached. Also, if you're logged in, you'll see a different page to an anonymous user.

    No, it won't cache your admin pages. Have you installed an object cache plugin? (use Google to find them)

  5. Drawer
    Member
    Posted 6 years ago #

    I haven't yet, donncha, but I'm reading them.

    I finally installed Super Cache on my big blog last night, and all the Google Adsense ads today are PSAs or are in another language. I guess Adsense can't read html, good for them.

    I don't see this problem listed, but have you come across this before, or have a solution?

    Thanks again.

  6. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Drawer - I use wp-super-cache on all my blogs and haven't seen that problem with Adsense.

  7. Drawer
    Member
    Posted 6 years ago #

    You are right, donncha.

    After more searching, this is an unusual problem. I'm using MistyLook, which I think is kind of a frame. I'm hoping that isn't the problem.

    I see that all my older posts, like a month ago, all show adsense fine. Just the newer ones that Super Cache saved, have bad Adsense, and are other languages and PSAs.

    Also, when I look in my htaccess file, everything looks like your Mod Rewrite Rules.

    But in wp-content/uploads, I noticed advanced-cache.php and wp-cache-config.php have permissions of 644, so I changed to 755. Could that have been the problem? Adsense takes at least a day or two to readjust itself, so I won't know if that was it, or turn Super Cache back on until you have a chance to look at this. I'm also waiting for my server to call back, to check on the compression thing.

  8. Drawer
    Member
    Posted 6 years ago #

    Donncha:
    I even called corporate for my server to help me figure this out, and a tech guy is trying SC on his own blog now.

    Here is what I see inside the bowels of my infernally slow File Mgr on my server: I can see wp-content/cache/my cached posts fine. If I click on them, the page is ok, and adsense ads are ok.

    However here is where Super Cache goes: my_blog/wp-content/cache/supercache/mywebsite.com/myblog/2008/04/13/name-of-my-post/index.html, and when I click on that I can see the post when I drill down - and I do mean drill-, but the adsense ads come up another language. Is this where super Cache is supposed to go?

    All permissions are correct. Compression is disabled. Can you please help me, because I really want this to work!

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic