WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Website doesn't display when cache is on (8 posts)

  1. jpw94
    Member
    Posted 1 year ago #

    When I enable cache with WP Super Cache, my website does not display correctly.
    I turn it off, and all is good.

    Any help would be appreciated.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Check your php error log, also use the debug log in the plugin as that may reveal what went wrong.

    Try using PHP mode caching.

  3. jpw94
    Member
    Posted 1 year ago #

    I did change to PHP mode caching. same result.

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Did you try all the tips suggested in the Troubleshooting section of the plugin documentation?

  5. Yaniv Harush
    Member
    Posted 1 year ago #

    i have the same problem. i run a multisite installation and every time i enable the plugin i get a 500 error or just a blank page.
    this happens to the admin pages and the site itself.

    to unable the plugin i have to remove the define('WP_CACHE', true); from the config file and then deactivate the plugin.

    i have another site in the same server, not a part of a multisite, and the plugin works fine there.

    both sites running under nginx server, with varnish.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    spartacus - anything in your PHP error log?

  7. Yaniv Harush
    Member
    Posted 1 year ago #

    Hi Donncha,

    these are the errors i get when the plugin is on: (i changed the ip and domain)

    2012/08/09 15:07:49 [error] 3387#0: *488543 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 124.43.132.12, server: mydomain.com, request: "POST /wp-admin/admin-ajax.php HTTP/1.1", upstream: "fastcgi://unix:/tmp/php-fpm.sock:", host: "www.mydomain.com", referrer: "http://www.mydomain.com/path-to-page/"

    2012/08/09 15:10:50 [error] 3384#0: *492364 readv() failed (104: Connection reset by peer) while reading upstream, client: 124.43.132.12, server: mydomain.com, request: "GET /stories/story-title/ HTTP/1.1", upstream: "fastcgi://unix:/tmp/php-fpm.sock:", host: "www.mydomain.com"

    is there any nginx/multisite configuration you recommend using with your plugin?
    are you going to update the plugin to full support nginx? (in the cache options there's only apache mod_rewrite, php and legacy)

    thanks in advance for your help.

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Unfortunately Nginx never worked right for me which is why I'm using Apache and Varnish. Not quite as fast but my site doesn't get a lot of traffic any more.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic