WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Way to limit Cache Size? (3 posts)

  1. rrhobbs
    Member
    Posted 5 years ago #

    I keep getting disk warnings from my host - the more storage quota I give my site, the more it seems to cache - started at 300mb , still not enough at 500mb. Way to limit Cache Size? Set really short expiry? ??? thx

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Just set the expiry time really low and then make it longer until you're using (on average) the amount of space you want.

  3. ddmdllt
    Member
    Posted 5 years ago #

    Setting the expiry time low is not always the best choice, because there is no warranty at all that the cache won't grow in huge proportions after the visit of a bot (some bad bots don't give anything relevant in the User-Agent field, and they can crawl an entire blog very quickly).

    I think a good feature in WP Super Cache would be the possibility to limit the number of pages a single "user" (or rather a single IP) can cause to put into cache (before expiry time).

    Since I didn't see anywhere this feature, I use a trick which is to disable caching of the pages containing the following strings in the URL :
    * '/2008/0'
    * '/2007/'
    * '/pages/' (for '/pages/2', '/pages/3', etc... In fact I'm not sure that is is really necessary)

    This is not the recommended setting for every blogger, before deciding such settings one should have a look at some web analytics software.

Topic Closed

This topic has been closed to new replies.

About this Topic