WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Warning that "pages do not match. timestamps differ" (52 posts)

  1. nickaster
    Member
    Posted 3 years ago #

    yeah, I loaded it and left the "debug" checked .... with my email address in the slot. It's been like that for days, I have not gotten any email. Blog's been loaded thousands of times.... what do you think I'm doing wrong?

  2. Donncha O Caoimh
    Member
    Posted 3 years ago #

    I don't know. There's obviously something wrong but you might have to dive into the code yourself to figure it out.

    Have you read through the readme and all the troubleshooting tips?

  3. nickaster
    Member
    Posted 3 years ago #

    Okay thanks! well, now it just started sending me messages. Don't know why it took so long.

    Here's a sample of what I've gotten (3 of these over the night)

    Cache Expiry cron job took more than 30 seconds to execute.
    You should reduce the Expiry Time in the WP Super Cache admin page
    as you probably have more cache files than your server can handle efficiently.

    Disable these emails by commenting out or deleting the line containing
    $wp_cache_debug_email in wp-content/wp-cache-config.php on your server.

    But I don't think that has anything to do with this "timestamp" issue. Though it would imply that the supercache is working no? (My expiry is set to 300 and there are only about 100 pages cached right now)

  4. f0rud
    Member
    Posted 3 years ago #

    I get the same error here, but the log is different.

    06:39:08 /564/a-small-tip-in-php/ supercache dir: ...../cache/supercache/cyberrabbits.net/564/a-small-tip-in-php/
    06:39:08 /564/a-small-tip-in-php/ No wp-cache file exists. Must generate a new one.
    06:39:09 /564/a-small-tip-in-php/ In WP Cache Phase 2
    06:39:09 /564/a-small-tip-in-php/ Setting up WordPress actions
    06:39:09 /564/a-small-tip-in-php/ Created output buffer
    06:39:09 /564/a-small-tip-in-php/ supercache dir: ....../cache/supercache/cyberrabbits.net/564/a-small-tip-in-php/
    06:39:10 /564/a-small-tip-in-php/ Output buffer callback
    06:39:10 /564/a-small-tip-in-php/ supercache dir: ....../cache/supercache/cyberrabbits.net/564/a-small-tip-in-php/
    06:39:10 /564/a-small-tip-in-php/ Anonymous user detected. Only creating Supercache file.
    06:39:10 /564/a-small-tip-in-php/ supercache dir: ....../wp-content/cache/supercache/cyberrabbits.net/564/a-small-tip-in-php/
    06:39:10 /564/a-small-tip-in-php/ Gzipping buffer.
    06:39:10 /564/a-small-tip-in-php/ Writing non-gzipped buffer to supercache file.
    06:39:10 /564/a-small-tip-in-php/ Writing gzipped buffer to supercache file.
    06:39:10 /564/a-small-tip-in-php/ Renamed temp supercache file to ..../wp-content/cache/supercache/cyberrabbits.net/564/a-small-tip-in-php/index.html
    06:39:10 /564/a-small-tip-in-php/ Renamed temp supercache gz file to ...../wp-content/cache/supercache/cyberrabbits.net/564/a-small-tip-in-php/index.html.gz
    06:39:10 /564/a-small-tip-in-php/ Writing gzip content headers. Sending buffer to browser

    The problem is, the cache generated, (OK) the file is there, but with any new request, the plugin create cache again and I see the above note again and again in log file.
    I think there is problem with IIS , (I use PHP option, not mod_rewrite or legacy )
    any idea how I can fix this? even with editing plugin to work with IIS ..
    Thanks

  5. Donncha O Caoimh
    Member
    Posted 3 years ago #

    nickaster - looks like files are generated (slowly), but that's unrelated. For some reason cache files aren't being served. Same for f0rud.

    If either of you have the ability, check out wp-cache-phase1.php and debug it with error_log() or mail() commands to see what's happening.

  6. f0rud
    Member
    Posted 3 years ago #

    It must be a meta file per every cache ?
    I change the code a bit (on serve function):

    $tmp=wp_super_cache_init() ;
        extract( $tmp );
    
        foreach ($tmp as $_kk=>$_vv){
            wp_cache_debug( "(Mine)=>$_kk :  $_vv", 5 );
        }

    and the result is :

    08:24:08 /564/a-small-tip-in-php/ (Mine)=>key :  221fa6f46b2eed9ea4f78b57633b1259
    08:24:08 /564/a-small-tip-in-php/ (Mine)=>cache_filename :  wp-cache-221fa6f46b2eed9ea4f78b57633b1259.html
    08:24:08 /564/a-small-tip-in-php/ (Mine)=>meta_file :  wp-cache-221fa6f46b2eed9ea4f78b57633b1259.meta
    08:24:08 /564/a-small-tip-in-php/ (Mine)=>cache_file :
    08:24:08 /564/a-small-tip-in-php/ (Mine)=>meta_pathname :

    No cache file and no meta path name. Why? is this ok?
    I'm going to check other functions.
    Any advice on where I should lock?

  7. f0rud
    Member
    Posted 3 years ago #

    I fix my problem.
    There is
    $wp_cache_slash_check=1;
    In my wp-cache-config.php file. but in
    wp_cache_serve_cache_file()
    function, its undefined! (I know its a global variable and there is a global declare of this in begin of function but ....)
    And since I use 404 handler instead of .htaccess file, the last check fail :) so I set $wp_cache_slash_check=1; in begin of the function and anything is ok right now.

  8. Donncha O Caoimh
    Member
    Posted 3 years ago #

    That's weird, but glad you figured it out!

  9. shagazulu
    Member
    Posted 3 years ago #

    ok, I've got the timestamp problem as well... "The pages do not match! Timestamps differ or were not found!" It's a virgin install, virgin database, with the default 3.0 wordpress theme, and no other plugins except Super Cache in PHP mode... WordPress is installed in a sub-directory called /test.

    And all it does is keep creating a new cache file with every request.

    Help is much appreciated!

    (here is part of the log file, representing 1 click of my "about" page:}

    01:36:31 /test/about Cookie detected: wordpress_logged_in_a1001be836d0d517b8bd189616e4f9a7
    01:36:31 /test/about supercache dir: ... /test/about/
    01:36:31 /test/about Cookie detected: wordpress_logged_in_a1001be836d0d517b8bd189616e4f9a7
    01:36:31 /test/about No wp-cache file exists. Must generate a new one.
    01:36:32 /test/about Cookie detected: wordpress_logged_in_a1001be836d0d517b8bd189616e4f9a7
    01:36:32 /test/about In WP Cache Phase 2
    01:36:32 /test/about Setting up WordPress actions
    01:36:32 /test/about Created output buffer
    01:36:32 /test/about Cookie detected: wordpress_logged_in_a1001be836d0d517b8bd189616e4f9a7
    01:36:32 /test/about Output buffer callback
    01:36:32 /test/about supercache dir: ... /test/wp-content/cache/supercache/xxxxxx/test/about/
    01:36:32 /test/about Cookie detected: wordpress_logged_in_a1001be836d0d517b8bd189616e4f9a7
    01:36:32 /test/about Cookie detected: wordpress_logged_in_a1001be836d0d517b8bd189616e4f9a7
    01:36:32 /test/about Not caching for known user.
    01:36:32 /test/about supercache dir: ... /test/wp-content/cache/supercache/xxxxxxx/test/about/
    01:36:32 /test/about Sending buffer to browser
    01:36:32 /test/about Writing meta file: ... /test/wp-content/cache/meta/wp-cache-e3eaf54e190d4d60c45dbde807c87aa5.meta

  10. Donncha O Caoimh
    Member
    Posted 3 years ago #

    That's you, logged in. What does a request from an "unknown user" look like? Both generating a cache file and serving it.

  11. shagazulu
    Member
    Posted 3 years ago #

    no, that's me in a different browser not logged in. But since my first post, I've deleted my browser's cookies which has helped... but not entirely.

    So, I'm logged in using Chrome, and then going over to Firefox where I'm not logged in and browsing the webpage. It looks now as if every page is calling up the saved cache file, except the home page. The home page keeps generating a new cache file.

    here's a log of me clicking 3 times (in logged out Firefox), once on the home page, then on the about page, then on the home again. Each time I clicked on home, I got a newly generated cache file (I checked the source code, and the browser loaded up much more slowly). When I clicked on about, I got a previously cached file. Note, however, the error in the debug log below, regarding the about page... which was the one that was successfully cached.

    08:07:36 /test/ supercache dir: /test/wp-content/cache/supercache/xxxxx/test/
    08:07:36 /test/ No wp-cache file exists. Must generate a new one.
    08:07:36 /test/ In WP Cache Phase 2
    08:07:36 /test/ Setting up WordPress actions
    08:07:36 /test/ Created output buffer
    08:07:36 /test/ supercache dir: /test/wp-content/cache/supercache/xxxxx/test/
    08:07:36 /test/ Output buffer callback
    08:07:36 /test/ supercache dir: /test/wp-content/cache/supercache/xxxxx/test/
    08:07:36 /test/ Anonymous user detected. Only creating Supercache file.
    08:07:37 /test/ supercache dir: /test/wp-content/cache/supercache/xxxxx/test/
    08:07:37 /test/ Writing non-gzipped buffer to supercache file.
    08:07:37 /test/ Renamed temp supercache file to /test/wp-content/cache/supercache/xxxxx/test/index.html
    08:07:37 /test/ Sending buffer to browser
    08:07:40 /test/about supercache dir: /test/wp-content/cache/supercache/xxxxx/test/about/
    08:07:40 /test/about Served page from supercache file. Mod rewrite rules may be broken or missing.
    08:07:45 /test/ supercache dir: /test/wp-content/cache/supercache/xxxxx/test/
    08:07:45 /test/ No wp-cache file exists. Must generate a new one.
    08:07:50 /test/ In WP Cache Phase 2
    08:07:50 /test/ Setting up WordPress actions
    08:07:50 /test/ Created output buffer
    08:07:50 /test/ supercache dir: /test/wp-content/cache/supercache/xxxxx/test/
    08:07:50 /test/ Output buffer callback
    08:07:50 /test/ supercache dir: /test/wp-content/cache/supercache/xxxxx/test/
    08:07:50 /test/ Anonymous user detected. Only creating Supercache file.
    08:07:50 /test/ supercache dir: /test/wp-content/cache/supercache/xxxxx/test/
    08:07:50 /test/ Writing non-gzipped buffer to supercache file.
    08:07:50 /test/ Renamed temp supercache file to /test/wp-content/cache/supercache/xxxxx/test/index.html
    08:07:50 /test/ Sending buffer to browser

  12. seriousthings
    Member
    Posted 3 years ago #

    Problem fixed on my end by removing: ob_start("ob_gzhandler");

    so now my page is cached, but uncompressed (windows server).

    The compression is helping me much more than the cache... need to get onto a linux server.

  13. saamxvr1
    Member
    Posted 3 years ago #

    i Found Problem My site Work fine.!! Timestamps differ or were not found ;-)

    Plz try with test Wp Super cache plugin WordPress Default themas , you problem will solved :-)

    Enjoy.!!

  14. yohansen79
    Member
    Posted 3 years ago #

    Check the permissions on "wp-content/cache/"!

    We are running WordPress 3.1, WP Super Cache 0.9.9.6 & Windows Server 2003 and although Super Cache appeared to be serving cached pages - I could see the "Dynamic page generated" & "Cached page generated" comments in the HTML source - I couldn't quite believe it as the cached page generation time was always the current time!

    Plus debugging mode showed the same messages as shagazulu was getting above.

    And whats with all those random name TMP files in "wp-content/cache/"?
    Well, Super Cache is meant to re-name those to ".html", which ties in with the mod_rewrite thats occurring in the .htaccess file in the root of your install.

    The up-shot?
    You need to add modify (as well as write) permissions to the "wp-content/cache/" directory. So, for IIS that is your Internet Guest Account (IUSR) account.
    And to know that Super Cache is serving these cached files, you should see something like this in debugging:

    18:54:11 /en/ wp-cache file exists: C:\inetpub\wwwroot\XXX\en\wp-content\cache\wp-cache-7eb37da74eb275522b441bca7bc4d02e.html
    18:54:11 /en/ Serving wp-cache static file
    18:54:11 /en/ exit request

    Otherwise it aint happening!

  15. lauraupcott
    Member
    Posted 3 years ago #

    I'm also getting the "pages do not match. timestamps differ" error. My site is installed in a sub-directory. I don't understand most of the solutions people have suggested in the previous 44 posts. I'm getting the picture that WP Super Cache needs to be installed by a expert. What the best way to go about hiring someone to solve a problem like this?

  16. lauraupcott
    Member
    Posted 3 years ago #

    I think I found a solution: In the Advanced tab I selected "Use mod_rewrite to serve cache files. (Recommended)" Now the error message has disappeared!

  17. seriousthings
    Member
    Posted 3 years ago #

    Good job Laura! I was just going to recommend that you save your $ and do some searching around. I'm not a code monkey, but I have been able to figure out all of my challenges. I'm even learning to eat bananas. :)

    Eventually, I went to W3 Total Cache. Both products are pretty good.

    Way to go

  18. lauraupcott
    Member
    Posted 3 years ago #

    Seriousthings: thanks so much for your encouraging words.

    WP Super Cache is working great for me know. I just did a vertain.com speed test to compare the speed of my site with caching on vs. caching off. My site loads 7.50 seconds faster with the caching turned on. That totally justifies the time spent troubleshooting WP Super Cache. But it's nice to know that I could try W3 Total Cache as an alternative.

  19. schmackLab
    Member
    Posted 3 years ago #

    So I get the error that my test pages don't match but when I actually check the time stamps while loading the site they are the same.

    I am assuming that everything is actually working but how can I know for sure?

    It's kind of imperative as a couple of my sites went down today for traffic when the plugin was disabled.

  20. randallwkowalenkoinc
    Member
    Posted 3 years ago #

    Hellooo...

    Ok, so here was how I resolved the problem getting the error "The pages do not match! Timestamps differ or were not found!".

    I was setting up a new blog, where I installed the new version of WP Super Cache (version 0.9.9.7), where I was copying the custom permalink info off of another older WordPress blog which has WP Super Cache version 0.9.9.3 installed.

    In the older WordPress blog I have the custom permalink field set to "/%category%/%postname%.html".

    When I copied the information into the new blog, which I have installed the newer 0.9.9.7 version of WP Super Cache, the test would not pass, giving me the error "The pages do not match! Timestamps differ or were not found!".

    I played around with it for a little while, and realized that adding the customer field as "/%category%/%postname%/", (which removed the ".html", and added a "/" forward slash at the end of the text as you can see) was the solution. The 'Test Cache' ran through correctly then, and says "The timestamps on both pages match!"

    Problem now solved!

    I hope this helps someone else since it took me a little time to figure it out.

  21. simon20080214
    Member
    Posted 3 years ago #

    ok, I solved it as follow:

    change 'caching' from 'use PHP...' to 'USE mod_rewrite..." to solve this case

    possible cause: static link way or other post way had been changed many times ,so use mod_write can resolve this case

  22. Eric
    Member
    Posted 3 years ago #

    Using WP Super Cache 0.9.9.8 on WP 3.0.4 and ran into the same "The pages do not match! Timestamps differ or were not found!" message. This was on a brand new fresh install with no other plugins running. I set this up purely to test WP Super Cache.

    Following the trail left by @randallwkowalenkoinc I modified the permalink format. In my case I changed "/archives/%post_id%" to "/archives/%post_id%/" (the only change is that trailing "/"). Now the Test Cache results in "The timestamps on both pages match!"

    Thanks, @randallwkowalenkoinc! I wonder if the maintainers of WP Super Cache could make the plugin more forgiving of permalinks without trailing slashes?

Topic Closed

This topic has been closed to new replies.

About this Topic