WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Warning that "pages do not match. timestamps differ" (52 posts)

  1. emilychang
    Member
    Posted 4 years ago #

    Hi, I've finally installed the plugin and gotten around the wp-cron.php issues on Media Temple.

    Thought everything was working, but when I go to test the cache, I get this error:

    Cache Tester
    Test your cached website by clicking the test button below.
    Fetching http://mysite.com to prime cache: OK
    Fetching first copy of http://mysite.com: OK
    Fetching second copy of http://mysite.com: OK
    The pages do not match! Timestamps differ or were not found!

    How do I fix this?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Use the debug system in the plugin to figure out why it's not working. That will help you a lot.

  3. gouffy41
    Member
    Posted 4 years ago #

    Hi,

    Same issue here and debug system dont work.

    How to fix this?

    Thansk

  4. Donncha O Caoimh
    Member
    Posted 4 years ago #

    gouffy41 - how doesn't the debug system work? Are you logging to a file?

  5. gouffy41
    Member
    Posted 4 years ago #

    donncha-now debug system is ok.
    But always this message with cache tester:
    The pages do not match! Timestamps differ or were not found!

  6. BeddgelertWoodcraft
    Member
    Posted 4 years ago #

    Same here. I am getting a lot of; No closing html tag. Not caching.
    But the tag is there when I view source.

    @donncha as you posted http://wordpress.org/support/topic/366668?replies=2

    You may have upgraded a plugin that uses the output buffer. Like the message says, check your plugins for ob_start.

    I searched the plugins and found ob_start to be in WP-Ecommerce plugin, which is a pretty important part of my site.

    WP 3.0, WP-Ecommerce 3.7.6.2

  7. gouffy41
    Member
    Posted 4 years ago #

    @donncha - no error message in the debug logs and always this message with cache tester:
    The pages do not match! Timestamps differ or were not found!

  8. BeddgelertWoodcraft
    Member
    Posted 4 years ago #

    Moving to W3 to see if thatt helps.

  9. Donncha O Caoimh
    Member
    Posted 4 years ago #

    gouffy41 - did you try checking manually? When you reload the page on a browser that isn't logged in does the timestamp change? If not, can you help debug the problem?

    Open up wp-cache.php and look for the "Timestamps differ or were not found" string. Dump the contents of each page to a file using error_log and see if each page has the timestamp.

  10. gouffy41
    Member
    Posted 4 years ago #

    Thanks @donncha - i've this error message :

    Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory.

  11. tmaster
    Member
    Posted 4 years ago #

    I am getting the same error. After running for a day it started passing the test on one install. I have just installed it on a second directory and am getting the error again.

    On both installs I get no errors in the log but when reloading the page it goes into half mode.

  12. Donncha O Caoimh
    Member
    Posted 4 years ago #

    gouffy41 - follow that advice, you need to find whatever other plugin is misbehaving.

  13. dgv76
    Member
    Posted 4 years ago #

    Please help I get this error: The pages do not match! Timestamps differ or were not found! I tried disabling plugins, but it did no help, debugging did not help, reinstall did not help.

    Thank you

  14. DDT
    Member
    Posted 4 years ago #

    same here
    -disabled all plugins
    - still getting the error "The pages do not match! Timestamps differ or were not found!"

    looking into the log file i see:

    Output buffer callback
    404 file not found not cached
    No closing html tag. Not caching.

    What can i do

  15. davidkurniawan
    Member
    Posted 4 years ago #

    disable another compression plugin . In my case : problem solved after
    WP HTTP Compression deactivated!

  16. cabanacriacao
    Member
    Posted 4 years ago #

    "blank page of death" all the time since I upgraded to
    WP 3.0
    No plugins installed.
    No log errors at all on my server.

    Cache Tester
    Test your cached website by clicking the test button below.
    Fetching http://mysite.com to prime cache: OK
    Fetching first copy of http://mysite.com: OK
    Fetching second copy of http://mysite.com: OK
    The pages do not match! Timestamps differ or were not found!

    Debbug:
    Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory.

    But as I said. No plugins installed.

    I´ve already tested I think ALL possible solutions I found. Next step is kill the DB and star from the scratch!

    Is there any way to remove the timestamps?

  17. slexo
    Member
    Posted 4 years ago #

    I was getting "The pages do not match! Timestamps differ or were not found!" message too when using the Cache Tester.

    Even with "Don’t cache pages for known users. (Logged in users and those that comment)" unchecked I was getting the error when using the Cache Tester.

    I tested it manually and found it is working perfectly. Thanks for the tip donncha.

  18. djchuang
    Member
    Posted 4 years ago #

    On my installation of WP Super Cache 0.9.9.3 with WordPress 3.0 (multi-site), the error message at the bottom of my generated page was:

    WP Super Cache is installed but broken. The path to wp-cache-phase1.php in wp-content/advanced-cache.php must be fixed!

    Now, the main line in advanced-cache.php is:

    @is_file( 'CACHEHOME' . 'wp-cache-phase1.php' )

    How would I change the path to wp-cache-phase1.php then? I'd have to reset the CACHEHOME variable?

  19. Donncha O Caoimh
    Member
    Posted 4 years ago #

    How did you install the plugin? That CACHEHOME string is supposed to be a path to your supercache plugin directory. It's installed by wp-cache.php

  20. djchuang
    Member
    Posted 4 years ago #

    I just re-installed the plugin to make sure I remember how I installed. I used the WP Dashboard built-in "Add New" plugin, selected WP Super Cache, did a Network Activiate, and then went to WP Super Cache Manager. Changed Status to "HALF ON", clicked Update Status. Then clicked on "Test Cache". Same error message

    Test your cached website by clicking the test button below.

    Fetching http://xyzsample.us to prime cache: OK

    Fetching first copy of http://xyzsample.us: OK

    Fetching second copy of http://xyzsample.us: OK

    The pages do not match! Timestamps differ or were not found!

    However, this time around, the bottom of the generated page says things are ok:

    <!-- Dynamic page generated in 1.018 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2010-07-17 09:04:07 -->

    Okay, good by me, even tho' the test part timestamp isn't working. Thanks for reply.

  21. andybritnell
    Member
    Posted 4 years ago #

    Hi Guys

    I have loaded up this Plug-in and it looks like it has worked (the site seems faster and cached pages appear in my files) but I get this message:

    The pages do not match! Timestamps differ or were not found!

    The debug message says: URI rejected. Not Caching

    Any ideas - site is http://www.leadinganddevelopinghighperformance.com

    Many thanks

    Andy

  22. dajuan
    Member
    Posted 4 years ago #

    I have the same test cache response:"The pages do not match! Timestamps differ or were not found!" on one of two WP installs in the same domain.

    The install in the blog directory passes (matches)(ex. http://www.dajuanjones.com/blog/ ).

    However, the install in the 'wordpress' directory whose URL is the root does not pass (ex. http://www.dajuanjones.com ). In the later, I gave that WP install it's own directory. The 'test cache' tested http://www.dajuanjones.com/wordpress, which doesn't exist. Donncha, is that expected behavior for this type of WP install?

  23. Donncha O Caoimh
    Member
    Posted 4 years ago #

    There's something weird with blogs where WP is installed in a subdirectory. The plugin tries to load site_url() which should point at the right place. When I have time I'm going to replicate that setup!

  24. wdypdx222
    Member
    Posted 4 years ago #

    I'm having the same issue with "The pages do not match! Timestamps differ or were not found!"

    Here are the debug log entries being emailed to me:

    • Writing meta file: /home/me/mysite.com/wordpress/wp-content/cache/meta/wp-cache-text#string.meta
    • URI rejected. Not Caching
    • 404 file not found not cached
    • gc: deleted /home/etc/etc... (A bunch of these)
    • Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory. There is no 'ob_start' there
    • No closing html tag. Not caching.
    • Anonymous user detected. Only creating Supercache file.

    I have deactivated supercache until I get this figured out. Also, I have WP in a subdirectory.

    ??

  25. Donncha O Caoimh
    Member
    Posted 4 years ago #

    I found the problem with the cache tester, it was using site_url() which returns the subdirectory. That'll be a 404. I've just changed it to "trailingslashit( get_bloginfo( 'url' )" in trunk and it works. Try the development version on the download page (other versions) to test it!

  26. arkitekt
    Member
    Posted 4 years ago #

    @donncha -- Thanks! This appears to have resolved my ongoing problem with wordpress being installed in a subdirectory but hosted at the root of the domain. I had been wondering if WP-Supercache had issues with this scenario but assumed that it was my configuration issue.

    By default we install all our sites in a subfolder and then when they are ready to launch we make it live on the root of the domain using this method: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    But we were noticing that this seemed to cause an issue with Supercache

    Thanks for your help - I will follow this thread to see the results for others and to let you know if there is anything else that is an issue.

  27. nityin
    Member
    Posted 3 years ago #

    I am getting the same - The pages do not match! Timestamps differ or were not found - message on my site http//www.himachallive.com

    The debug log entries mentions - URI rejected. Not Caching

    I am using the permalinks in http://www.himachallive.com//%postname%.html format.

    I downloaded and uploaded the developmental version of the plugin and am getting the same error.

    Is there a fix for this?

  28. nickaster
    Member
    Posted 3 years ago #

    I have the same error. Does it actually mean anything? Does it mean that SuperCache isn't working?

    Second questions - how does this debugging work? How do I get some information that might be useful? I checked it "on" and enetered my email adress, but it doesn't do anything.

    Thanks!

  29. Donncha O Caoimh
    Member
    Posted 3 years ago #

    nityin - the plugin isn't caching because of some setting you in have in the "rejected uri" field I'd guess.

    nickaster - yes, it means the plugin probably isn't working. If you didn't get any emails from the debug system did you try loading your blog while debugging was on?

  30. nickaster
    Member
    Posted 3 years ago #

    yeah, I loaded it and left the "debug" checked .... with my email address in the slot. It's been like that for days, I have not gotten any email. Blog's been loaded thousands of times.... what do you think I'm doing wrong?

Topic Closed

This topic has been closed to new replies.

About this Topic