WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Unable To Post With Version 0.9.3 (48 posts)

  1. wagerrard
    Member
    Posted 5 years ago #

    Just installed 0.9.3 and I am unable to publish a new post while the plugin is activated.

    WordPress displays this message:

    "Your attempt to edit this post: "test" has failed."

    Playing with the settings has no impact, and I've verified that none of my other plugins are the culprit by deactivating all but Super-Cache.

    Also, the cache settings page displays with "Cache rebuild" checked. A mistake or a new default?

  2. perrydc
    Member
    Posted 5 years ago #

    I'm seeing a related problem, which just happened after updating to 0.9.3. While it's letting me post, I'm getting the following error every time I hit publish:

    Warning: opendir(/home/content/p/e/r/perrydc/html/wordpress/wp-content/cache/meta/) [function.opendir]: failed to open dir: No such file or directory in /home/content/p/e/r/perrydc/html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 632

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/p/e/r/perrydc/html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php:632) in /home/content/p/e/r/perrydc/html/wordpress/wp-includes/pluggable.php on line 850

    ...hope this helps to diagnose!

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    wagerrard - not sure why you see that error message. The cache rebuild is on by default now for new installs as it's very stable.

    perrydc - that's odd. There should be a meta directory there! Every time? Did you visit the admin page?

  4. beernews
    Member
    Posted 5 years ago #

    Upgraded to the 4/4/09 file. When I try to save or publish a post at first, I get the same exact message as Wagerrard. Even though I post a few lines and WordPress saves the post automatically just fine. However, if I go back to the post, and save or publish, I dont see the same message, it saves/publishes just fine.

    This occurs on half on and off settings as well as when cache rebuild is turned off.

    It stops if I deactivate the plugin.

    I also cant do anything with my referral stats. Pages just load but once I deactivate, the stats charts once again load.

    I don't do this to complain so much as I hope this info leads to a solution. We appreciate your hard work on this plugin, Donncha.

  5. steff3107
    Member
    Posted 5 years ago #

    Hey!

    I have the same problem like perrydc every time I save a post or page. It seems as if the post/page is saved correctly in background.

  6. wagerrard
    Member
    Posted 5 years ago #

    OK, I slapped myself and viewed the source of the error page WP showed me when i tried to post. In there I found this:

    "<!-- WP Super Cache is installed but broken. The path to wp-cache-phase1.php in wp-content/advanced-cache.php must be fixed! -->

    That's from advanced-cache.php

    However, the path in the code is correct. Here it is:

    `if( !include_once( '/users/home/wagerrard/web/public/wp-content/plugins/wp-super-cache/' . 'wp-cache-phase1.php' ) ) register_shutdown_function( 'wpcache_broken_message' );'

  7. Tonohono
    Member
    Posted 5 years ago #

    If it's of any use to know, commenting out the line
    wp_enqueue_script('autosave');
    in wp-admin/post-new.php seems to solve the "Your attempt to edit this post: "test" has failed." error.

  8. Donncha O Caoimh
    Member
    Posted 5 years ago #


  9. cgh
    Member
    Posted 5 years ago #

    I've seen the same issue crop up on first-time saves (though the autosave works correctly in the background, so I lose nothing but maybe the last few characters I'd typed in).

    I did have a site move the night before, but inasmuch as the plugin found the new path correctly (and it's correct in advanced-cache.php), I don't think that's the issue.

    Whatever is going on, I'm pretty sure it will be fixed in 0.9.4.

  10. jeffqc
    Member
    Posted 5 years ago #

    i have the same issue as perry

    Warning: opendir(/home/stripper/public_html/tvqc.com/wp-content/cache/meta/) [function.opendir]: failed to open dir: No such file or directory in /home/stripper/public_html/tvqc.com/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 632

    Warning: Cannot modify header information - headers already sent by (output started at /home/stripper/public_html/tvqc.com/wp-content/plugins/wp-super-cache/wp-cache-phase2.php:632) in /home/stripper/public_html/tvqc.com/wp-includes/pluggable.php on line 850

  11. josephcrotty
    Member
    Posted 5 years ago #

    Ditto.

    Warning: opendir(/home/catholic/public_html/wp-content/cache/meta/) [function.opendir]: failed to open dir: No such file or directory in /home/catholic/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 632

    Warning: Cannot modify header information - headers already sent by (output started at /home/catholic/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php:632) in /home/catholic/public_html/wp-includes/pluggable.php on line 850

  12. Donncha O Caoimh
    Member
    Posted 5 years ago #

    To stop the opendir warning, you should turn off "Display errors in your php.ini and download this file and copy into your plugins/wp-super-cache/ folder. It will overwrite the one already there.

  13. Donncha O Caoimh
    Member
    Posted 5 years ago #

    I have this fixed. Grab the development version from the download page in about 15 minutes from the date of this post (must wait for it to update). Copy the unzipped files into your plugins/wp-super-cache/ folder.

    Optionally, or preferably, you should delete wp-content/advanced-cache.php or make wp-content writeable (chmod 777 wp-content is the easiest way) and visit the admin page where a new advanced-cache.php will be generated.

    If all works, I'll release a 0.9.3.1 tomorrow with those fixes.

  14. Tonohono
    Member
    Posted 5 years ago #

    Current trunk seems to be working just fine, thanks for the fixes.

  15. wagerrard
    Member
    Posted 5 years ago #

    Donncha, I tweaked the permissions on advanced-cache.php from 644 to 777 and twiddled with the admin page, as well as just deleting the file. I got the same failure to post error I mentioned earlier, claiming that wp-cache-phase1.php isn't where its supposed to be.

    Ditto when I installed the development release.

    The posts in question are saved as drafts and will subsequently publish successfully.

    For the record, I've seen no opendirs messages.

  16. Donncha O Caoimh
    Member
    Posted 5 years ago #

    wagerrard - comment out the line that says, "WP Super Cache is installed but broken. ..." in wp-content/advanced-cache.php - does that fix it?
    Is there a check for wp-admin in the REQUEST_URI before it?

  17. misthero
    Member
    Posted 5 years ago #

    same error here when publishing:

    Warning: opendir(/home/stripper/public_html/tvqc.com/wp-content/cache/meta/) [function.opendir]: failed to open dir: No such file or directory in /home/stripper/public_html/tvqc.com/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 632

    I'm waiting for an update, meanwhile i've had to disable Super Cache..

    good plugin anyway

  18. Donncha O Caoimh
    Member
    Posted 5 years ago #

    misthero - please try the dev version on the download page I linked to a few posts above. I need more feedback as it didn't work for wagerrard for some reason.

  19. misthero
    Member
    Posted 5 years ago #

    ok the dev version worked for me, i've simply overwritten th wp super cache folder and reactivated it. I've tried to publish a new article and everything seems working fine right now. no more error messages.

    I don't know if it could be important but this was my configuration for super cache when it gave me the error:

    ON: WP Cache and Super Cache enabled
    ACTIVED: Clear all cache files when a post or page is published. (This may significantly slow down saving of posts.)

    all other options in "WP Super Cache Status" where OFF. (even cache rebuild)

    the rest was at default settings.

    same settings now and it works.
    thank you.

  20. Donncha O Caoimh
    Member
    Posted 5 years ago #

    misthero - thanks! Appreciate you taking the time to test it!

  21. wagerrard
    Member
    Posted 5 years ago #

    donncha, commenting out that line does eliminate the error display and allows new posts to publish. You'll have to help me with the REQUEST_URI bit, though. I'm not a coder. If I should see it in advanced-cache.php, though, its not there.

    My settings: ON (Cache and Super Cache enabled), Cache rebuild on, compression on. The rest is the default.

    Thanks very much for the plugin and the attention to it. My site's on a shared server and being able to serve static pages is a very good thing indeed.

  22. Tonohono
    Member
    Posted 5 years ago #

    Since you don't see REQUEST_URI in advanced-cache.php, you may not have the development version. Uninstall the current version of wp-super-cache, grab the dev version here or here, and install. Afterwards, verify your advanced-cache.php matches this one:
    http://svn.wp-plugins.org/wp-super-cache/trunk/advanced-cache.php

  23. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Tonohono - thanks for responding!

    I'm not going to force updating of the advanced-cache.php because this bug will only affect people who installed the plugin over the weekend, not those upgrading.
    I'll update my blog post and other forum post with instructions to remove the wp-content/advanced-cache.php and visit the admin page.

  24. wagerrard
    Member
    Posted 5 years ago #

    Pretty sure I had the development release. I pulled it down from the link on the download page. Gremlins, maybe.

    Nonetheless, I deactivated, deleted, and reinstalled and all seems well. Advanced-cache.php matches what's in the trunk.

    Thanks.

  25. wagerrard
    Member
    Posted 5 years ago #

    donncha, thanks for working through this. Apologies for what must have been my mistake with the development release.

  26. Shyzer
    Member
    Posted 5 years ago #

    Hey folks, I just wanted to say thanks for working this out. I switched servers last night and have been squashing bugs all morning long. In the process of switching, I had upgraded to 0.9.3 and started getting the "you can't post" error. Had this thread not existed, I might have gone mad with trying to track down the source of the problem! I just grabbed 0.9.3.1 and all is well again.

  27. perrydc
    Member
    Posted 5 years ago #

    Wow. I can't believe you got a fix in that fast! Smooth sailing on my site. Thanks!

  28. cgh
    Member
    Posted 5 years ago #

    Deactivated, overwrote the old files with the new ones, reactivated. Seems to work fine now.

  29. bekar09
    Member
    Posted 5 years ago #

    Hi,
    I'm using WP 2.7.1 and WP Super Cache 0.9.6(upgraded recently). I'm having the same problem-- "Your attempt to edit [post_title} has failed. Please try again".

    I tried both 'Half On' and 'On' mode, but same problem.

    donncha please suggest. should i delete the plugin and install a fresh copy and try? or there's any quick fix for this?

  30. bekar09
    Member
    Posted 4 years ago #

    I noticed that I'm having the problem when I disable caching for logged in users. guys can somebody post the best(optimum) settings for this plugin to get the best results?

Topic Closed

This topic has been closed to new replies.

About this Topic