WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] Unable to edit/save/delete posts since installing Super Cache (5 posts)

  1. pinkbeats
    Member
    Posted 5 years ago #

    Using WordPress 2.7.1

    The plugin seems to work fine, any ideas as I've got some posting to do! I'm wondering if it's anything to do with the .htaccess files but any help in troubleshooting this gratefully received.

    Just to add - when I try to delete or save an edit to a post, even a quick edit, the screen comes up blank.

    Thanks.

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Anything in your PHP error log? (Before you ask, No, I don't know where that file is on your system)

  3. pinkbeats
    Member
    Posted 5 years ago #

    Thanks for the quick reply - I've done some troubleshooting and the problem is to do with the .htaccess file in the root directory of my blog. I disabled all my plugins and deleted the .htaccess file from the server and I could then edit & save posts - once I reactivated all the plugins including Super Cache, the error re-asserted itself.

    The code in my .htaccess is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /myblogname/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /myblogname/index.php [L]
    </IfModule>
    # END WordPress
    
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /myblogname/
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/myblogname/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/myblogname/$1/index.html.gz [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/myblogname/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/myblogname/$1/index.html [L]
    </IfModule>
    # END WPSuperCache

    I will have a look for my php log and see if anything is in it.

  4. pinkbeats
    Member
    Posted 5 years ago #

    I have loads of the error below in my logs - is it relevant?

    PHP Warning:  Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/home/users/web/bxxxx/sl.tiptopmu/public_html/cgi-bin/tmp) in Unknown on line 0
    PHP Warning:  Unknown(): open(/home/users/web/bxxxx/sl.tiptopmu/public_html/cgi-bin/tmp/sess_769531b78a99fe9644f0d12ed1a5aaf2, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    I also saw that my host is running PHP4 as a default rather than PHP5 but this is unrelated as WordPress runs fine on PHP4.1 or higher.

  5. pinkbeats
    Member
    Posted 5 years ago #

    Actually that seems to be it - I can now save edits to posts so it must be related to my host running PHP4 as default rather than PHP5 - will do some more testing just to make sure, gotta couple of posts to finish and publish.

Topic Closed

This topic has been closed to new replies.

About this Topic