WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Unable to delete Cache in 1.0 (28 posts)

  1. Diesel12
    Member
    Posted 2 years ago #

    We are unable to delete cache. If we click the delete button in top toolbar OR go dashboard > wp super cache > contents tab > then click on Delete button .... and then view pages via different browsers or computers, the older cached pages are still served with older cache timestamps in the footer .... This is new as of our upgrade to 1.0 ... we've reinstalled to to no avail.

    Edit:

    Just read this http://wordpress.org/support/topic/plugin-wp-super-cache-delete-cache-button-problem?replies=17 ... so not sure if it's same issue or not.

    Also, we don't have "Delete Cache on all Blogs" button as indicated in that post ... and we are on multisite ...

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Diesel12
    Member
    Posted 2 years ago #

    Upgrading to dev version seems to fix issue ...

  3. Diesel12
    Member
    Posted 2 years ago #

    Correction, turning plugin off and off to upgrade to dev version deleted cache but the new dev version still has previous issue of cache not clearing when deleted....

  4. DerEineDa
    Member
    Posted 2 years ago #

    Yep, same issue here. I also updated to the development version, but this didn't help.

    I am not using a multiuser-setup, just a personal blog. Since upgrading to 1.0 (or newest development version) the "clear cache"-button at the backend doesn't do anything anymore.

  5. Diesel12
    Member
    Posted 2 years ago #

    Also seeing that updating a post does not clear cache ... The only way we have found to clear cache is by disabling and re-enabling the plugin via the dashboard > plugins ...

  6. majoga
    Member
    Posted 2 years ago #

    Same here. I found that I could show cached files on the content page and delete them 1 at a time. But it's a hassle, so I just turn off caching when I'm developing.

  7. echezuria
    Member
    Posted 2 years ago #

    I'm also having this issue. Since 1.0 update wp super cache is not deleting the WP-Cache files. Is there any way to fix this?

    Thanks in advance

  8. echezuria
    Member
    Posted 2 years ago #

    I'm downloading the development version. To check if the issue have been solved there.

  9. echezuria
    Member
    Posted 2 years ago #

    The problem persist on development version too.

  10. knivesOut
    Member
    Posted 2 years ago #

    I have this same issue as well.

    No matter how many times I click "delete cache" I still have the following..

    WP-Cache (1.44MB)
    46 Cached Pages
    0 Expired Pages

  11. JustinHorn
    Member
    Posted 2 years ago #

    I've noticed that it deletes the super cache, but not the regular cache. If you click to see cached pages, you can delete the regular cache one by one.

    Although it's easier to just go to the easy tab, disable and enable to clear it, like diesel12 mentioned earlier in this thread.

  12. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Are you using a multisite install or regular single blog install?

  13. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    I've just fixed this in the dev version but the zip file won't update for another 15 minutes. Grab wp-cache.php and copy it into wp-content/plugins/wp-super-cache/ on your server. WP-Cache files will now be deleted.

  14. Diesel12
    Member
    Posted 2 years ago #

    I'm on multisite. Still not able to update cache after updating wp-cache.php, unfortunately ....

  15. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    diesel12 - you could try using the debug system when you update a post. See what files it deletes.

  16. Diesel12
    Member
    Posted 2 years ago #

    Debugging file doesn't mention anything being deleted.

    22:31:00 /wp-admin/network/settings.php?page=wpsupercache&tab=contents Cookie detected: wordpress_logged_in_91279470b428afd65380ab3a48a1f980
    22:31:00 /wp-admin/network/settings.php?page=wpsupercache&tab=contents In WP Cache Phase 2
    22:31:00 /wp-admin/network/settings.php?page=wpsupercache&tab=contents Setting up WordPress actions
    22:31:00 /wp-admin/network/settings.php?page=wpsupercache&tab=contents Not caching wp-admin requests.
    22:31:00 / No wp-cache file exists. Must generate a new one.
    22:31:00 / In WP Cache Phase 2
    22:31:00 / Setting up WordPress actions
    22:31:00 / USER AGENT (http://www.yellowpages.com/about/legal/crawl) rejected. Not Caching
    22:31:00 / No wp-cache file exists. Must generate a new one.
    22:31:00 / In WP Cache Phase 2
    22:31:00 / Setting up WordPress actions
    22:31:00 / USER AGENT (http://www.yellowpages.com/about/legal/crawl) rejected. Not Caching

  17. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    You need to find the log results for /wp-admin/post.php which saves the post when you update it. Those are just random clicks on the supercache settings page and the front page of your blog.

  18. Diesel12
    Member
    Posted 2 years ago #

    Donncha: I'm not updating any posts to clear cache, just simply trying to clear cache via the delete cache buttons mentioned previously in the thread. You didn't indicate you wanted me to update a post, so maybe I missed something? You asked for the debugging log, which is what I posted after I clicked on the delete cache button ..... first I cleared the log so that it was empty, then deleted the cache once using the toolbar button and once using the delete cache button in the Contents section of WP Super Cache and the log results I posted are what showed up in the debugging log ....

  19. P. Chandra
    Member
    Posted 2 years ago #

    Exact same issue here since 1.0
    Cant delete wp-cache. Even after turning on and off.

    ------------
    WP-Cache (2.72MB)
    157 Cached Pages
    0 Expired Pages
    WP-Super-Cache (0KB)

    0 Cached Pages
    0 Expired Pages
    List all cached files

    Garbage Collection
    Last GC was 01:10 minutes ago
    Next GC in 08:50 minutes

    Expired files are files older than 36000 seconds.
    ----------------

  20. threeatetwo
    Member
    Posted 2 years ago #

    I have this problem, too. Will there be a 1.1 release soon?

  21. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    pchere, threeatetwo - try the development version, you may find that fixes it.

  22. G
    Member
    Posted 2 years ago #

    jumped in again using the latest dev version, the cache is updated immediately after editing a page ok, but the problem of deleting cache using the button on network admin page still remains for me.

    the cached files listed on Contents tab all disappear upon hitting Delete Cache button, but the actual files remain.

    i saw it mentioned earlier here about a multi-site define in wp-config.php, mine is an original MU install and has instead: define('VHOST', 'yes');
    dont know if that makes a difference...

    lets nail this one!

  23. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    G - so are you in the main site network admin page? and you want to delete the cached pages on ALL blogs? I need to add a check for VHOST probably as it only checks the new multisite constant now.

    If you want to clear the cache of one blog you have to visit that blog and clear the cache on it's settings page.

  24. G
    Member
    Posted 2 years ago #

    Donncha thanks for reply. i updated super-cache few times since it went 1.0 and reverted to the long standing 0.9.9.9.9 which i thought should have been the 1.0 as i found it the most stable version.
    the reason its best for me to be able to clear all blogs cache at once, is that i do updates on one site that i wish to appear on other sites instantly (through feed), so i'm used to just hitting the Delete Cache button in Network Admin settings page.
    i'm back on 0.9.9.9.9 version again as it has that funcionality. glad to test next dev version if checks for VHOST. by the way, do u think it wise to re-install WordPress using the Multisite define in wp-config.php rather than VHOST, in order to avoid possible plugin problems in future? if so, does anyone know how to do it without toasting the whole thing?
    or is best left alone? VHOST works so well right now.

  25. Diesel12
    Member
    Posted 2 years ago #

    We're also still sitting tight with .9.9.9.9.9 and not experiencing issues unless we go to dev or 1.0 ... fwiw.

  26. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    G - no need to reinstall. I added a check for VHOST yesterday in the development version if you want to give that a go.

    diesel12 - try the dev version again, many bugs have been fixed!

  27. G
    Member
    Posted 2 years ago #

    thanks a lot Donncha, that definitely resolved it for me. i see a neat new button in Network Admin Supercache Contents tab: "Delete Cache On All Blogs" - tested and works fine here!
    for those wishing to try the shiny new dev version, download here: http://downloads.wordpress.org/plugin/wp-super-cache.zip

  28. Diesel12
    Member
    Posted 2 years ago #

    D. Seems to be working. I really like the update cache when a PAGE is updated as well in addition to a post ... When managing multsite installs, I typically use the delete button in the toolbar to delete cache for all blogs, but it looks like that button is now only for deleting the blog you are on, is this correct? It would be great to have an option in the tool bar to delete all cache, especially when you're in the Network Admin section of multisite ... just a thought. :) Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic